Bedingung in der Rangfunktion

Bild

Betrifft: Bedingung in der Rangfunktion von: nika
Geschrieben am: 20.02.2005 09:52:26

Ausgangslage:
in der ersten Spalte steht die Summe der erreichten Prüfungsergebnisse für jeden Prüfling (auf 10tel genau gepunktet)
in der zweiten Spalte steht ein "nein" oder ein "ja", je nach dem, ob die Bedingungen für eine Aufnahme erreicht oder nicht erreicht sind. (die Bedingungen sind nicht nur von der Summe abhängig, sondern noch von anderen Kriterien)

Was ich nun noch machen sollte:
in der dritten Spalte sollte ich den Rang so berechnen, dass zuerst die mit "ja" rangiert werden und danach die mit "nein". Wie kann ich in die Matrix der Rangfunktion diese Bedingung einfliessen lassen ( Da nicht alle "ja" eine höhere Punktzahlen haben als die "nein" aber im Rang vor den "nein" stehen müssen)?

PS: bis jetzt löste ich das Problem mit einem Makro, das zuerst sortierte und dann mit der Funktion Anzahl2() die Rangfolge simulierte.
Ist aber nicht sehr elegant...

Bild


Betrifft: AW: Bedingung in der Rangfunktion von: OttoH
Geschrieben am: 20.02.2005 10:28:18

Hallo Nika,

hier eine Lösung mit Hilfsspalte und der Annahme, dass kein Prüfling mehr als 100 Punkte erreicht hat.

Rangfolge mit Bedingung
 ABCDE
1PunkteKommentarHilfeRang 
222ja1228 
333nein3315 
444ja1446 
555nein5513 
666ja1664 
777nein7711 
888ja1882 
999nein999 
1023ja1237 
1132nein3216 
1245ja1455 
1354nein5414 
1467ja1673 
1576nein7612 
1689ja1891 
1798nein9810 
18     
19     
20     
Formeln der Tabelle
C2 : =A2+(B2="ja")*100
D2 : =RANG(C2;$C$2:$C$17)
C3 : =A3+(B3="ja")*100
D3 : =RANG(C3;$C$2:$C$17)
C4 : =A4+(B4="ja")*100
D4 : =RANG(C4;$C$2:$C$17)
C5 : =A5+(B5="ja")*100
D5 : =RANG(C5;$C$2:$C$17)
C6 : =A6+(B6="ja")*100
D6 : =RANG(C6;$C$2:$C$17)
C7 : =A7+(B7="ja")*100
D7 : =RANG(C7;$C$2:$C$17)
C8 : =A8+(B8="ja")*100
D8 : =RANG(C8;$C$2:$C$17)
C9 : =A9+(B9="ja")*100
D9 : =RANG(C9;$C$2:$C$17)
C10 : =A10+(B10="ja")*100
D10 : =RANG(C10;$C$2:$C$17)
C11 : =A11+(B11="ja")*100
D11 : =RANG(C11;$C$2:$C$17)
C12 : =A12+(B12="ja")*100
D12 : =RANG(C12;$C$2:$C$17)
C13 : =A13+(B13="ja")*100
D13 : =RANG(C13;$C$2:$C$17)
C14 : =A14+(B14="ja")*100
D14 : =RANG(C14;$C$2:$C$17)
C15 : =A15+(B15="ja")*100
D15 : =RANG(C15;$C$2:$C$17)
C16 : =A16+(B16="ja")*100
D16 : =RANG(C16;$C$2:$C$17)
C17 : =A17+(B17="ja")*100
D17 : =RANG(C17;$C$2:$C$17)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  







Gruß OttoH


Bild


Betrifft: AW: Bedingung in der Rangfunktion von: nika
Geschrieben am: 20.02.2005 10:51:19

merci für den Tipp mit der Hilfsspalte und dem Hunderter

Ich habe es nun so gelöst:
Hilfsspalte C : C3=WENN(B3="ja";A3+100;A3) ergibt für alle mit "ja" eine Zahl über 100
Rang Spalte D:D3=RANG(B3;$B$3:$B$28;0)... bei 28 Prüflingen, sonst eben bis ans Ende der TB


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Bedingung in der Rangfunktion"