COUNTIF mit Bedingungen

Bild

Betrifft: COUNTIF mit Bedingungen
von: Hebbe
Geschrieben am: 22.02.2005 14:19:29
Hallo,
ich würde gerne einen bestimmten Text einer Spalte nur zählen, wenn eine
andere Spalte ebenfalls einen bestimmten Text enthält.
Bsp:
Zähle text "pend" in Spalte B nur wenn in Spalte A "test" steht.
Ergenbis muss in diesem Beispiel 2 sein.
A B
test pend
test close
test pend
test2 pend
test2 pend
test2 pend
test2 open
test2 pend
test2 pend
Hat jemand ne Lösung für dieses Problem
mfg
Hebbe

Bild

Betrifft: AW: COUNTIF mit Bedingungen
von: UweN
Geschrieben am: 22.02.2005 14:26:42
Hi Hebbe,
hier die Lösung:
=SUMMENPRODUKT((A1:A9="Test")*(B1:B9="Pend"))

Viele Grüße
Uwe
Bild

Betrifft: AW: COUNTIF mit Bedingungen
von: Hebbe
Geschrieben am: 22.02.2005 14:42:59
Hallo Uwe,
danke für die schnelle Hilfe. Deine Formel funktioniert, doch leider kann
ich kein Wildcards nutzen.
Wenn ich zb =SUMMENPRODUKT((A1:A9="Test")*(B1:B9="Pend*"))benutze
dann ist das Ergebnis = 0
Hast Du dafür auch ne Lösung ?
Gruss Hebbe
Bild

Betrifft: AW: COUNTIF mit Bedingungen
von: Hebbe
Geschrieben am: 22.02.2005 14:43:06
Hallo Uwe,
danke für die schnelle Hilfe. Deine Formel funktioniert, doch leider kann
ich kein Wildcards nutzen.
Wenn ich zb =SUMMENPRODUKT((A1:A9="Test")*(B1:B9="Pend*"))benutze
dann ist das Ergebnis = 0
Hast Du dafür auch ne Lösung ?
Gruss Hebbe
Bild

Betrifft: AW: COUNTIF mit Bedingungen
von: Hebbe
Geschrieben am: 22.02.2005 14:43:12
Hallo Uwe,
danke für die schnelle Hilfe. Deine Formel funktioniert, doch leider kann
ich kein Wildcards nutzen.
Wenn ich zb =SUMMENPRODUKT((A1:A9="Test")*(B1:B9="Pend*"))benutze
dann ist das Ergebnis = 0
Hast Du dafür auch ne Lösung ?
Gruss Hebbe
Bild

Betrifft: AW: COUNTIF mit Bedingungen
von: UweN
Geschrieben am: 22.02.2005 14:51:41
Hallo Hebbe,
mit Wildcards geht das nicht, aber Du kannst stattdessen mit der Funktion LINKS arbeiten:
=SUMMENPRODUKT((A1:A9="Test")*(LINKS(B1:B9;4)="Pend"))
Viele Grüße
Uwe
Bild

Betrifft: AW: COUNTIF mit Bedingungen
von: Hebbe
Geschrieben am: 22.02.2005 16:57:04
Hallo Uwe,
deine Lösung funktioniert für fast alle meiner Fälle. Leider hab ich auch
zB Wörter wie pended oder nfc_pend. Und ich möchte alle zählen die ein pend
beinhalten egal was davor oder dahinter steht. Ich hab mit LEFT RIGHT ohne
Erfolg rumprobiert. Hast Du vielleicht noch ne Idee ?
mfg
Hebbe
Bild

Betrifft: AW: COUNTIF mit Bedingungen
von: Hebbe
Geschrieben am: 22.02.2005 16:57:18
Hallo Uwe,
deine Lösung funktioniert für fast alle meiner Fälle. Leider hab ich auch
zB Wörter wie pended oder nfc_pend. Und ich möchte alle zählen die ein pend
beinhalten egal was davor oder dahinter steht. Ich hab mit LEFT RIGHT ohne
Erfolg rumprobiert. Hast Du vielleicht noch ne Idee ?
mfg
Hebbe
Bild

Betrifft: AW: COUNTIF mit Bedingungen
von: Tinu
Geschrieben am: 22.02.2005 18:10:25
Hallo Hebbe
wahrscheinlich kann man noch vereinfachen, aber so müsste es gehen:
=SUMMENPRODUKT((A1:A9="Test")*(1-(ISTFEHLER(WENN((FINDE("pend";B1:B9;1))="#WERT";1;2)))))
Gruss
Tinu
Bild

Betrifft: AW: COUNTIF mit Bedingungen
von: Hebbe
Geschrieben am: 23.02.2005 08:54:01
Hi Tinu,
mit Deiner Lösung krieg ich als Ergebnis immer nur 0. Krieg ich so
irgendwie nicht hin.
mfg
Hebbe
Bild

Betrifft: AW: COUNTIF mit Bedingungen
von: Tinu
Geschrieben am: 23.02.2005 10:06:51
Hallo Hebbe,
sorry, ich hatte nur eine Zeile getestet. Diese funktioniert aber! Dann ginge es auf jeden Fall mit Hilfsspalte so:
https://www.herber.de/bbs/user/18572.xls
Gruss
Tinu
Bild

Betrifft: AW: COUNTIF mit Bedingungen
von: UweN
Geschrieben am: 22.02.2005 18:25:38
Hallo Hebbe,
ein Lösungsansatz mit einer Hilfsspalte:
z.B. in C1 ermittelst Du, ob pend in B1 vorkommt mit:
=WENN(ISTFEHLER(FINDEN("pend";B1));"-";"x")
Dann sieht die Summenproduktformel so aus:
=SUMMENPRODUKT((A1:A9="Test")*(LINKS(C1:C9;4)="x"))
Ich bin mir aber ziemlich sicher, daß es auch ohne Hilfspalte funktionieren muß, krieg's im Moment aber nicht hin.
... (Hilfspalte oder HilfSspalte .... grübel grübel ???)
Viele Grüße
Uwe
 Bild

Beiträge aus den Excel-Beispielen zum Thema "COUNTIF mit Bedingungen"