Mehrere Suchkriterien

Bild

Betrifft: Mehrere Suchkriterien von: Karin
Geschrieben am: 24.02.2005 08:25:53

Guten Morgen

Ich habe ein Tabellenblatt mit Daten (siehe Beispiel), in einem weiteren Tabellenblatt benötige ich nur einen Teil dieser Daten. Wie bringe ich diese Daten in ein neues Tabellenblatt wenn ich nach zwei Kriterien suche.

https://www.herber.de/bbs/user/18644.xls

Danke für die Hilfe.

Gruss
Karin

Bild


Betrifft: AW: Mehrere Suchkriterien von: Hübi
Geschrieben am: 24.02.2005 08:34:14

Hi Karin,

so kannst du es machen
Tabelle2
 ABC
1KSTCodeBetrag
28011TOTAL2110
38012TOTAL3145
Formeln der Tabelle
C2 : =SUMMENPRODUKT((Tabelle1!$A$2:$A$20=A2)*(Tabelle1!$B$2:$B$20=B2)*Tabelle1!$C$2:$C$20)
C3 : =SUMMENPRODUKT((Tabelle1!$A$2:$A$20=A3)*(Tabelle1!$B$2:$B$20=B3)*Tabelle1!$C$2:$C$20)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß Hübi


Bild


Betrifft: AW: Mehrere Suchkriterien von: Karin
Geschrieben am: 24.02.2005 09:37:18

Hallo Hübi

Danke für deine schnelle Hilfe!

Für die Beispiel Datei funktioniert ja alles tiptop. Aber bei der wirklichen Datei erhalte ich einen Fehler #ZAHL! Ich habe die Formel wie folgt abgeändert:
=SUMMENPRODUKT((BMBS!$E:$E=A18)*(BMBS!$I:$I=B18)*BMBS!$M:$M)

Was mache ich falsch?

Gruss
Karin


Bild


Betrifft: AW: Mehrere Suchkriterien von: heikoS
Geschrieben am: 24.02.2005 10:10:48

Hallo Karin,

SUMMENPRODUKT() kann nicht auf ganze Spalten angewendet werden - alternativ: E1:E65535 und die Bereiche müssen dieselbe Größe haben, dann also auch in I und M bis 65535.


Gruß Heiko


Bild


Betrifft: Danke! :-) von: Karin
Geschrieben am: 24.02.2005 10:24:21

Gruss
Karin


Bild


Betrifft: Gern geschehen. oT von: heikoS
Geschrieben am: 24.02.2005 12:22:08




 Bild

Beiträge aus den Excel-Beispielen zum Thema "Mehrere Suchkriterien"