SUMMEWENN Funktion

Bild

Betrifft: SUMMEWENN Funktion von: FLO
Geschrieben am: 28.02.2005 20:34:09

Hallo liebe Excel Freunde!

Ich habe ein Problem.

Ich möchte von einer Zahlenreiche die Summe bilden und dann durch die Anzahl aller Zahlen BIS AUF DIE 0 bilden.

Ich habs versucht mit

=SUMME(A1:D1)/ANZAHL(A1:D1)

aber wenn Nullen in der Zahlenreihe vorkommen wird das Endergebnis verfälscht.

Ich müsste die Anzahl bilden eben außer die Felder in denen die Zahl Null vorkommt.

Und hab noch ein kleines Problem.

Wenn ich die Funktion =WENN benutze möchte ich das Excel mir nicht wahr oder Falsch anzeigt sondern eine von mir definierte Zahl oder die Zahl eines Feldes:

=0 =WENN(0;9)

Jetzt sollte nicht WAHR erscheinen sondern die Zahl 9!

Irgendetwas muss noch geändert werden. Aber nur was??

Ich bin noch relativ neu in dem Gebiet

Vielen Dank für eure Hilfe!!

Flo

Bild


Betrifft: AW: SUMMEWENN Funktion von: ransi
Geschrieben am: 28.02.2005 20:42:50

hallo

geht das ?

=SUMME(A1:D1)/zählenwenn(A1:D1;"<>0")

ransi


Bild


Betrifft: 2. frage vergessen... von: ransi
Geschrieben am: 28.02.2005 20:56:18

hallo flo

das geht so:
 
 AB
109
Formeln der Tabelle
B1 : =WENN(A1=0;9;A1)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

ransi


 Bild

Beiträge aus den Excel-Beispielen zum Thema "SUMMEWENN Funktion"