Schaltjahre

Bild

Betrifft: Schaltjahre von: Peter
Geschrieben am: 01.03.2005 11:14:52

Hallo

ich möchte zu einem beliebigen Zeitraum - der über 2 Zellen eingegeben wird - feststellen, wieviel Schaltjahre mit einem 29.2. darinliegen. Wie findet man das heraus?

Danke für jeden Tipp

Bild


Betrifft: AW: Schaltjahre von: c0bRa
Geschrieben am: 01.03.2005 11:33:46

hallo

pauschal würd ich mal folgende formel nehmen:

=ABS(ABRUNDEN(JAHR(A1-60)/4;0)-ABRUNDEN(JAHR(A1-60)/100;0)+ABRUNDEN(JAHR(A1-60)/400;0)-(ABRUNDEN(JAHR(B1-59)/4;0)-ABRUNDEN(JAHR(B1-59)/100;0)+ABRUNDEN(JAHR(B1-59)/400;0)))

wobei

a1 = anfangsdatum
b1 = enddatum

das ergebnis ist dann die anzahl der 29.02. in dem bereich... :)

Das Forum lebt auch von Rückmeldungen...
c0bRa


Bild


Betrifft: Nachtrag / Hinweis von: c0bRa
Geschrieben am: 01.03.2005 11:36:32

Formel funktioniert erst ab dem 01.03.1900 :)
c0bRa


Bild


Betrifft: AW: Schaltjahre von: Andreas Emmert
Geschrieben am: 01.03.2005 11:38:16

Hi Peter,

mit folgender Formel findest du raus, aber das Jahr in Zelle A1 ein Schaltjahr ist:

=WENN(RUNDEN((A1-2000)/4;0)-(A1-2000)/4<>0;"Kein Schaltjahr";"Schaltjahr")

Wie man das jetzt aber für einen Zeitraum ermittelt, gute Frage, ich denke mal da wirst du an VBA nicht vorbeikommen.

Gruß
Andreas


Bild


Betrifft: Frage hat sich beantworte (o.T.) von: Andreas Emmert
Geschrieben am: 01.03.2005 11:40:15

.


Bild


Betrifft: AW: Frage hat sich beantworte (o.T.) von: Peter
Geschrieben am: 01.03.2005 11:59:52

Hallo
Die Antwort von Cobra ist wirklich gut und es hat sich damit erledigt.
Trotzdem vielen Dank.
Peter


 Bild

Beiträge aus den Excel-Beispielen zum Thema "In Diagramm anzeigen"