Suchkriterien in Matrix als VBA-Programm

Bild

Betrifft: Suchkriterien in Matrix als VBA-Programm
von: Jan
Geschrieben am: 02.03.2005 10:30:08
Hallo,
ich habe folgende Formel in Excel
=INDEX(C2:E13;VERGLEICH(H1;B2:B13;0);VERGLEICH(H2;C1:E1;0);VERGLEICH(H3;A2:A13;0))
und möchte diese Funktion in ein VBA-Programm einfügen. Da meine VBA-Kenntnisse nicht dafür ausreichen bitte ich um Hilfe.
Matrix:
_ _ n m h
A n 1 2 2
A m 2 2 2
A h ..
B n
B m
B h
...
Danke für die Hilfe!
Jan

Bild

Betrifft: AW: Suchkriterien in Matrix als VBA-Programm
von: Martin Beck
Geschrieben am: 02.03.2005 14:42:18
Hallo Jan,
starte den Makrorekorder, gib die Formel in die Tabelle ein, beende die Makroaufzeichnung.
Gruß
Martin Beck
Bild

Betrifft: AW: Suchkriterien in Matrix als VBA-Programm
von: Jan
Geschrieben am: 03.03.2005 09:54:06
Hallo Martin,
mußte die Formel korrigieren und hab es dann versucht mit dem Markrorekorder auf zu nehmen, doch die Formel scheint zu lang zu sein. Es wird nur ein Bruchteil erfasst.
ActiveCell.FormulaR1C1 = _
"=R[-11]C=""A"" (INDEX(R2C3:R4C5,MATCH(R[-11]C[1],R2C2:R4C2,0),MATCH(R[-11]C[2],R1C3:R1C5,0))) R[-11]C=""B"" (INDEX(R5C3:R7C5,MATCH(R[-11]C[1],R5C2:R7C2,0),MATCH(R[-11]C[2],R1C3:R1C5,0))) R[-11]C=""C"" R8C3:R10C5 MATCH(R[-11]C[1],R8C2:R10C2,0)"
Wenn ich den Teil "R[-11]C=""C"" R8C3:R10C5 MATCH(R[-11]C[1],R8C2:R10C2,0)" Lösche Funktioniert das Makro trotzdem nicht. Wieso? Was muß ich beachten?
Für mich ist es sowieso wichtiger, dass ich nicht in jeder Zelle die Formel eingetragen bekomme sondern nur das Ergebnis. Also als Programm mit IF.. THEN.. ELSE.. Bedingungen wäre es mit lieber, jedoch fehlen mir dazu die Kenntnisse.
Neue Formel:
=WENN(H1="A";(INDEX($C$2:$E$4;VERGLEICH(I1;$B$2:$B$4;0);VERGLEICH(J1;$C$1:$E$1;0)));WENN(H1="B";(INDEX($C$5:$E$7;VERGLEICH(I1;$B$5:$B$7;0);VERGLEICH(J1;$C$1:$E$1;0)));WENN(H1="C";(INDEX($C$8:$E$10;VERGLEICH(I1;$B$8:$B$10;0);VERGLEICH(J1;$C$1:$E$1;0)));WENN(H1="D";(INDEX($C$11:$E$13;VERGLEICH(I1;$B$11:$B$13;0);VERGLEICH(J1;$C$1:$E$1;0)));"geht nicht"))))
Bild

Betrifft: Neuer Thread eröffnet (oT)
von: xxx
Geschrieben am: 04.03.2005 12:18:51

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Suchkriterien in Matrix als VBA-Programm"