Herbers Excel-Forum - das Archiv

Zelleninhalte verschieben bei Leerzeichen

Bild

Betrifft: Zelleninhalte verschieben bei Leerzeichen
von: Otto

Geschrieben am: 02.03.2005 17:15:33
Hallo zusammen,
ich habe folgendes Problem:
Ich möchte die Inhalte aller Zellen der dritten Spalte, die mit zwölf Leerzeichen beginnen, in die gleiche Zeile der vierten Spalte verschieben. Dort sollten die Leerzeichen nicht mehr vorhanden sein.
Kann mir da jemand helfen? Bin ein absoluter VBA-Anfänger :(
Danke,
Otto
Bild

Betrifft: AW: Zelleninhalte verschieben bei Leerzeichen
von: serge
Geschrieben am: 02.03.2005 17:19:52
Hi Otto
in der vierten spalten mit
=GLÄTTEN(A3)die Werte ohne Leerzeichen übernehmen
Serge
Bild

Betrifft: AW: Zelleninhalte verschieben bei Leerzeichen
von: Otto

Geschrieben am: 03.03.2005 15:50:03
Hallo Otto,
Meine Testumgebungen: Excel 9.0 SR-1, Multilingual unter Windows 2000 SP-4 und Excel 11 Deutsch unter Windows XP
Schreibe nach D1:
=WENN(LINKS(C1;12)=WIEDERHOLEN(" ";12);TEIL(C1;13;2000);"")
und ziehe das entsprechend nach unten
Gruß Otto
 Bild
Excel-Beispiele zum Thema "Zelleninhalte verschieben bei Leerzeichen"
Zeilen bedingt durch SpinButton verschieben Artikel aus Auswahltextbox in Sammeltextbox verschieben
Datei verschieben Daten in ListBoxes verschieben und sortieren
Bei Blattnamenseintrag Zeile in jeweiliges Blatt verschieben Tabellenblattgrafik ein/ausblenden und verschieben
Excel-Arbeitsmappe aus dem Internet öffnen und verschieben Mails eines Outlook-Ordners in einen anderen verschieben
Blatt verschieben und neuer Code für Schaltfläche Verschieben von ListBox-Eintragen nach oben und unten