Herbers Excel-Forum - das Archiv

verweis auf eine xls-Liste

Bild

Betrifft: verweis auf eine xls-Liste
von: michael

Geschrieben am: 04.03.2005 08:59:03
Hallo,
kann mir jemand das Phänomen erklären.
Erstellt wurde die Datei Auswertg.xls aus dem der folgende Teil eines Befehls stammt und auch die sliste.xls sthet auf Lw P:\
=WENN((SVERWEIS($K4,'P:\50_AAA\BBB\CCC\DDD\[sliste.xls]Liste'!$A:$W,2,FALSCH))=0,"",.....
Zum Bearbeiten muss ich die Datei Auswertg.xls in ein anderes Lw kopieren z.B. Q:\.
Nun wird aber auch der SVERWEIS auf Q:\ geändert.
Warum geschieht das, denn die Liste steht ja nach wie vor auf P:\
jedoch funktioniert noch der SVERWEIS obwohl sich unter dem geänderten Pfad Q:\ im SVERWEIS keine Liste befindet?
Gibt es eine Möglichkeit sicher zu stellen, dass beim kopieren einer Datei in ein anderes Lw die Verweise auf das ursprüngliche Lw unverändert bleiben?
Danke und Gruß
Michael
Bild

Betrifft: AW: verweis auf eine xls-Liste
von: Günther Oppold

Geschrieben am: 04.03.2005 12:16:44
Hallo Michael,
mit folgendem Verfahren müsste der Bezug gleich bleiben:
Öffne beide Dateien,
dann Speichere die Auswertung unter Laufwerk Q
Schließe die Ursprungstabelle (die bleibt ja auf Laufwerk P)
Die Formeln in Auswertung müssten nun weiterhin den Pfad Laufwerk P aufweisen

Günther
Bild

Betrifft: AW: verweis auf eine xls-Liste
von: michael
Geschrieben am: 04.03.2005 13:03:13
Hallo Günther,
danke für die Antwort.
Warum wird denn überhaupt der Lw-Buchstabe automatisch geändert/"angepasst"?
Danke und Gruß
Michael
 Bild
Excel-Beispiele zum Thema "verweis auf eine xls-Liste"
SVERWEIS auf geschlossene Arbeitsmappe aus Makro aufrufen Per VBA einen Verweis zu einer *.DLL erstellen
Benutzerdefinierte SVERWEIS-Funktion über mehrere Bereiche VBE-Verweis löschen
Arbeitszeittabelle und SVERWEIS-Formel Verweise anhand einer Kopfzeile erkennen
Zugriff über SVERWEIS() auf eine Artikelliste Verweise auf Zellen in geschlossener Arbeitsmappe erstellen
SVERWEIS-Formel über mehrere Fundstellen SVERWEIS-, WVERWEIS- und Matrixformel-Beispiele