Summe

Bild

Betrifft: Summe
von: Pascal
Geschrieben am: 04.03.2005 09:06:47
Hallo zusammen!
Ich habe ein kleines Excel-Problem. Ich habe eine Reihe von Wertpapierdaten, die ich aufsummieren will. Die Datenbasis besteht aus mehreren unterschiedlichen Wertpapieren, die sich durch ihre Kennnummern unterscheiden lassen. Ich habe diese Daten nun nach Kennnummern sortiert und möchte, dass Excel sich die Daten mit gleicher Kennnummer raussucht und deren Werte addiert. Und zwar so, dass ich nicht manuell die jeweilige Kennnummer in "SUMMEWENN" eingeben muss.
Kann mir da jemand helfen?
Lieben Gruß,

Pascal

Bild

Betrifft: AW: Summe -->Teilergebnisse oT
von: u_
Geschrieben am: 04.03.2005 09:24:40

Bild

Betrifft: AW: Summe
von: Matthias G
Geschrieben am: 04.03.2005 09:25:50
Hallo Pascal,
woher willst du die Kennummer nehmen? Oder sollen alle Kennnummern automaisch gefunden werden?
Du kannst die Kennnummer doch in eine Zelle schreiben und in SUMMEWENN() darauf verweisen...
Gruß Matthias
Bild

Betrifft: AW: Summe
von: Pascal
Geschrieben am: 04.03.2005 09:31:16
Also, die Tabelle sieht so aus: Spalte A: Kennnummern, Spalte B: Anzahl. Da es sehr viele Kennnummern sind, wäre eine einzige Formel praktisch, die automatisch die Summe der Anzahl aller gleichen Kennnummern finden würde.
Bild

Betrifft: AW: Summe
von: Matthias G
Geschrieben am: 04.03.2005 09:41:03
Hallo Pascal,
wie willst du denn in einer Zelle mehrere Summen unterbringen?
GRuß Matthias
Bild

Betrifft: AW: Summe
von: Pascal
Geschrieben am: 04.03.2005 09:47:07
Hi Matthias!
Danke erstmal für Deine Mühe! Nein, natürlich nicht in einer Zelle. Excel soll die Spalte A von oben nach unten absuchen und bei gleichen Nummern die Summe von Spalte B bilden. Wenn er das mit der erstan WKN getan hat, soll die nächste kommen und so weiter. Allerdings vermute ich, dass das nicht wirklich möglich ist. :-(
Bild

Betrifft: AW: Summe
von: Matthias G
Geschrieben am: 04.03.2005 10:11:35
Hallo Pascal,
mit dieser Formel bekommst du alle Werte aus A:
z.B. in Zelle C2:
{=INDIREKT("A"&KKLEINSTE(WENN((ZÄHLENWENN(INDIREKT("A1:A"&ZEILE($1:$100));A$1:A$100)=1);ZEILE($1:$100));ZEILE(A2)))}
und dann runterkopieren.
Evtl. den Bereich anpassen (hier nur bis A100)
Die geschweiften Klammern nicht mit eingeben, sondern Eingabe mit Strg-Shift-Enter abschließen.
vergleiche auch hier:
http://www.excelformeln.de/formeln.html?welcher=78
Dann hast du schon mal eine Liste mit den Kennzahlen. Ein Summewenn() daneben dürfte kein Problem mehr sein.
Gruß Matthias
Bild

Betrifft: AW: Summe
von: HermannZ
Geschrieben am: 04.03.2005 10:07:47
Hallo Pascal,
also mehr möglichkeiten nach deiner beschreibung fallen mir nicht ein,
Beispiel;
TestAlt
 ABCDE
46   ges. 
47BedingungWert BedingungSumme
48568 6127
49463   
50513 Bedingungen =4
51267   
52332  8
53642  Anzahl Bedingungen
54156  ohne Doppelte
55613   
56646   
57538   
58128   
59847   
60749   
61626   
62327   
63     
64  Bedingung  
65BedingungWertohne DoppelteSumme Wert 
665685119
67463463 
68513267 
69267359 
703326127 
71642184 
72156847 
73613749 
74646   
75538   
76128Formeln herunterkopieren  
77847   
78749   
79626   
80327   
81     
Formeln der Tabelle
E48 : =SUMMEWENN(A48:A62;D48;B48:B62)
E50 : =ZÄHLENWENN(A48:A62;D48)
E52 : {=SUMME(WENN(A48:A62=D48;0;1/ZÄHLENWENN(A48:A62;A48:A62)))+1}
C66 : {=WENN(SUMME(WENN(A$66:A$80="";0;1/ZÄHLENWENN(A$66:A$80;A$66:A$80))) < ZEILE(A1);"";INDIREKT("A"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(A$66;;;ZEILE($1:$15));A$66:A$80)=1;ZEILE($66:$80));ZEILE(A1))))}
D66 : =SUMMEWENN($A$66:$A$80;C66;$B$66:$B$80)
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Gruß hermann
Bild

Betrifft: AW: Summe
von: Holger Levetzow
Geschrieben am: 04.03.2005 10:21:44
Hallo Pascal,
sieh mal in die Datei rein.
https://www.herber.de/bbs/user/19190.xls
Holger
 Bild

Beiträge aus den Excel-Beispielen zum Thema "markierten Bereich mit VBA verschieben"