Auslesen einer Spalte und Bildung Summe

Bild

Betrifft: Auslesen einer Spalte und Bildung Summe von: Roth
Geschrieben am: 07.03.2005 12:49:02

Hallo,

ich habe mehrere Tabelle, aus der ich aus 2 Spalten eine konsolidierte Form der Info brauche.
In der Ersten Spalte stehen Typenbezeichnung in der zweiten laufende Nummern.
ich will in der xtra tabelle "ausrechnen" lassen, wieviele verschiedene Typen es tatsächlich gibt.
die typen können untereinander auftauchen, und tauchen in mehrere zeilen mit der selbigen laufende nummer auf.
d.h. die anzahl soll erst dann erhöht werden, wenn auch eine andere laufende nummer da.
oder muss man dies in 2 schritten machen ?
Vielen dank für die Info.
Gruss
Karo

Typ / Laufende Nummer
M1F / 3_01
M1F / 3_01
D3 / 3_02
D3 / 3_02
D3 / 3_02
M1F / 3_01
D1 / 3_03
D1 / 3_04
D1 / 3_05
M3F / 3_06
M3 / 3_06
M2 / 3_07
M2 / 3_07
M3F / 3_08
M3 / 3_07
M3F / 3_08
M3F / 3_08
D1 / 3_09
M3F / 3_06
D2 / 3_10
D2 / 3_10

Bild


Betrifft: AW: Auslesen einer Spalte und Bildung Summe von: eres
Geschrieben am: 07.03.2005 13:03:28

Hallo "Roth",

ein Ansatz:

lege eine neue Spalte an, in der Du die Werte aus Spalte 1 und Spalte 2 verbindest
(=A1&A2). Danach sortierst Du die neue Spalte und ermittelst mit Daten - Teilergebnisse die gesuchten Werte.

Gruss

eres


Bild


Betrifft: AW: Auslesen einer Spalte und Bildung Summe von: Peter W
Geschrieben am: 07.03.2005 13:07:44

Servus,

meinst du so:

Excel Jeanie HTML
Bild
Bild
Formeln der Tabelle
D1 : =A1
E2 : =SUMMENPRODUKT(($B$2:$B$8=$C2)*($A$2:$A$8=D$2))
  Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  



MfG

Peter


Bild


Betrifft: AW: Auslesen einer Spalte und Bildung Summe von: HermannZ
Geschrieben am: 07.03.2005 13:22:19

Hallo Roth,

Ein Beispiel;

TestNeu
 ABC
1M1F3_0115
2M1F3_01 
3D33_02 
4D43_02 
5D53_02 
6M1F 3_01 
7D1 3_03 
8D23_04 
9D33_05 
10M3F3_06 
11M3 3_06 
12M23_07 
13M33_07 
14M3F3_08 
15M33_07 
16M3F3_08 
17M3F3_08 
18D13_09 
19M3F3_06 
20D23_10 
21D33_10 
22   
Formeln der Tabelle
C1 : {=SUMME(1/MMULT(IDENTISCH(A1:A21&B1:B21;MTRANS(A1:A21&B1:B21))*1;ZEILE(1:21)/ZEILE(1:21)))-1}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß hermann


Bild


Betrifft: AW: Auslesen einer Spalte und Bildung Summe von: Karo Roth
Geschrieben am: 07.03.2005 15:32:20

Hallo,

danke erstmal,

aber das ist noch nicht das, was ich suche.

denn in meiner Liste ist es ja so, dass die Antwort folgende sein muss
M1F= 1 Gerät
D3 = 1 Gerät
D1 = 4 Geräte
M2= 1 Gerät
M3F= 2 Geräte
D2= 1 Gerät

Das M1F taucht zwar 3 mal auf, ist aber die selbe laufende Nummer. bei M3F taucht es 4 mal auf, aber 2 verschiedene Nummern.

Bei Euren Beispielen da adiert xls wieoft das Gerät auftaucht.. aber diese plausible Prüfung, dass das Gerät die selbige laufende Nummer wie vorhin hat, muss noch drinn sein.

@Herrmann, wenn ich deine Formel anwende, dann erhalte ich für eine kleine tabelle als summe 20. was ich mir nicht erklären kann.


Gruss
K. Roth


Bild


Betrifft: AW: Auslesen einer Spalte und Bildung Summe von: Peter W
Geschrieben am: 07.03.2005 16:22:42

Hi,

Sry aber die Formel Summenprodukt liefert genau das, wie du an unten ausgebauten Bsp. siehst.

Excel Jeanie HTML
Bild
Bild
Formeln der Tabelle
D1 : =A1
E2 : =SUMMENPRODUKT(($B$2:$B$11=$C2)*($A$2:$A$11=$D2))&" Geräte"
E3 : =SUMMENPRODUKT(($B$2:$B$11=$C3)*($A$2:$A$11=$D3))&" Geräte"
  Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  



MfG

Peter


Bild


Betrifft: AW: Auslesen einer Spalte und Bildung Summe von: HermannZ
Geschrieben am: 07.03.2005 17:29:30

Hallo Roth,

deine ursprüngliche Frage lautete ---ich will in der xtra tabelle "ausrechnen" lassen, wieviele verschiedene Typen es tatsächlich gibt---
und das rechnet die Formel sonst nichts.
wenn du natürlich wissen willst wieviele es von jedem Typ gibt dann anders.
Ein Beispiel;

TestNeu
 ABCD
1   Anzahl
2  Stück je Nr.Verschiedene
3M1F3_01215
4M1F3_012 
5D33_021 
6D43_021 
7D53_021 
8M1F 3_011 
9D1 3_031 
10D23_041 
11D33_051 
12M3F3_062 
13M3 3_061 
14M23_071 
15M33_072 
16M3F3_083 
17M33_072 
18M3F3_083 
19M3F3_083 
20D13_091 
21M3F3_062 
22D23_101 
23D33_101 
24  Formel nach 
25  unten kopieren 
Formeln der Tabelle
C3 : {=SUMME(($A$3:$A$23&$B$3:$B$23=A3&B3)*1)}
D3 : {=SUMME(1/MMULT(IDENTISCH(A3:A23&B3:B23;MTRANS(A3:A23&B3:B23))*1;ZEILE(3:23)/ZEILE(3:23)))-1}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


wenn das deiner Vorstellung entspricht kann man auch die doppelten noch entfernen.

Gruß hermann


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Auslesen einer Spalte und Bildung Summe"