Kopieren, wenn....

Bild

Betrifft: Kopieren, wenn....
von: Tina
Geschrieben am: 08.03.2005 16:30:26
Hallo, stehe ein wenig auf dem Schlauch:
Ich habe 4 Tabellen, die eine ist nach Kunden aus dem Bereich Süd, eine nach Kunden aus dem Bereich Nord und eine nach Kunden aus dem Bereich Mitte aufgeteilt, die andere ist eine Gesamtkunden-Tabelle.
Alle vier Tabellen sind alphabetisch nach Kunden Namen (A-Z) sortiert.
Ich habe in den 3 Bereichstabellen jeweils eine Spalte mit "Bereich" die jeweils mit Süd, Nord oder Mitte ausgefüllt sind.
In der Gesamt-Tabelle habe ich auch so eine Spalte, allerdings möchte ich diese von Excel automatisch ausfüllen lassen, weil ich keine Lust habe für über 1000 Kunden den Bereich mit der Hand aus zu füllen.
Wie heisst die Formel, die ich hier verwenden kann?
Es müsste in Etwa so aussehen:
"Liebes Excel, bitte schaue nach, ob der Wert in a2 in Tabelle Süd a2:a350 ist, dann schreibe "Süd", ist er in Tabelle Mitte a2:a350, dann schreibe "Mitte" und ist er in Tabelle Nord a2:a350, dann schreibe "Nord", findest Du ihn nicht, schreibe "falsch""
Ist das machbar?
Lieben Dank und Liebe Grüße
Tina

Bild

Betrifft: AW: Kopieren, wenn....
von: c0bRa
Geschrieben am: 08.03.2005 16:36:33
hallo
ungetestet würd ich sagen:
=wenn(summewenn(süd!a:a;a2)>0;"süd";wenn(summewenn(mitte!a:a;a2)>0;"mitte";wenn(summewenn(nord!a:a;a2)>0;"nord";"fehler")))
tabellennamen musst halt bei bedarf anpassen... :)

Das Forum lebt auch von Rückmeldungen...
c0bRa
Bild

Betrifft: AW: Kopieren, wenn....
von: Tina
Geschrieben am: 08.03.2005 16:49:03
Hi, vielen Dank, ich werde mal sehen, ob das so funktioniert.
Manchmal steht man da auf dem Schlauch und weiss garnix mehr... ! ;-)
LG Tina
Bild

Betrifft: AW: Kopieren, wenn....
von: Tina
Geschrieben am: 08.03.2005 16:55:38
Hallo nochmal,
klappt leider nicht (habe die Tabellen-Namen, etc abgeändert...) ;-(
Schade.
Bild

Betrifft: AW: Kopieren, wenn....
von: Peter W
Geschrieben am: 08.03.2005 17:24:13
Servus,
meinst du so:
Excel Jeanie HTML
Formeln der Tabelle
B1 : =Süd!A1
C1 : =B1
B3 : =WENN(DBAUSZUG(Süd!$A$1:$B$6;Süd!$A$1;Tabelle4!B1:B2)=B2;"Süd";WENN(DBAUSZUG(Mitte!$A$1:$B$6;Mitte!$A$1;Tabelle4!B1:B2)=Tabelle4!B2;"Mitte";WENN(DBAUSZUG(Nord!$A$1:$A$6;Nord!$A$1;Tabelle4!B1:B2)=Tabelle4!B2;"Nord";"Falsch")))
C3 : =WENN(DBAUSZUG(Süd!$A$1:$B$6;Süd!$A$1;Tabelle4!C1:C2)=C2;"Süd";WENN(DBAUSZUG(Mitte!$A$1:$B$6;Mitte!$A$1;Tabelle4!C1:C2)=Tabelle4!C2;"Mitte";WENN(DBAUSZUG(Nord!$A$1:$A$6;Nord!$A$1;Tabelle4!C1:C2)=Tabelle4!C2;"Nord";"Falsch")))
  Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
MfG
Peter
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Kopieren, wenn...."