mehrfachwerte aus spalten filtern und addieren

Bild

Betrifft: mehrfachwerte aus spalten filtern und addieren von: wjansen
Geschrieben am: 12.03.2005 17:49:31

Hi,
also folgendes problem.
ich habe eine Tabelle in der in spalte B mehrere Werte doppelt vorhanden sind.
zu diesen werten stehen jeweils in der dazugehörigen zeile andere verschiedene werte und zwar bis spalte t.
jetzt möchte ich auf einen anderen tabellenblatt eine art liste haben in der immer nur ein wert aus spalte b steht mit dem dazugehörigen werten aus den spalten r (der höchste), s und t und die doppelten werte aus den spalten s und t sollen addiert werden.

0101 Werner Jansen 7,2 10,4 10,2 10,5 10,1 10,3 10,1 10,4 10,4 10,3 99,9 97 15,38 105,23 29 9 0
0102 Johannes Jansen 10,9 10,9 10,9 10,9 10,9 10,9 10,9 10,9 10,9 10,9 109,0 100 90 10 10
0103 Josef Walker 10,5 10,6 10,5 10,1 10,1 10,5 10,7 10,7 10,9 10,4 105,0 100 20,53 62,43 50 10 1
0104 Werner Jansen 9,1 9,3 9,8 7,4 9,3 8,9 9,5 10,8 8,7 8,4 91,2 86 43,54 285,61 52 1 0
0105 Werner Jansen 10,5 10,6 10,6 10,7 10,3 10,5 9,9 10,7 10,3 10,5 104,6 99 131,92 140,40 56 9 0
0106 Johannes Jansen 7,4 7,4 7,5 7,3 7,2 7,1 7,6 5,6 4,3 4,2 65,6 62 36 0 0
0107 Willi Tammen 9,9 9,9 9,9 10,5 10,5 10,5 9,9 10,5 9,9 10,5 102,0 95 70 5 0
0108 Werner Jansen 10,5 10,5 10,3 10,6 10,3 10,2 10,5 10,5 10,8 10,8 105,0 100 50 10 0


ich hoffe mann hat mich verstanden
mfg
wjansen

Bild


Betrifft: AW: mehrfachwerte aus spalten filtern und addieren von: Hajo_Zi
Geschrieben am: 12.03.2005 17:59:16

Hallo wjansen,

eine Beispiel datei wäre wohl besser.
"r (der höchste) soll ich das so interpretieren das Spalte R die Letzte ist? Das würde dem aber wiedersprechen das die Werte in Spalte S und T summiert werden sollen?
Sollen nur Spalte B; S und T angezeigt werden?
Muß irgendwie gekennzeichnet werden wo Doppelte Werte sind?
Das sind nur so paar Fragen die mir auf die schnelle zu Deinem Beitrag einfallen.


Bitte keine Mail, Probleme sollten im Forum gelöst werden.
Microsoft MVP für Excel
Das Forum lebt auch von den Rückmeldungen.
Betriebssystem XP Home SP2 und Excel Version 2003 SP1.




Bild


Betrifft: AW: mehrfachwerte aus spalten filtern und addieren von: wjansen
Geschrieben am: 12.03.2005 18:07:14

Hallo,

also letzte spalte ist spalte T.
es sollen Spalte B,R,S und T angezeigt werden.
doppelte werte stehen in spalte B das sind die namen.
summiert werden sollen S und T .
aus Spalte R soll der höchste wert genommen werden zu den jeweiligen Namen aus Spalte B

der upload der datei geht nicht

mfg
wjansen


Bild


Betrifft: AW: mehrfachwerte aus spalten filtern und addieren von: Hajo_Zi
Geschrieben am: 12.03.2005 18:12:25

Hallo wjansen,

Die Aufgabe ist klar und bis auf einen Punkt von meinen Standpunkt auch leicht zu lösen. Es ist ja schön das ich zur Klärung der Aufgabe beigetragen habe.
Jetzt mußt Du nur noch jemand finden der das nachbauen will. Ich für meinen Teil gebe zu 95% nur Sachen raus die ich getestet habe.

Gruß Hajo

Das Forum lebt auch von den Rückmeldungen.


Bild


Betrifft: AW: mehrfachwerte aus spalten filtern und addieren von: wjansen
Geschrieben am: 14.03.2005 13:46:18

hi,
würde ja gerne die datei zur verfügung stellen
aber leider geht der upload irgendwie nicht.
bei bedarf einfach anfordern wjansen@ems-it.de


mfg
wjansen


Bild


Betrifft: AW: mehrfachwerte aus spalten filtern und addieren von: Ramses
Geschrieben am: 12.03.2005 18:14:31

Hallo

einfachste Variante.
Am Ende eine Neue Spalte einfügen in der du in der ersten Zeile diese Formel einfügst

 
 ABCDEF
111 Suche nach:3 
212    
313 Max-Wert11 
414    
525    
636    
727    
8311    
919    
1019    
11      
Formeln der Tabelle
E3 : {=INDEX(B1:B100;VERGLEICH(E1&MAX((A1:A100=E1)*B1:B100);A1:A100&B1:B100;0))}
 
Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  




Anstelle von E1 verweist du auf Spalte A deiner Formelzeile, anstelle von B1:B100 verweist du auf den Bereich Rx:Rxx.
Daneben schreibst du die Formel in der du die Spalten S und T der Zeile summierst.

Danach geht alles ganz einfach:

Daten - Pivot Tabelle

Im Layout Assistent kannst du die Spalte mit der Nummer und dem Namen in das Spaltenfeld ganz links ziehen, in den Auswerte Bereich ziehst du die beiden Neuen Spaltenwerte.

Sollte eigentlich tun.

Gruss Rainer


Bild


Betrifft: AW: mehrfachwerte aus spalten filtern und addieren von: wjansen
Geschrieben am: 14.03.2005 13:38:37

Hallo,
habe mal versucht die tabelle hier darzustellen.
die tabelle gesamt hat ca 700 zeilen.
in spalte B stehen verschiedene aber auch doppelte namen.
zu diesen stehen in den folgenden spalten bis spalte T jeweils verschiedene Werte (wie mann im beispiel sieht)
wie schon beschrieben sollen jetzt auf einem neuen tabellenblatt folgende werte angezeigt werden.
Name (keine doppelten)dahinter der höchste wert zum namen asu Spalte R dahinter dann die summe alle Werte zum Namen aus Spalte S und dahinter die summe aller Werte zum Namen aus Spalte T
Das ganze handelt sich um einen Tabelle eines Schiesswettkampfes in der die ergebnisse automatisch von einer auswertmaschine eingetragen werden. nur müssen wir zum auswerten umständlich alle werte zum namen aus den spalten S und T manuell zusammenrechnen und beim sortieren z.b.nach spalte R so das das höchste ergebniss oben steht kann es natürlich vorkommen das ein name an zweiter dritter und vierter stelle steht.
darum hab ich mir gedacht das mann diese werte irgendwie automatisch auf einem neuen tabellenblatt schreibt in der die oben genannten filter und summierungen angewendet werden.

achja die berechnung der kommawerte findet auf einen seperaten tabellenblat statt.

ich hoffe du kannst mir da helfen
für mich scheint das ziemlich kompliziert

mfg
wjansen


Excel Jeanie HTML
Bild
Bild
Formeln der Tabelle
N7 : =SUMME(D7:M7)
O7 : =Ergeb_ganzzahl!N3
R7 : =Ergeb_komma!N3
S7 : =ZÄHLENWENN(Ergeb_ganzzahl!D3:M3;10)
T7 : =ZÄHLENWENN(D7:M7;10,9)
N8 : =SUMME(D8:M8)
O8 : =Ergeb_ganzzahl!N4
R8 : =Ergeb_komma!N4
S8 : =ZÄHLENWENN(Ergeb_ganzzahl!D4:M4;10)
T8 : =ZÄHLENWENN(D8:M8;10,9)
N9 : =SUMME(D9:M9)
O9 : =Ergeb_ganzzahl!N5
R9 : =Ergeb_komma!N5
S9 : =ZÄHLENWENN(Ergeb_ganzzahl!D5:M5;10)
T9 : =ZÄHLENWENN(D9:M9;10,9)
N10 : =SUMME(D10:M10)
O10 : =Ergeb_ganzzahl!N6
R10 : =Ergeb_komma!N6
S10 : =ZÄHLENWENN(Ergeb_ganzzahl!D6:M6;10)
T10 : =ZÄHLENWENN(D10:M10;10,9)
N11 : =SUMME(D11:M11)
O11 : =Ergeb_ganzzahl!N7
R11 : =Ergeb_komma!N7
S11 : =ZÄHLENWENN(Ergeb_ganzzahl!D7:M7;10)
T11 : =ZÄHLENWENN(D11:M11;10,9)
N12 : =SUMME(D12:M12)
O12 : =Ergeb_ganzzahl!N8
R12 : =Ergeb_komma!N8
S12 : =ZÄHLENWENN(Ergeb_ganzzahl!D8:M8;10)
T12 : =ZÄHLENWENN(D12:M12;10,9)
N13 : =SUMME(D13:M13)
O13 : =Ergeb_ganzzahl!N9
R13 : =Ergeb_komma!N9
S13 : =ZÄHLENWENN(Ergeb_ganzzahl!D9:M9;10)
T13 : =ZÄHLENWENN(D13:M13;10,9)
N14 : =SUMME(D14:M14)
O14 : =Ergeb_ganzzahl!N10
R14 : =Ergeb_komma!N10
S14 : =ZÄHLENWENN(Ergeb_ganzzahl!D10:M10;10)
T14 : =ZÄHLENWENN(D14:M14;10,9)
  Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  




Bild


Betrifft: AW: mehrfachwerte aus spalten filtern und addieren von: Hajo_Zi
Geschrieben am: 14.03.2005 16:22:59

Hallo wjansen,

ich bin nun nicht der Formelprofil, aber bis auf max. habe ich das hinbekommen. Vielleicht hat Rainer die Formel für max.

Tabelle2
 ABCD
1Werner Jansen200Formel Spalte A von
2Johannes Jansen1010http://www.excelformeln.de/formeln.html?welcher=194
3Josef Walker101Spalte D Formel von Ramses
4Heinz Dirksen90 
5Willi Tammen50 
6    
7    
8    
9    
10    
11    
12    
13 Summe Spalte SSumme Spalte T 
Formeln der Tabelle
A1 : {=WENN(SUMME(WENN(Tabelle1!B$3:B$101="";0;1/ZÄHLENWENN(Tabelle1!B$3:B$101;Tabelle1!B$3:B$101))) < ZEILE();"";INDIREKT("Tabelle1!B"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!B$3;;;ZEILE(Tabelle1!B$3:B$101));Tabelle1!B$3:B$101)=1;ZEILE(Tabelle1!B$3:B$101));ZEILE())))}
B1 : =SUMMEWENN(INDIREKT("Tabelle1!$B$3:$B$" &ANZAHL2(Tabelle1!B:B)+1);A1;INDIREKT("Tabelle1!$S$3:$S" &ANZAHL2(Tabelle1!B:B)+1))
C1 : =SUMMEWENN(INDIREKT("Tabelle1!$B$3:$B$" &ANZAHL2(Tabelle1!B:B)+1);A1;INDIREKT("Tabelle1!$T$3:$T" &ANZAHL2(Tabelle1!B:B)+1))
A2 : {=WENN(SUMME(WENN(Tabelle1!B$3:B$101="";0;1/ZÄHLENWENN(Tabelle1!B$3:B$101;Tabelle1!B$3:B$101))) < ZEILE();"";INDIREKT("Tabelle1!B"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!B$3;;;ZEILE(Tabelle1!B$3:B$101));Tabelle1!B$3:B$101)=1;ZEILE(Tabelle1!B$3:B$101));ZEILE())))}
B2 : =SUMMEWENN(INDIREKT("Tabelle1!$B$3:$B$" &ANZAHL2(Tabelle1!B:B)+1);A2;INDIREKT("Tabelle1!$S$3:$S" &ANZAHL2(Tabelle1!B:B)+1))
C2 : =SUMMEWENN(INDIREKT("Tabelle1!$B$3:$B$" &ANZAHL2(Tabelle1!B:B)+1);A2;INDIREKT("Tabelle1!$T$3:$T" &ANZAHL2(Tabelle1!B:B)+1))
A3 : {=WENN(SUMME(WENN(Tabelle1!B$3:B$101="";0;1/ZÄHLENWENN(Tabelle1!B$3:B$101;Tabelle1!B$3:B$101))) < ZEILE();"";INDIREKT("Tabelle1!B"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!B$3;;;ZEILE(Tabelle1!B$3:B$101));Tabelle1!B$3:B$101)=1;ZEILE(Tabelle1!B$3:B$101));ZEILE())))}
B3 : =SUMMEWENN(INDIREKT("Tabelle1!$B$3:$B$" &ANZAHL2(Tabelle1!B:B)+1);A3;INDIREKT("Tabelle1!$S$3:$S" &ANZAHL2(Tabelle1!B:B)+1))
C3 : =SUMMEWENN(INDIREKT("Tabelle1!$B$3:$B$" &ANZAHL2(Tabelle1!B:B)+1);A3;INDIREKT("Tabelle1!$T$3:$T" &ANZAHL2(Tabelle1!B:B)+1))
A4 : {=WENN(SUMME(WENN(Tabelle1!B$3:B$101="";0;1/ZÄHLENWENN(Tabelle1!B$3:B$101;Tabelle1!B$3:B$101))) < ZEILE();"";INDIREKT("Tabelle1!B"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!B$3;;;ZEILE(Tabelle1!B$3:B$101));Tabelle1!B$3:B$101)=1;ZEILE(Tabelle1!B$3:B$101));ZEILE())))}
B4 : =SUMMEWENN(INDIREKT("Tabelle1!$B$3:$B$" &ANZAHL2(Tabelle1!B:B)+1);A4;INDIREKT("Tabelle1!$S$3:$S" &ANZAHL2(Tabelle1!B:B)+1))
C4 : =SUMMEWENN(INDIREKT("Tabelle1!$B$3:$B$" &ANZAHL2(Tabelle1!B:B)+1);A4;INDIREKT("Tabelle1!$T$3:$T" &ANZAHL2(Tabelle1!B:B)+1))
A5 : {=WENN(SUMME(WENN(Tabelle1!B$3:B$101="";0;1/ZÄHLENWENN(Tabelle1!B$3:B$101;Tabelle1!B$3:B$101))) < ZEILE();"";INDIREKT("Tabelle1!B"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!B$3;;;ZEILE(Tabelle1!B$3:B$101));Tabelle1!B$3:B$101)=1;ZEILE(Tabelle1!B$3:B$101));ZEILE())))}
B5 : =SUMMEWENN(INDIREKT("Tabelle1!$B$3:$B$" &ANZAHL2(Tabelle1!B:B)+1);A5;INDIREKT("Tabelle1!$S$3:$S" &ANZAHL2(Tabelle1!B:B)+1))
C5 : =SUMMEWENN(INDIREKT("Tabelle1!$B$3:$B$" &ANZAHL2(Tabelle1!B:B)+1);A5;INDIREKT("Tabelle1!$T$3:$T" &ANZAHL2(Tabelle1!B:B)+1))
A6 : {=WENN(SUMME(WENN(Tabelle1!B$3:B$101="";0;1/ZÄHLENWENN(Tabelle1!B$3:B$101;Tabelle1!B$3:B$101))) < ZEILE();"";INDIREKT("Tabelle1!B"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!B$3;;;ZEILE(Tabelle1!B$3:B$101));Tabelle1!B$3:B$101)=1;ZEILE(Tabelle1!B$3:B$101));ZEILE())))}
A7 : {=WENN(SUMME(WENN(Tabelle1!B$3:B$101="";0;1/ZÄHLENWENN(Tabelle1!B$3:B$101;Tabelle1!B$3:B$101))) < ZEILE();"";INDIREKT("Tabelle1!B"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!B$3;;;ZEILE(Tabelle1!B$3:B$101));Tabelle1!B$3:B$101)=1;ZEILE(Tabelle1!B$3:B$101));ZEILE())))}
A8 : {=WENN(SUMME(WENN(Tabelle1!B$3:B$101="";0;1/ZÄHLENWENN(Tabelle1!B$3:B$101;Tabelle1!B$3:B$101))) < ZEILE();"";INDIREKT("Tabelle1!B"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!B$3;;;ZEILE(Tabelle1!B$3:B$101));Tabelle1!B$3:B$101)=1;ZEILE(Tabelle1!B$3:B$101));ZEILE())))}
A9 : {=WENN(SUMME(WENN(Tabelle1!B$3:B$101="";0;1/ZÄHLENWENN(Tabelle1!B$3:B$101;Tabelle1!B$3:B$101))) < ZEILE();"";INDIREKT("Tabelle1!B"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!B$3;;;ZEILE(Tabelle1!B$3:B$101));Tabelle1!B$3:B$101)=1;ZEILE(Tabelle1!B$3:B$101));ZEILE())))}
A10 : {=WENN(SUMME(WENN(Tabelle1!B$3:B$101="";0;1/ZÄHLENWENN(Tabelle1!B$3:B$101;Tabelle1!B$3:B$101))) < ZEILE();"";INDIREKT("Tabelle1!B"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!B$3;;;ZEILE(Tabelle1!B$3:B$101));Tabelle1!B$3:B$101)=1;ZEILE(Tabelle1!B$3:B$101));ZEILE())))}
A11 : {=WENN(SUMME(WENN(Tabelle1!B$3:B$101="";0;1/ZÄHLENWENN(Tabelle1!B$3:B$101;Tabelle1!B$3:B$101))) < ZEILE();"";INDIREKT("Tabelle1!B"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!B$3;;;ZEILE(Tabelle1!B$3:B$101));Tabelle1!B$3:B$101)=1;ZEILE(Tabelle1!B$3:B$101));ZEILE())))}
A12 : {=WENN(SUMME(WENN(Tabelle1!B$3:B$101="";0;1/ZÄHLENWENN(Tabelle1!B$3:B$101;Tabelle1!B$3:B$101))) < ZEILE();"";INDIREKT("Tabelle1!B"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!B$3;;;ZEILE(Tabelle1!B$3:B$101));Tabelle1!B$3:B$101)=1;ZEILE(Tabelle1!B$3:B$101));ZEILE())))}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Tabelle1
 ABCRST
1   Komma-EierKümmer-
2StNr.Name, Vorname  werteling
3101Werner Jansen 2990
4102Johannes Jansen 901010
5103Josef Walker 50101
6104Werner Jansen 5210
7105Heinz Dirksen 5690
8106Johannes Jansen 3600
9107Willi Tammen 7050
10108Werner Jansen 50100
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Gruß Hajo

Das Forum lebt auch von den Rückmeldungen.


Bild


Betrifft: AW: mehrfachwerte aus spalten filtern und addieren von: wjansen
Geschrieben am: 15.03.2005 15:10:18

hi,

soweit so gut,

nur ein kleiner haken ist da noch!
und zwar wenn ich zwei gleiche namen untereinander eingebe kommt ein fehler!
der wird dann einfach weggelassen und als #Zahl! angezeigt und ans ende gestellt.

mfg
wjansen


 Bild

Beiträge aus den Excel-Beispielen zum Thema "mehrfachwerte aus spalten filtern und addieren"