Herbers Excel-Forum - das Archiv

Drop-Down Liste im Autofilter auslesen

Bild

Betrifft: Drop-Down Liste im Autofilter auslesen
von: Jeanne

Geschrieben am: 14.03.2005 13:38:24
Hi,
ich möchte die Drop-Down Liste zum Autofilter auslesen.
Hat jemand eine Idee? Wäre für jeden Ratschlag dankbar.
Liebe Grüße
Jeanne
Bild

Betrifft: AW: Drop-Down Liste im Autofilter auslesen
von: Holger Levetzow
Geschrieben am: 14.03.2005 14:06:39
ich glaube, dafür gibt es keine Lösung. Die Frage blieb schon oft unbeantwortet.
Holger
Bild

Betrifft: AW: Drop-Down Liste im Autofilter auslesen
von: Volker
Geschrieben am: 14.03.2005 14:19:09
Tach Jeanne,
was Du willst ist eigentlich nichts anderes als Spezialfilter ohne Doppelte, oder?
Das Ergebnis kriegst Du zwar auch nicht ohne Umwege in VBA rein, aber immerhin.
Gruß
Volker
Bild

Betrifft: AW: Drop-Down Liste im Autofilter auslesen
von: Hajo_Zi

Geschrieben am: 14.03.2005 20:11:45
Hallo Jeanne
Tabelle2
 AD
1ThomasFormel Spalte A von
2Beahttp://www.excelformeln.de/formeln.html?welcher=194
3Joannaunterschiedliche werte in Spalte A Tabelle1
4Richard 
5Ivan 
6Lukas 
716.01.03 
812.01.03 
922.03.03 
1014.01.03 
1117.01.03 
Formeln der Tabelle
A1 : {=WENN(SUMME(WENN(Tabelle1!A$2:A$101="";0;1/ZÄHLENWENN(Tabelle1!A$2:A$101;Tabelle1!A$2:A$101))) < ZEILE();"";INDIREKT("Tabelle1!A"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!A$2;;;ZEILE(Tabelle1!A$2:A$101));Tabelle1!A$2:A$101)=1;ZEILE(Tabelle1!A$2:A$101));ZEILE())))}
A2 : {=WENN(SUMME(WENN(Tabelle1!A$2:A$101="";0;1/ZÄHLENWENN(Tabelle1!A$2:A$101;Tabelle1!A$2:A$101))) < ZEILE();"";INDIREKT("Tabelle1!A"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!A$2;;;ZEILE(Tabelle1!A$2:A$101));Tabelle1!A$2:A$101)=1;ZEILE(Tabelle1!A$2:A$101));ZEILE())))}
A3 : {=WENN(SUMME(WENN(Tabelle1!A$2:A$101="";0;1/ZÄHLENWENN(Tabelle1!A$2:A$101;Tabelle1!A$2:A$101))) < ZEILE();"";INDIREKT("Tabelle1!A"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!A$2;;;ZEILE(Tabelle1!A$2:A$101));Tabelle1!A$2:A$101)=1;ZEILE(Tabelle1!A$2:A$101));ZEILE())))}
A4 : {=WENN(SUMME(WENN(Tabelle1!A$2:A$101="";0;1/ZÄHLENWENN(Tabelle1!A$2:A$101;Tabelle1!A$2:A$101))) < ZEILE();"";INDIREKT("Tabelle1!A"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!A$2;;;ZEILE(Tabelle1!A$2:A$101));Tabelle1!A$2:A$101)=1;ZEILE(Tabelle1!A$2:A$101));ZEILE())))}
A5 : {=WENN(SUMME(WENN(Tabelle1!A$2:A$101="";0;1/ZÄHLENWENN(Tabelle1!A$2:A$101;Tabelle1!A$2:A$101))) < ZEILE();"";INDIREKT("Tabelle1!A"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!A$2;;;ZEILE(Tabelle1!A$2:A$101));Tabelle1!A$2:A$101)=1;ZEILE(Tabelle1!A$2:A$101));ZEILE())))}
A6 : {=WENN(SUMME(WENN(Tabelle1!A$2:A$101="";0;1/ZÄHLENWENN(Tabelle1!A$2:A$101;Tabelle1!A$2:A$101))) < ZEILE();"";INDIREKT("Tabelle1!A"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!A$2;;;ZEILE(Tabelle1!A$2:A$101));Tabelle1!A$2:A$101)=1;ZEILE(Tabelle1!A$2:A$101));ZEILE())))}
A7 : {=WENN(SUMME(WENN(Tabelle1!A$2:A$101="";0;1/ZÄHLENWENN(Tabelle1!A$2:A$101;Tabelle1!A$2:A$101))) < ZEILE();"";INDIREKT("Tabelle1!A"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!A$2;;;ZEILE(Tabelle1!A$2:A$101));Tabelle1!A$2:A$101)=1;ZEILE(Tabelle1!A$2:A$101));ZEILE())))}
A8 : {=WENN(SUMME(WENN(Tabelle1!A$2:A$101="";0;1/ZÄHLENWENN(Tabelle1!A$2:A$101;Tabelle1!A$2:A$101))) < ZEILE();"";INDIREKT("Tabelle1!A"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!A$2;;;ZEILE(Tabelle1!A$2:A$101));Tabelle1!A$2:A$101)=1;ZEILE(Tabelle1!A$2:A$101));ZEILE())))}
A9 : {=WENN(SUMME(WENN(Tabelle1!A$2:A$101="";0;1/ZÄHLENWENN(Tabelle1!A$2:A$101;Tabelle1!A$2:A$101))) < ZEILE();"";INDIREKT("Tabelle1!A"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!A$2;;;ZEILE(Tabelle1!A$2:A$101));Tabelle1!A$2:A$101)=1;ZEILE(Tabelle1!A$2:A$101));ZEILE())))}
A10 : {=WENN(SUMME(WENN(Tabelle1!A$2:A$101="";0;1/ZÄHLENWENN(Tabelle1!A$2:A$101;Tabelle1!A$2:A$101))) < ZEILE();"";INDIREKT("Tabelle1!A"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!A$2;;;ZEILE(Tabelle1!A$2:A$101));Tabelle1!A$2:A$101)=1;ZEILE(Tabelle1!A$2:A$101));ZEILE())))}
A11 : {=WENN(SUMME(WENN(Tabelle1!A$2:A$101="";0;1/ZÄHLENWENN(Tabelle1!A$2:A$101;Tabelle1!A$2:A$101))) < ZEILE();"";INDIREKT("Tabelle1!A"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(Tabelle1!A$2;;;ZEILE(Tabelle1!A$2:A$101));Tabelle1!A$2:A$101)=1;ZEILE(Tabelle1!A$2:A$101));ZEILE())))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Bitte keine Mail, Probleme sollten im Forum gelöst werden.
Microsoft MVP für Excel
Das Forum lebt auch von den Rückmeldungen.
Betriebssystem XP Home SP2 und Excel Version 2003 SP1.


 Bild
Excel-Beispiele zum Thema "Drop-Down Liste im Autofilter auslesen"
Autofilter auch mit Ziffern von Zahlen Zellenwert als Autofilter-Kriterienwert
AutoFilter über mehrere Arbeitsblätter setzen Kopfzelle mit aktivem Autofilter markieren
Nur die sichtbaren Zellen eines AutoFilter-Bereiches einlesen Anzahl der durch Autofilter ermittelten Datensätze anzeigen
Autofilter-Kriterien über UserForm vorgeben Makroaufruf bei Betätigung des Autofilters
Autofilter-Kriterien nach dem Filtern anzeigen Kopfzeile einer Autofilter-Tabelle gelb hinterlegen