Wenn-Funktion mit Vielfachen

Bild

Betrifft: Wenn-Funktion mit Vielfachen
von: Julia Anderlein
Geschrieben am: 20.03.2005 17:47:22
Ich würde gerne eine Wenn-Funktion in Verbindung mit Vielfachen erstellen.
Diese soll sich folgendermassen gestalten:
Angenommen ich habe einen Zahlenstrahl, z.B. Jahr 0,1,2,3,...,40.
Jedem Jahr möchte ich ein und dieselbe Summe zuordnen, z.B. 200.
In einer gesonderten Zelle steht eine Zahl, z.B. 5, und in jedem 5. Jahr soll die dazugehörige Summe 600 sein. Die 600 würde ich in eine Zelle neben die 5 schreiben.
Ich hätte gerne in den Zellen, in denen eben noch die 200 steht, eine Funktion die sagt, wenn die Jahreszahl ein Vielfaches von 5 ist (also 5, 10, 15, 20,...,40), dass dann der dazugehörige Wert 600 ist; Für alle anderen Felder soll er 200 bleiben.
Dabei wäre ich gerne so flexibel, dass sich - wenn man aus der 5 z.B. eine 4 macht - der Wert zu allen Vielfachen von 4 (also 4, 8, 12, 16,..., 40) auf 600 ändert, und alle anderen Werte sind 200.
Falls jemand eine Lösung zu diesem Problem weiss, bin ich mehr als dankbar!!

Bild

Betrifft: AW: Wenn-Funktion mit Vielfachen
von: Björn B.
Geschrieben am: 20.03.2005 18:07:31
Hallo Julia,
angenommen dein Zahlenstrahl steht in den Zellen A2 (=0) bis A42 (=40). Dann schreibe in Zelle B2 =WENN(UND(A2>0;KÜRZEN(A2/5;0)=A2/5);600;200) und kopiere die Formel nach unten.
Gruß
Björn
Bild

Betrifft: Ergänzung
von: Björn B.
Geschrieben am: 20.03.2005 18:09:47
Hallo Julia,
wenn du die 5 z. B. in Zelle C2 schreibst, dann musst du in B2 =WENN(UND(A2>0;KÜRZEN(A2/$C$2;0)=A2/5);600;200) eintragen und nach unten kopieren.
Gruß
Björn
Bild

Betrifft: AW: Wenn-Funktion mit Vielfachen
von: Jörg Gradert
Geschrieben am: 20.03.2005 18:15:15
Hallo Julia,
https://www.herber.de/bbs/user/19901.xls
Wenn bei 0 die Bedingung nicht zutreffen soll, mußt Du die Formel erst in der zweiten Zeile beginnen lassen.
Gruß Jörg
Bild

Betrifft: =400+(REST(ZEILE(A1);B$1)=0)*200
von: FP
Geschrieben am: 21.03.2005 00:18:48
Hallo Julia,
in B1 steht die Zahl, die das Intervall für den Wert 600 angibt
Tabelle1
 AB
1 5
20400
31400
42400
53400
64600
75400
86400
97400
108400
119600
Formeln der Tabelle
B2 : =400+(REST(ZEILE(A1);B$1)=0)*200
B3 : =400+(REST(ZEILE(A2);B$1)=0)*200
B4 : =400+(REST(ZEILE(A3);B$1)=0)*200
B5 : =400+(REST(ZEILE(A4);B$1)=0)*200
B6 : =400+(REST(ZEILE(A5);B$1)=0)*200
B7 : =400+(REST(ZEILE(A6);B$1)=0)*200
B8 : =400+(REST(ZEILE(A7);B$1)=0)*200
B9 : =400+(REST(ZEILE(A8);B$1)=0)*200
B10 : =400+(REST(ZEILE(A9);B$1)=0)*200
B11 : =400+(REST(ZEILE(A10);B$1)=0)*200
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Servus aus dem Salzkammergut
Franz
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Wenn-Funktion mit Vielfachen"