Werte Filtern und addieren

Bild

Betrifft: Werte Filtern und addieren
von: Gerd
Geschrieben am: 23.03.2005 10:42:39
Hallo,

also ich habe eine Tabelle. In der als Artikelbeschreibung z.B. Rohre, Platten, Maschinen usw. aufgelistet sind.
Dahinter steht immer die Anzahl.
z.B.
Rohre 550
Platten 340
Rohre 225
Maschinen 670
Platten 140
Rohre 590
Wie funktioniert es, dass alle Anzahlen von den einzelnen Artikeln jetzt zusammengezählt werden. Ich suche also eine Funktion in der Art v_lookup oder so.
Zu den Daten gehörenen natürlich noch mehrere Angaben wie Hersteller usw usw., aber an sicht ist nur die commodity und anzahl entscheidend.
Hoffe jmd. kann mir helfen,
mfg
Gerd

Bild

Betrifft: AW: Werte Filtern und addieren
von: Hajo_Zi
Geschrieben am: 23.03.2005 10:45:40
Hallo Gerd,
löse es über Summenprodukt
=SUMMENPRODUKT((A1:A100<>"")*(MONAT(A1:A100)=1)*(JAHR( A1:A100)=2003)*B1:B100)
Über Spalte B wird die Summe gebildet.

Bitte keine Mail, Probleme sollten im Forum gelöst werden.
Microsoft MVP für Excel
Das Forum lebt auch von den Rückmeldungen.
Betriebssystem XP Home SP2 und Excel Version 2003 SP1.


Bild

Betrifft: =summewenn
von: c0bRa
Geschrieben am: 23.03.2005 10:48:59
hallo...
siehe datei: https://www.herber.de/bbs/user/20046.xls

Rückmeldung nicht vergessen...
c0bRa
Bild

Betrifft: AW: Werte Filtern und addieren
von: Gerd
Geschrieben am: 23.03.2005 11:04:04
Naja, aber wenn ich jetzt noch einen Wert in die Tabelle einfüge addiert er es nicht dazu.
Also versuche ich es mal besser zu erklären.
Ich habe eine Tabelle und möchte darüber ein Feld haben. Als Gesamtübersicht z.B. Pipes: "ANZAHL"
in das Feld sollen dann die Werte aus der Tabelle addiert werden.
Es geht hierbei um eine fortlaufende Liste, in der weitere "Aufträge" eingefügt werden.
Bild

Betrifft: AW: Werte Filtern und addieren
von: Hajo_Zi
Geschrieben am: 23.03.2005 11:09:57
Hallo Gerd,
wähle den Bereich groß genug.
Ansonsten lade Beispiel hoch
Gruß Hajo
Das Forum lebt auch von den Rückmeldungen.
Bild

Betrifft: AW: Werte Filtern und addieren
von: c0bRa
Geschrieben am: 23.03.2005 11:11:20
hallo nochmal...
also mit =summewenn(A:A;A1;B:B) addiert er den mit sicherheit dazu... du musst nur auf die bereichsgrenzen achten... A:A ist die komplette spalte... A1:A10 ist A1 bis A10. ich denk mal da liegt irgendwo dein fehler...

Rückmeldung nicht vergessen...
c0bRa
Bild

Betrifft: AW: Werte Filtern und addieren
von: Gerd
Geschrieben am: 23.03.2005 11:19:00
ich bitte um entschuldigung, das hat echt geklappt. hatte mich in dr tat mit den zeilen verhauen, weil die funktion in der gleichen zeile war wie die daten. danke! es klappt jetzt sehr gut!
Gruß,
Gerd
Bild

Betrifft: np ;)
von: c0bRa (oT)
Geschrieben am: 23.03.2005 11:31:47

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Werte Filtern und addieren"