Formelsuche

Bild

Betrifft: Formelsuche von: Josef
Geschrieben am: 23.03.2005 12:58:44

Hallo!

Ich hab in Zelle A1 die Zahl 1538300 stehen.

Ich bräuchte bitte jetzt unten stehende 2 Formeln in einer Formel:

=LINKS(A1;6) Ergebnis sind die ersten 6 Zahlen
=REST(B1;7) die ersten 6 Zahlen durch 7 ergeben den Rest 5

Also wenn A1 = 1538300 dann sollte in B1 1538305 stehen.


Danke

Josef

Bild


Betrifft: =(links(a1;6)&rest(b1;7))*1 von: c0bRa (oT)
Geschrieben am: 23.03.2005 13:05:11




Bild


Betrifft: AW: =(links(a1;6)&rest(links(a1;6);7))*1 von: so natürlich: (c0bRa)
Geschrieben am: 23.03.2005 13:06:14




Bild


Betrifft: AW: =(links(a1;6)&rest(links(a1;6);7))*1 von: so natürlich: (c0bRa)
Geschrieben am: 23.03.2005 13:06:17




Bild


Betrifft: AW: =(links(a1;6)&rest(b1;7))*1 von: MRP
Geschrieben am: 23.03.2005 13:08:01

Hmm, wozu das *1 wenn ich fragen darf ??
Ciao
Manu


Bild


Betrifft: AW: =(links(a1;6)&rest(b1;7))*1 von: c0bRa
Geschrieben am: 23.03.2005 13:09:50

um die als text gegebene zahl in eine echte zahl umzuwandeln :)

+0 oder *1 bewirkt das ;)

sosnt spinnen manche funktionen rum (siehe 30% der SVERWEIS-Probleme hier im Forum), alles nur wegen einer als text formatierten zahl...

c0bRa


Bild


Betrifft: AW: =(links(a1;6)&rest(b1;7))*1 von: MRP
Geschrieben am: 23.03.2005 13:19:25

Hey c0bRa,
herzlichen Dank für die Info!
Ich hab nur getestet, ob ich mit der Zelle weiterrechnen kann, und das funzte. Hab jetzt das mit dem SVERWEIS geprüft, und du hast recht es kommt #NV.
Danke nochmal, und schönen Tag noch
Manu


Bild


Betrifft: =LINKS(A1;6)&REST(LINKS(A1;6);7) von: MRP
Geschrieben am: 23.03.2005 13:05:19

Hallo Josef,
=LINKS(A1;6)&REST(LINKS(A1;6);7)
Ciao
Manuele Rocco Parrino


Bild


Betrifft: AW: =LINKS(A1;6)&REST(LINKS(A1;6);7) von: Josef
Geschrieben am: 23.03.2005 13:15:13

Hallo!

Besten Dank an alle.
Wenn in der Zelle A1 kein Wert vorhanden wäre dann kommt die Meldung #WERT.
Kann man diese Meldung vielleicht auch noch wegbringen?

Danke


Josef


Bild


Betrifft: =WENN(A1="";"";LINKS(A1;6)&REST(LINKS(A1;6);7)*1) von: c0bRa (oT)
Geschrieben am: 23.03.2005 13:17:06




Bild


Betrifft: AW: Fehler! von: FP
Geschrieben am: 23.03.2005 22:10:26

Hallo,

Klammern falsch gesetzt - so bleibt das Ergebnis Text:

=WENN(A1="";"";LINKS(A1;6)&REST(LINKS(A1;6);7)*1)

so nicht ;-)

=WENN(A1="";"";(LINKS(A1;6)&REST(LINKS(A1;6);7))+0)

kürzer ist aber auf jeden Fall:

=(LINKS(A1;6)&REST(LINKS(A1&"000000";6);7))+0


Servus aus dem Salzkammergut
Franz


Bild


Betrifft: DANKE FÜR DIE LÖSUNGEN von: Josef
Geschrieben am: 27.03.2005 22:49:45

o.T.


Bild


Betrifft: =(LINKS(A1;6)&REST(LINKS(A1&"000000";6);7))+0 von: FP
Geschrieben am: 23.03.2005 22:01:27

Hallo Sepp,

etwas kürzer :-)

Servus aus dem Salzkammergut
Franz


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Makros aus Arbeitsmappe löschen"