wenn

  • wenn von Hokweb vom 23.03.2005 20:22:59
    • AW: wenn - von Hajo_Zi am 23.03.2005 20:26:14
    • AW: wenn - von Peter W am 23.03.2005 20:26:53
    • AW: wenn - von c0bRa am 24.03.2005 09:22:11
Bild

Betrifft: wenn
von: Hokweb
Geschrieben am: 23.03.2005 20:22:59
Hallo,
ich habe eine "Wenn" Funktion aber leider reicht mir die Anzahl der "Verschachtelungen" nicht Was kann ich tuen??
Hokweb

Bild

Betrifft: AW: wenn
von: Hajo_Zi
Geschrieben am: 23.03.2005 20:26:14
Hallo Hockweb,
bnutze eine Verweisfunktion z.B. Sverweis.
Mehr als 7 Ebenen bei wenn
Eine Formel kann bis zu sieben Ebenen einer verschaltelter Funktion enthalten.
http://www.excelformeln.de/formeln.html?welcher=128
=WENN(A1=1;1;WENN(A1=2;2;WENN(A1=3;3;WENN(A1=4;4;WENN(A1=5;5;WENN(A1=6;6;WENN(A1=7;7;)))))))+WENN(A1=8;8;WENN(A1=9;9;WENN(A1=10;10;WENN(A1=11;11;WENN(A1=12;12;)))))
von WF
Die Grenze liegt bei 1024 Zeichen für die Formel.

Bitte keine Mail, Probleme sollten im Forum gelöst werden.
Microsoft MVP für Excel
Das Forum lebt auch von den Rückmeldungen.
Betriebssystem XP Home SP2 und Excel Version 2003 SP1.


Bild

Betrifft: AW: wenn
von: Peter W
Geschrieben am: 23.03.2005 20:26:53
Servus,
ohne genauere Beschreibung was du erreichen willst, wird dir keiner helfen können.
Möglichkeiten wie und / oder /usw. gibts genug.
MfG
Peter
Bild

Betrifft: AW: wenn
von: Hokweb
Geschrieben am: 23.03.2005 20:45:34
Mein Problem stellt sich so dar:
in Spalte A habe ich 12 Zeile mit verschiedenen Auswahlmöglichkeiten in Spalte B sind 20 verschiedene Unterpunkte welche unterschiedlich zugeordnet werden sollen.
Diese gesamten Einstellungen sind ausgeblendet.
Nun habe ich in Spalte A Zeile 20 ein Feld eingerichtet in welchem durch "Gültigkeit" die weiter oben gelisteten Einträge eingefügt werden können.
in der Spalte B Zeile 20 bis 26 sollen je nach dem was in Spalte A ausgewählt wird die Unterpunkte angezeigt werden.
Ich hoffe das ist irgend wie begreiflich.
MfG
Hokweb
Bild

Betrifft: AW: wenn
von: Andy
Geschrieben am: 24.03.2005 06:49:44
Hallo,
Du kannst mehrere Wenn Verschachteln. Du musst nur nach den ersten paar WENN-Bedingungen ein '+' einfügen und von neuem beginnen. Beispiel siehe unten:
WENN(A2="A";$C$3;WENN(A2="B";$C$4;WENN(A2="C";$C$5;WENN(A2="D";$C$6))))+WENN(A2="E";$C$7;WENN(A2="F";$C$8;WENN(A2="G";$C$9;WENN(A2="H";$C$10))))+WENN(A2="I";$C$11;WENN(A2="J";$C$12;WENN(A2="K";$C$13;WENN(A2="L";$C$14)))) usw.
Hier wird geprüft was in Spalte A steht und dann eben der entsprechende Wert aus Spalte C eingesetzt. Hoffe, dass ist das was du gesucht hast.
Andy
Bild

Betrifft: AW: wenn
von: c0bRa
Geschrieben am: 24.03.2005 09:22:11
hallo...
ich hab mal was gebastelt, so wie ichs mir vorstell, was du willst ;)
https://www.herber.de/bbs/user/20114.xls

Rückmeldung nicht vergessen...
c0bRa
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Hyperlinks auslesen in Spalte B ?"