vermutlich eine verschachtelte "wenn"-funktion

Bild

Betrifft: vermutlich eine verschachtelte "wenn"-funktion von: Erwin
Geschrieben am: 29.03.2005 09:41:50

Hallo alle zusammen.
Folgende Frage:
Vorhanden sind 4 Spalten.
1.Spalte Name (Artikel)
2.Spalte Wert (z.B. 1,00)
3.Spalte Wert (z.B. 2,00)
4.Spalte Wert (z.B. 1,00)
in der 5. Spalte soll aufgrund der Werte der Spalten 2,3 oder 4 ein Text stehen.
Wobei die Werte in den Spalten 2,3 und 4 kleiner, größer oder auch gleich sein können.
Eigentlich soll es eine Preisvergleichstabelle werden, wo statt dem Preis ein Lieferantenname in der 5. Spalte stehen soll. Wenn bei einem Artikel 2 oder mehr Lieferanten den gleichen Preis haben, sollten auch beide (oder alle 3) Namen in der 5. Spalte stehen.
Das geht sicher mit einer verschachtelten „wenn-Funktion“, aber wie genau das gehen soll bin ich überfragt.
Ich ersuche die Spezialisten um Hilfe, war mit der gleichen Frage schon einmal da (siehe Paket 580to584)

Bild


Betrifft: AW: vermutlich eine verschachtelte "wenn"-funktion von: Frank Domke
Geschrieben am: 29.03.2005 10:24:10


=WENN(B3<C3;WENN(B3<D3;"SpalteB";"SpalteC");WENN(C3<D3;"SpalteC";"SpalteD"))

Es gibt sicherlich noch elegantere Lösungen, aber die o.g. müsste funktionieren. Ausnahme, wenn zwei gleiche Preise angegeben werden, wird nur ein Wert angezeigt!
Viel Erfolg
Frank.


Bild


Betrifft: AW: vermutlich eine verschachtelte "wenn"-funktion von: Martin Beck
Geschrieben am: 29.03.2005 10:34:28

Hallo Erwin,

eine gute Frage ist die halbe Antwort. Du schreibst "wo statt dem Preis ein Lieferantenname in der 5. Spalte stehen soll". Das schreit nach SVERWEIS, aber alle hier rätseln, wo denn die Lieferantennamen herkommen sollen. :-(

Beschreibe den Tabellenaufbau noch einmal genauer.

Gruß
Martin Beck


Bild


Betrifft: AW: vermutlich eine verschachtelte "wenn"-funktion von: Erwin
Geschrieben am: 31.03.2005 10:58:04

Hallo Martin,
so wie Hermann und Franz (gleichzeitig DANKE) die Tabelle darstellen habe ich sie mir vorgestellt. Ich werde das mal ausprobieren - falls es Probleme gibt melde ic mich wieder! Nochmals Danke!
Erwin


Bild


Betrifft: AW: vermutlich eine verschachtelte "wenn"-funktion von: HermannZ
Geschrieben am: 29.03.2005 10:40:53

Hallo Erwin,

suchst du sowas;

Summe
 ABCDEFGHI
2154Angebotsvergleich        
2155         
2156         
2157 Firma AFirma BFirma C Niederigster   
2158     Preis   
2159Artikel 1125115115 115Firma CFirma B 
2160Artikel 2234256267 234Firma A  
2161Artikel 3167178189 167Firma A  
2162Artikel 4289289289 289Firma CFirma BFirma A
2163Artikel 5567543543 543Firma CFirma B 
2164         
2165     Formel nach unten und nach rechts kopieren
Formeln der Tabelle
F2159 : =MIN(B2159;C2159;D2159)
G2159 : {=WENN(KGRÖSSTE(($B2159:$D2159=$F2159)*SPALTE($A$1:$C$1);SPALTE(A1))=0;"";INDEX($B$2157:$D$2157;1;KGRÖSSTE(($B2159:$D2159=$F2159)*SPALTE($A$1:$C$1);SPALTE(A1))))}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß hermann


Bild


Betrifft: AW: vermutlich eine verschachtelte "wenn"-funktion von: Erwin
Geschrieben am: 31.03.2005 10:59:35

Hallo Hermann!
Sieht echt toll aus, ich werde das mal ausprobieren - falls es Probleme gibt melde ich mich wieder!
Danke!
Erwin


Bild


Betrifft: AW: ne, INDEX, KGRÖSSTE, ZÄHLENWENN von: FP
Geschrieben am: 29.03.2005 11:33:30

Hallo Erwin,

und geordnet nach Fundstelle von links nach rechts:

Tabelle3
 ABCDEFGHI
1 Firma AFirma BFirma C Niederigster
Preis
Firma1Firma2Firma3
2Artikel 1125,00 115,00 115,00  115,00 Firma BFirma C 
3Artikel 2234,00 256,00 267,00  234,00 Firma A  
4Artikel 3167,00 178,00 189,00  167,00 Firma A  
5Artikel 4289,00 289,00 289,00  289,00 Firma AFirma BFirma C
6Artikel 5567,00 543,00 543,00  543,00 Firma BFirma C 
Formeln der Tabelle
F2 : =MIN(B2:D2)
G2 : {=WENN(SPALTE(A2)>ZÄHLENWENN($B2:$D2;$F2);"";INDEX($1:$1;KKLEINSTE(WENN($B2:$D2=$F2;SPALTE($B2:$D2));SPALTE(A2))))}
H2 : {=WENN(SPALTE(B2)>ZÄHLENWENN($B2:$D2;$F2);"";INDEX($1:$1;KKLEINSTE(WENN($B2:$D2=$F2;SPALTE($B2:$D2));SPALTE(B2))))}
I2 : {=WENN(SPALTE(C2)>ZÄHLENWENN($B2:$D2;$F2);"";INDEX($1:$1;KKLEINSTE(WENN($B2:$D2=$F2;SPALTE($B2:$D2));SPALTE(C2))))}
F3 : =MIN(B3:D3)
G3 : {=WENN(SPALTE(A3)>ZÄHLENWENN($B3:$D3;$F3);"";INDEX($1:$1;KKLEINSTE(WENN($B3:$D3=$F3;SPALTE($B3:$D3));SPALTE(A3))))}
H3 : {=WENN(SPALTE(B3)>ZÄHLENWENN($B3:$D3;$F3);"";INDEX($1:$1;KKLEINSTE(WENN($B3:$D3=$F3;SPALTE($B3:$D3));SPALTE(B3))))}
I3 : {=WENN(SPALTE(C3)>ZÄHLENWENN($B3:$D3;$F3);"";INDEX($1:$1;KKLEINSTE(WENN($B3:$D3=$F3;SPALTE($B3:$D3));SPALTE(C3))))}
F4 : =MIN(B4:D4)
G4 : {=WENN(SPALTE(A4)>ZÄHLENWENN($B4:$D4;$F4);"";INDEX($1:$1;KKLEINSTE(WENN($B4:$D4=$F4;SPALTE($B4:$D4));SPALTE(A4))))}
H4 : {=WENN(SPALTE(B4)>ZÄHLENWENN($B4:$D4;$F4);"";INDEX($1:$1;KKLEINSTE(WENN($B4:$D4=$F4;SPALTE($B4:$D4));SPALTE(B4))))}
I4 : {=WENN(SPALTE(C4)>ZÄHLENWENN($B4:$D4;$F4);"";INDEX($1:$1;KKLEINSTE(WENN($B4:$D4=$F4;SPALTE($B4:$D4));SPALTE(C4))))}
F5 : =MIN(B5:D5)
G5 : {=WENN(SPALTE(A5)>ZÄHLENWENN($B5:$D5;$F5);"";INDEX($1:$1;KKLEINSTE(WENN($B5:$D5=$F5;SPALTE($B5:$D5));SPALTE(A5))))}
H5 : {=WENN(SPALTE(B5)>ZÄHLENWENN($B5:$D5;$F5);"";INDEX($1:$1;KKLEINSTE(WENN($B5:$D5=$F5;SPALTE($B5:$D5));SPALTE(B5))))}
I5 : {=WENN(SPALTE(C5)>ZÄHLENWENN($B5:$D5;$F5);"";INDEX($1:$1;KKLEINSTE(WENN($B5:$D5=$F5;SPALTE($B5:$D5));SPALTE(C5))))}
F6 : =MIN(B6:D6)
G6 : {=WENN(SPALTE(A6)>ZÄHLENWENN($B6:$D6;$F6);"";INDEX($1:$1;KKLEINSTE(WENN($B6:$D6=$F6;SPALTE($B6:$D6));SPALTE(A6))))}
H6 : {=WENN(SPALTE(B6)>ZÄHLENWENN($B6:$D6;$F6);"";INDEX($1:$1;KKLEINSTE(WENN($B6:$D6=$F6;SPALTE($B6:$D6));SPALTE(B6))))}
I6 : {=WENN(SPALTE(C6)>ZÄHLENWENN($B6:$D6;$F6);"";INDEX($1:$1;KKLEINSTE(WENN($B6:$D6=$F6;SPALTE($B6:$D6));SPALTE(C6))))}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Servus aus dem Salzkammergut
Franz


Bild


Betrifft: AW: ne, INDEX, KGRÖSSTE, ZÄHLENWENN von: Erwin
Geschrieben am: 31.03.2005 11:01:44

Hallo Franz,
vorerst mal Danke. Sieht im Vergleich zur der Version von Hermann etwas kompliziert (für mich!) aus, werde es aber mal ausprobieren. Wenn ich nicht mehr weiterkomme, dann melde ich mich wieder.
Erwin


Bild


Betrifft: AW: ne, INDEX, KGRÖSSTE, ZÄHLENWENN von: Erwin
Geschrieben am: 31.03.2005 14:30:46

Hallo Franz,
habe deine Version getestet, klappt auch aber leider nur in den Zellen F2 bis F6.
G2,H2,I2 geht nicht. Fehlermeldung: #WERT!. Habe die Formeln über die Zwischenablage in die jeweilige Zelle kopiert. War das falsch?
Frage: warum nimmst Du in der Zelle G2 Bezug auf B2+D2+F2?
Hoffe Du kannst die angehängte Datei öffnen.
https://www.herber.de/bbs/user/20432.xls
Falls nicht:
Lief1 Lief2 Lief3 Preis
Artikel 1 125 115 115 115 #WERT! #WERT!
Artikel 2 234 256 267 234 Firma A
Artikel 3 167 178 189 167 Firma A
Artikel 4 289 289 289 289 Firma A Firma B Firma C
Artikel 5 567 543 543 543 Firma B Firma C

Zelle A1 = leer
Spalte A ab A2 der Artikel.
Zelle B1 = Lieferantenname z.B. Lief1
Zelle C1 = Lieferantenname z.B. Lief2
Zelle D1 = Lieferantenname z.B. Lief3
Spalte B ab B2 der jeweilige Preis für den Artikel aus Spalte A für den Lieferanten der in B1 steht.
Spalte C ab C2 der jeweilige Preis für den Artikel aus Spalte A für den Lieferanten der in C1 steht.
Spalte D ab D2 der jeweilige Preis für den Artikel aus Spalte A für den Lieferanten der in D1 steht.
In der Zelle F2 steht der günstigste Preis aus B1 bis D1
In der Zelle G2 (eventuell G2, E2 und F2) sollte der/die Lieferant(en) stehen (Lieferntenname kommt aus Zellen B1, C1 und D1) der/die die günstigsten Preise hat.

Hoffe Du kennst Dich aus was ich mir so vorstelle. Können wir auch direkt mailen?
erwin.thomaier@lycos.at

Danke
Erwin


Bild


Betrifft: AW: ne, INDEX, KGRÖSSTE, ZÄHLENWENN von: HermannZ
Geschrieben am: 01.04.2005 10:21:28

Hallo Erwin,

wenn du die Formel richtig einsetzt bzw. richtig übernimmst dann geht das auch.
siehe Beispiel;

Summe
 ABCDEFGHI
2224         
2225 Lief1Lief2Lief3 Preis   
2226Artikel 1125115115 115Lief2Lief3 
2227Artikel 2234256267 234Lief1  
2228Artikel 3167178189 167Lief1  
2229Artikel 4289289289 289Lief1Lief2Lief3
2230Artikel 5567543543 543Lief2Lief3 
Formeln der Tabelle
G2226 : {=WENN(SPALTE(A2226)>ZÄHLENWENN($B2226:$D2226;$F2226);"";INDEX($A$2225:$D$2225;KKLEINSTE(WENN($B2226:$D2226=$F2226;SPALTE($B2226:$D2226));SPALTE(A2226))))}
H2226 : {=WENN(SPALTE(B2226)>ZÄHLENWENN($B2226:$D2226;$F2226);"";INDEX($A$2225:$D$2225;KKLEINSTE(WENN($B2226:$D2226=$F2226;SPALTE($B2226:$D2226));SPALTE(B2226))))}
I2226 : {=WENN(SPALTE(C2226)>ZÄHLENWENN($B2226:$D2226;$F2226);"";INDEX($A2225:$D2225;KKLEINSTE(WENN($B2226:$D2226=$F2226;SPALTE($B2226:$D2226));SPALTE(C2226))))}
G2227 : {=WENN(SPALTE(A2227)>ZÄHLENWENN($B2227:$D2227;$F2227);"";INDEX($A$2225:$D$2225;KKLEINSTE(WENN($B2227:$D2227=$F2227;SPALTE($B2227:$D2227));SPALTE(A2227))))}
G2228 : {=WENN(SPALTE(A2228)>ZÄHLENWENN($B2228:$D2228;$F2228);"";INDEX($A$2225:$D$2225;KKLEINSTE(WENN($B2228:$D2228=$F2228;SPALTE($B2228:$D2228));SPALTE(A2228))))}
G2229 : {=WENN(SPALTE(A2229)>ZÄHLENWENN($B2229:$D2229;$F2229);"";INDEX($A$2225:$D$2225;KKLEINSTE(WENN($B2229:$D2229=$F2229;SPALTE($B2229:$D2229));SPALTE(A2229))))}
H2229 : {=WENN(SPALTE(B2229)>ZÄHLENWENN($B2229:$D2229;$F2229);"";INDEX($A$2225:$D$2225;KKLEINSTE(WENN($B2229:$D2229=$F2229;SPALTE($B2229:$D2229));SPALTE(B2229))))}
I2229 : {=WENN(SPALTE(C2229)>ZÄHLENWENN($B2229:$D2229;$F2229);"";INDEX($A$2225:$D$2225;KKLEINSTE(WENN($B2229:$D2229=$F2229;SPALTE($B2229:$D2229));SPALTE(C2229))))}
G2230 : {=WENN(SPALTE(A2230)>ZÄHLENWENN($B2230:$D2230;$F2230);"";INDEX($A$2225:$D$2225;KKLEINSTE(WENN($B2230:$D2230=$F2230;SPALTE($B2230:$D2230));SPALTE(A2230))))}
H2230 : {=WENN(SPALTE(B2230)>ZÄHLENWENN($B2230:$D2230;$F2230);"";INDEX($A$2225:$D$2225;KKLEINSTE(WENN($B2230:$D2230=$F2230;SPALTE($B2230:$D2230));SPALTE(B2230))))}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß Hermann


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Wertebereich Balkendiagramm ansteuern VBA"