Falsche Summen/Division

Bild

Betrifft: Falsche Summen/Division von: Michael
Geschrieben am: 29.03.2005 17:06:17

Hallo,

ich habe dieses Problem heute schon mal ins Forum gestellt, aber ich komme
noch nicht weiter. Folgende Formel ermittelt für mich die Division aus zwei
Bereichssummen, wobei die Summenbereiche variabel ermittelt werden.

=SUMME(INDIREKT("Tabelle1!"&ADRESSE(SVERWEIS(($C$36&$C43);Tabelle1!$234:$400;2;FALSCH);7)&":"&ADRESSE(SVERWEIS(($C$36&$C43);Tabelle1!$234:$400;2;FALSCH);Tabelle1!$D$378+6)))*1000/SUMME(INDIREKT("Tabelle2!"&ADRESSE(SVERWEIS(($B$36&$B43);Tabelle2!$113:$200;2;FALSCH);6;)&":"&ADRESSE(SVERWEIS(($B$36&$B43);Tabelle2!$113:$200;2;FALSCH);Tabelle1!$D$378+5)))*0,5

Ich habe die Formel schrittweise aufgebaut. Die erste Summenformel ergibt:

13825000

Dies wird auch als Ergebnis der Zelle angezeigt.

Die zweite Summe ergibt:

87809

Auch dieser Wert wird so angezeigt, wenn ich die Formel einzeln eingebe.

Die Division müsste also nach Adam Riese 157,444 ergeben!

Als Ergebnis der o. g. Formel erscheint aber: 39,361!!

Die Bereiche, in denen die zu summierenden Daten stehen sind komplett als
Zahl formatiert.

Wer weiß Rat??

Viele Grüße

Michael

Bild


Betrifft: Neuer Thread muss nicht sein von: Boris
Geschrieben am: 29.03.2005 17:11:55

Hi Michael,

...dennoch hier der Hinweis: Lad mal das Beispiel hoch.

Grüße Boris


Bild


Betrifft: AW: Neuer Thread muss nicht sein von: Michael
Geschrieben am: 29.03.2005 17:44:14

Hallo Boris,

hier das Beispiel mit den betreffenden Daten. Habe die Tabelle sehr abgespeckt, aber der Fehler tritt immer noch auf.

Wenn Du Dir die Daten ansiehst, stellst Du fest, dass die 39 auf dem dritten Tabellenblatt nicht der korrekte Wert der Formel sein können.

https://www.herber.de/bbs/user/20343.xls

Viele Grüße

Michael


Bild


Betrifft: Ein ganz einfacher Klammerfehler... von: Boris
Geschrieben am: 29.03.2005 17:52:25

Hi Michael,

=SUMME(INDIREKT("Tabelle1!"&ADRESSE(SVERWEIS(($C$16&$C17);Tabelle1!$14:$28;2;FALSCH);7)&":"&ADRESSE(SVERWEIS(($C$16&$C17);Tabelle1!$14:$28;2;FALSCH);Tabelle1!$D$27+6)))*1000/(SUMME(INDIREKT("Tabelle2!"&ADRESSE(SVERWEIS(($B$16&$B17);Tabelle2!$29:$31;2;FALSCH);6;)&":"&ADRESSE(SVERWEIS(($B$16&$B17);Tabelle2!$29:$31;2;FALSCH);Tabelle1!$D$27+5)))*0,5)

Die fetten Klammern hab ich dazugesetzt - und schon kommt auch 157 raus...

Grüße Boris


Bild


Betrifft: AW: Ein ganz einfacher Klammerfehler... von: Michael
Geschrieben am: 29.03.2005 17:56:36

Hallo Boris,

danke für Deine Hilfe. Allerdings bin ich sehr überrascht. Ich habe die gleiche Formel, wie in dem Beispiel in der Tabelle ein paar Zeilen weiter oben stehen und da funzt die ohne diese Klammern!!!

Das gibt es doch gar nicht, oder?

Viele Grüße

Michael


Bild


Betrifft: Es ist doch wohl ein Unterschied,... von: Boris
Geschrieben am: 29.03.2005 18:00:19

Hi Michael,

...ob ich =10/5*0,5 oder =10/(5*0,5) rechne - insofern schenke ich deiner Aussage

Ich habe die gleiche Formel, wie in dem Beispiel in der Tabelle ein paar Zeilen weiter oben stehen und da funzt die ohne diese Klammern!!!

keinen uneingeschränkten Glauben ;-)

Grüße Boris


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Falsche Summen/Division"