Formel oder Makro für Filter

Bild

Betrifft: Formel oder Makro für Filter
von: Max K.
Geschrieben am: 30.03.2005 19:26:11
Hallo,
es heißt ja immer....nichts ist unmöglich....;-))
In einem Formular werden oben in einer Zelle (Platzmangel, schmale Spalte)Namen eingegeben: bspw. "Manfred Meier und Gertrud Schmitz" (zusammenhängend).
Kann Excel per Makro oder Formel den Text vor dem "und", nämlich "Manfred Meier" und den Text nach dem "und", nämlich "Gertrud Schmitz" zu 2 anderen Zellen auf dem Blatt (Unterschriftsfelder) transportieren?
Falls das geht, ließe sich die Lösung auch erweitern für den Fall dass es kein
"und" gibt weil "Manfred Meier" oder "Gertrud Schmitz" alleine gekommen sind?
Ich habe leider nur eine Zelle für den Namenseintrag, daher brauche ich so eine
merkwürdige Lösung. Die Alternative ist, immer alles doppelt zu schreiben.
Vielleicht klappt es ja.
Vielen Dank schonmal für`s Nachdenken!
Gruß
Max

Bild

Betrifft: AW: Formel oder Makro für Filter
von: Josef Ehrensberger
Geschrieben am: 30.03.2005 19:42:16
Hallo Max!
Mit Formel z.b. so.
Tabelle1
 ABC
1Hans Rundum und Gertrund MüllerHans RundumGertrund Müller
Formeln der Tabelle
B1 : =WENN(ISTZAHL(FINDEN(" und ";A1));GLÄTTEN(LINKS(A1;FINDEN(" und ";A1)-1));A1)
C1 : =WENN(ISTZAHL(FINDEN(" und ";A1));GLÄTTEN(TEIL(A1;FINDEN(" und ";A1)+5;99));"")
 


Gruß Sepp

P.S.: Rückmeldung nicht vergessen!


Bild

Betrifft: AW: Formel oder Makro für Filter
von: Max K.
Geschrieben am: 30.03.2005 19:58:01
Hallo Sepp,
vielen Dank für die tolle Formel! Ich halte sowas ja für Zauberei.........;-))
Demnächst macht Excel mir noch das Frühstück.
Eine Nachfrage habe ich noch: Wenn jemand das "und" abkürzt mit "u." weil "Ludger
Müller-Lüdenscheid und Hermine Freifrau von Hohenstolz" kommt, läßt sich das mit in
die Formel einbauen oder ist das "und" ein Muß?
Falls ja, dürfen die zwei von oben eben nie kommen.............
Gruß
Max
Bild

Betrifft: AW: Formel oder Makro für Filter
von: Josef Ehrensberger
Geschrieben am: 30.03.2005 20:12:54
Hallo Max!
Geht auch!
Vieleicht kanns einer der Experten auch kürzer.
Tabelle1
 ABC
1Hans Rundum und Gertrund MüllerHans RundumGertrund Müller
2Ludger Müller-Lüdenscheid u. Hermine Freifrau von HohenstolzLudger Müller-LüdenscheidHermine Freifrau von Hohenstolz
Formeln der Tabelle
B1 : =WENN(ISTZAHL(FINDEN(" und ";A1));GLÄTTEN(LINKS(A1;FINDEN(" und ";A1)-1));WENN(ISTZAHL(FINDEN(" u. ";A1));GLÄTTEN(LINKS(A1;FINDEN(" u. ";A1)-1));A1))
C1 : =WENN(ISTZAHL(FINDEN(" und ";A1));GLÄTTEN(TEIL(A1;FINDEN(" und ";A1)+5;99));WENN(ISTZAHL(FINDEN(" u. ";A1));GLÄTTEN(TEIL(A1;FINDEN(" u. ";A1)+3;99));""))
B2 : =WENN(ISTZAHL(FINDEN(" und ";A2));GLÄTTEN(LINKS(A2;FINDEN(" und ";A2)-1));WENN(ISTZAHL(FINDEN(" u. ";A2));GLÄTTEN(LINKS(A2;FINDEN(" u. ";A2)-1));A2))
C2 : =WENN(ISTZAHL(FINDEN(" und ";A2));GLÄTTEN(TEIL(A2;FINDEN(" und ";A2)+5;99));WENN(ISTZAHL(FINDEN(" u. ";A2));GLÄTTEN(TEIL(A2;FINDEN(" u. ";A2)+3;99));""))
 


Gruß Sepp

P.S.: Rückmeldung nicht vergessen!


Bild

Betrifft: AW: Formel oder Makro für Filter (erledigt)
von: Max K.
Geschrieben am: 30.03.2005 20:22:34
Hallo Sepp,
bin sprachlos.....und dankbar für deine Hilfe ;-)))))
Gruß
Max
Bild

Betrifft: AW: Formel oder Makro für Filter
von: Peter W
Geschrieben am: 30.03.2005 19:57:20
Servus,
So müssts gehen, jetzt kommt sowie so gleich wieder ein Formelexperte mit ner Formel die nur 5stellig ist oder so ;)
Excel Jeanie HTML
Formeln der Tabelle
A3 : =WENN(ISTFEHLER(SUCHEN("und";A1));LINKS(A1;FINDEN(" ";A1)-2);LINKS(A1;SUCHEN("und";A1)-2))&" "&WENN(ISTFEHLER(SUCHEN("und";A1));RECHTS(A1;FINDEN(" ";A1)-3);RECHTS(A1;SUCHEN("und";A1)-3))
B3 : =WENN(ISTFEHLER(SUCHEN("und";B1));LINKS(B1;FINDEN(" ";B1)-1);LINKS(B1;SUCHEN("und";B1)-1))&" "&WENN(ISTFEHLER(SUCHEN("und";B1));RECHTS(B1;FINDEN(" ";B1)-3);RECHTS(B1;SUCHEN("und";B1)-3))
  Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
MfG
Peter
Bild

Betrifft: AW: Formel oder Makro für Filter
von: Max K.
Geschrieben am: 30.03.2005 20:09:56
Hallo Peter,
vielen Dank für deine Formel!
Nicht verzagen, es gibt - wie so oft - immer mehrere Lösungen für ein Problem.
Allerdings haben Leute wie ich (die hier fragen) meistens gar keine Lösung und
machen immer ein kleines Freudentänzchen wenn jemand antwortet.
Danke!
Gruß
Max
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Formel oder Makro für Filter"