Summenprodukt Autofilter

Bild

Betrifft: Summenprodukt Autofilter von: LordFaber
Geschrieben am: 31.03.2005 14:38:23

Hallo zusammmen,

habe da ein Problem bei der Kombination Summenprodukt und Teilergebnis bei dem ich dringend Hilfe benötige.

In meiner Tabelle gibt es drei Spalten:
A=Produkt (a,b,c);
B=Preis/Stück für die Bauteile die in eines der drei Produkte einfließen; C=Anzahl je Stück der Bauteile die benötigt werden

Gefiltert wird nach Spalte A, als Ergebnis sollen die Gesamtkosten je Produkt gebildet werden. Habe mir auch schon mal von Boris, danke erstmal, ne Formel bekommen, aber die funktioniert nicht richtig. Diese funktioniert nur dann wenn das zu filternde Produkt in der ersten Spalte steht, sobald ein zu filterndes Produkt in Zeile5 steht kommt die #ZAHL Fehlermeldung.
Die Formel ist:
=SUMMENPRODUKT((C2:C10=INDEX(C:C;MIN(WENN(TEILERGEBNIS(3;INDIREKT("C"&ZEILE(2:10)));ZEILE(2:10)))))*A2:A10*B2:B10)

Am besten wäre, wenn unabhängt von dem Produkt nur das teilergebnis/summenprodukt von Spalte B und C gebildet werden würde, aber das geht glaube ich nicht

Wäre dankbar wenn mir da jemand helfen könnte!

Bild


Betrifft: AW: Summenprodukt Autofilter von: Boris
Geschrieben am: 31.03.2005 14:48:40

Hi,

lad mal ne Beispieltabelle hoch und trag dort händisch die gewünschten Ergebnisse ein.

Grüße Boris


Bild


Betrifft: AW: Summenprodukt Autofilter von: LordFaber
Geschrieben am: 31.03.2005 15:06:52

https://www.herber.de/bbs/user/20433.xls


ein Ergebnis kommt wie schon gesagt nur für das oberste Produkt der Liste unabhänig vom Filter raus.
Danke und Gruß

Fabian


Bild


Betrifft: Siehe Antwort von Ingo... von: Boris
Geschrieben am: 31.03.2005 15:09:58

Hi Fabian,

...seinerzeit ging es aber daraum, den ersten gefilterten Wert auszulesen - das ist hier ja jetzt nichtmehr der Fall.
Ingos Lösung reicht dann aus.
Alternativ solltest du mal über eine Pivottabelle nachdenken - ist viel übersichtlicher.

Grüße Boris


Bild


Betrifft: ...bzw. deine Formel in F1 - die passt doch! oT von: Boris
Geschrieben am: 31.03.2005 15:11:08




Bild


Betrifft: AW: Summenprodukt Autofilter von: IngoG
Geschrieben am: 31.03.2005 14:51:44

Hallo ????, (Real-Vornamen erwünscht)

mE hast Du in der Formel spalte a und c vertauscht.
ausserdem sollte es so einfacher gehen...

=SUMMENPRODUKT((TEILERGEBNIS(3;INDIREKT("a"&ZEILE(2:10)))>0)*c2:c10*B2:B10)

Gruß Ingo

PS eine Rückmeldung wäre nett...


Bild


Betrifft: AW: Summenprodukt Autofilter von: Fabian
Geschrieben am: 31.03.2005 15:19:59

Ich danke euch! Jetzt, haut es hin. Vorher habe ich mich wahrscheinlich zu unklar ausgedrückt. Aber ich möchte die Chance nutzen noch mal kurz zu fragen ob es auch ohne den Verweis auf das Produkt funktioniert. Es gibt nämluch noch andere Spalten die gefiltert werden könnten. Geht das dann nur per Makro. Abgesehen davon versuch ichs mal per Pivot.
Kann ich die Formelbildung bzw. -zusammensetung irgenwo nachlesen?

Besten Dank und Gruß
Fabian


Bild


Betrifft: Danke für die Rückmeldung von: IngoG
Geschrieben am: 31.03.2005 15:46:54

Hallo Fabian,

generell funktioniert meine Formel für alle Filterungen, du mußt nur sicherstellen, dass du bei der Teilergebnisfunktion auf eine Spalte zugreifst, die immer gefüllt ist.
Es wird ja nur gezählt, ob in dieser Spalte pro Zeile ein wert sichtbar ist und dann das Produkt gezählt oder sonst nicht.

Gruß Ingo


Bild


Betrifft: AW: Danke für die Rückmeldung von: Fabian
Geschrieben am: 01.04.2005 13:20:56

Richtig, Funktioniert auch wenn ich wenn ich mich nur auf Spalte B beziehe.
Danke noch mal!


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Summenprodukt Autofilter"