leere Zellen mit Wenn Formeln aussortieren

Bild

Betrifft: leere Zellen mit Wenn Formeln aussortieren von: ömer
Geschrieben am: 05.04.2005 12:40:32

LIEBE EXPERTEN,
AUF DEM BLATT HABE ICH AUF VIELEN ZELLEN WENN-FORMELN; KOPIERT IN GANZEN SPALTEN: WEIL ES SICH JA IMMER AUF BESTIMMTE KRITERIEN BEZIEHEN BLEIBEN NATÜRLICH VIELE ZEILEN ZWISCHENDURCH LEER BZW.MIT DEN LETZEN WERTEN VON OBEN:

JETZT:
WIE KANN ICH ES SCHAFFEN DAS ZWISCEHNLIEGENDE ZEILEN AUTOMATISCH VERSCHWINDEN; ODER AUTOMATISCH AUSBLENDEN:
WEIL DIESE ZEILEN BRAUCHE ICH NICHT MEHR UND ICH BRAUCHE MANCHMAL JEDE 20 STE ZEILE SODASS SIE VÜM BILDSCHIRM VERSCHWINDEN UND NICHT SCHÖN AUSSEHEN

VIELEN DANK IM VORAUS

MFG
ÖMER

Bild


Betrifft: AW: leere Zellen mit Wenn Formeln aussortieren von: Heinz Ulm
Geschrieben am: 05.04.2005 12:54:33

Hallo Ömer,

versuchs mal so:
Tabelle1
 ABCD
1    
2    
31abtext
4 er 
52ghtext
6 jk 
7 lm 
8    
9    
10 das auf eine andere Tabelle  
11    
121abtext
132ghtext
Formeln der Tabelle
A3 : =WENN(D3>"";MAX($A$1:A2)+1;"")
D3 : =WENN(ODER(B3="a";B3="g");"text";"")
A4 : =WENN(D4>"";MAX($A$1:A3)+1;"")
D4 : =WENN(ODER(B4="a";B4="g");"text";"")
A5 : =WENN(D5>"";MAX($A$1:A4)+1;"")
D5 : =WENN(ODER(B5="a";B5="g");"text";"")
A6 : =WENN(D6>"";MAX($A$1:A5)+1;"")
D6 : =WENN(ODER(B6="a";B6="g");"text";"")
A7 : =WENN(D7>"";MAX($A$1:A6)+1;"")
D7 : =WENN(ODER(B7="a";B7="g");"text";"")
B12 : =SVERWEIS(ZEILE(A1);$A$3:$D$7;SPALTE(B1);0)
C12 : =SVERWEIS(ZEILE(B1);$A$3:$D$7;SPALTE(C1);0)
D12 : =SVERWEIS(ZEILE(C1);$A$3:$D$7;SPALTE(D1);0)
B13 : =SVERWEIS(ZEILE(A2);$A$3:$D$7;SPALTE(B2);0)
C13 : =SVERWEIS(ZEILE(B2);$A$3:$D$7;SPALTE(C2);0)
D13 : =SVERWEIS(ZEILE(C2);$A$3:$D$7;SPALTE(D2);0)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß Heinz


Bild


Betrifft: AW: leere Zellen mit Wenn Formeln aussortieren von: ömer
Geschrieben am: 05.04.2005 14:52:22

Vielen Dank Heinz,
weißt Du, ich habe fast 150 tabellen mit je mehr als 1000 Teilen voll mit diesem Wenn Formeln.
Es ist für mich unmöglich daß ich alle Formeln wieder neu definiere.
Dann sortiere ich einfachz nach Datum oder so.

Aber vielen vielen Dank. Nächstes Mal muss ich vom Anfang an richtig formulieren.

MFG
ömer


Bild


Betrifft: AW: leere Zellen mit Wenn Formeln aussortieren von: andre
Geschrieben am: 05.04.2005 19:24:19

Hallo ömer,
wenn die nicht benötigten Zeilen komplett oder an bestimmten Stellen leer sind reicht eine Hilfsspalte. darin zählst Du die leeren Zellen der Zeile oder der bestimmten Spalten der Zeile und tust dann über Autofilter alle Zeilen ausblenden, wo als Summe die Anzahl aller betroffenen Spalten steht.
Beispiel:
=ANZAHLLEEREZELLEN(A1:C1) ' und runterziehen
ergibt 3 wenn alle 3 Spalten leer sind - daher Autofilter auf 3 setzen.


Bild


Betrifft: AW: leere Zellen mit Wenn Formeln aussortieren von: ömer
Geschrieben am: 06.04.2005 11:41:13

Lieber Andre,
Vielen Vielen Dank
kannst Du für mich ein kleines Beispiel hochladen.
MFG
Ömer


Bild


Betrifft: AW: leere Zellen mit Wenn Formeln aussortieren von: andre
Geschrieben am: 06.04.2005 18:15:17

Hallo ömer,
im Prinzip so:
relevant sind die Spalten A-D
dann einen Autofilter setzen in Spalte G und alles was 4 hat ausblenden.
Tabellenblattname: Tabelle2
 

A

B

C

D

E

F

G

1

Überschrift

2

a

a

a

a

a

1

3

b

b

b

b

2

4

c

c

4

5

d

d

d

d

d

1

6

b

b

4

7

b

b

b

1

8

b

b

b

1

9

b

b

b

2

10

d

d

d

d

2

11

d

d

d

d

0


Benutzte Formeln:
G2: =ANZAHLLEEREZELLEN(A2:D2)
G3: =ANZAHLLEEREZELLEN(A3:D3)
G4: =ANZAHLLEEREZELLEN(A4:D4)
G5: =ANZAHLLEEREZELLEN(A5:D5)
G6: =ANZAHLLEEREZELLEN(A6:D6)
G7: =ANZAHLLEEREZELLEN(A7:D7)
G8: =ANZAHLLEEREZELLEN(A8:D8)
G9: =ANZAHLLEEREZELLEN(A9:D9)
G10: =ANZAHLLEEREZELLEN(A10:D10)
G11: =ANZAHLLEEREZELLEN(A11:D11)
Grüße, Andre


Bild


Betrifft: Alles Klar, Vielen Dank von: ömer
Geschrieben am: 07.04.2005 11:20:45

Vielen Dank Andre !!
MFG
ömer


 Bild

Beiträge aus den Excel-Beispielen zum Thema "leere Zellen mit Wenn Formeln aussortieren"