Herbers Excel-Forum - das Archiv

SVERWEIS: Ausgabe von mehreren Spaltne

Bild

Betrifft: SVERWEIS: Ausgabe von mehreren Spaltne
von: Martin

Geschrieben am: 09.04.2005 12:55:17
Hallo,
ziehe die Frage von Montag nochmal nach oben, weil ich immer noch nach einer Lösung suche:
Ich will über SVERWEIS als Spaltenindex nicht nur eine Zelle zurückgeben, sondern gleich mehrere - etwa 5 Stück. Das Rüberziehen des SVERWEISbefehls über weitere Zelle passt aber auch den ersten Wert an und es ist unpraktisch den manuell immer anzupassen. So eine Lösung will ich am Ende nicht haben.
Wie ist der Trick?
Zur Erklärung: =SVERWEIS(E1;$A$1:$D$20;2;FALSE) soll statt den Wert aus B wie hier
die Werte in der gefundenen Zeile in den Spalten A,B,C,D zurückgeben.
Wie geht das?
Bin für jeden Tipp dankbar!
Martin


Bild

Betrifft: AW: SVERWEIS: Ausgabe von mehreren Spaltne
von: Bernd
Geschrieben am: 09.04.2005 13:13:04
Hallo Martin,
in welcher Spalte steht denn Deine Formel?
Gruß Bernd
Bild

Betrifft: AW: SVERWEIS: Ausgabe von mehreren Spaltne
von: Josef B
Geschrieben am: 09.04.2005 14:08:07
Hallo Martin
Folgendes sollte funktionieren:
=SVERWEIS($E1;$A$1:$D$20;SPALTE(A1);0)
und nach rechts kopieren.
Gruss Josef
 Bild
Excel-Beispiele zum Thema "SVERWEIS: Ausgabe von mehreren Spaltne"
Ausgabe einer benutzerdefinierten Funktion in Matrixformel Rechtschreibprüfung und Fehlerausgabe
Vergleich von zwei Listen und Ausgabe eines Wahrheitswertes Der Einsatz der SVERWEIS-Funktion in einem Ausgabeblatt
Druck aus mehreren Tabellenblättern auf eine Druckseite Daten von mehreren Blättern auf ein Druckblatt
Werte in mehreren Spalten sortieren Den selben Bereichsnamen in mehreren Tabellenblättern
Tabelle nach mehreren Kriterien summieren Auswahl von Zellen in mehreren Zeilen verhinden