Datum und Quartal

Bild

Betrifft: Datum und Quartal von: Thomas G
Geschrieben am: 11.04.2005 09:42:26

Hallo zusammen,

ich brauche eure Hilfe.

In der Zeile A1 bis H1 stehen jeweils ein Datum.
Jetzt möchte ich das mir in der Zeile A2 bis H2
das Quartal und das Jahr angezeigt wird.

Diese Formel zeigt mir nur das Quarteal an =AUFRUNDEN(MONAT(A1)/3;)

Was muß an dieser Formel geändert werden damit mir auch das entsprechende Jahr angezeigt wird?

Für eure Hilfe wäre ich sehr dankbar.

Mit freundlichen Grüßen.

Thomas

Bild


Betrifft: AW: Datum und Quartal von: UweD
Geschrieben am: 11.04.2005 09:47:44

Hallo Thomas


so:

=AUFRUNDEN(MONAT(A1)/3;)& "/" &TEXT(JAHR(A1);"JJ")

Gruß UweD


Bild


Betrifft: AW: Datum und Quartal nicht ganz iO. von: Thomas G
Geschrieben am: 11.04.2005 10:05:31

Hallo Uwe,

Deine Formel funktioniert nicht ganz so wie es sein sollte.
Wenn mehrere Jahre vorhanden sind funktioniert die Formel nicht richtig.

Bei Juni 04 wird mir 02/05 angezeigt usw.

Kannst Du noch mal nachsehen woran es liegt?

Danke für Deine Hilfe.

MfG

Thomas


Bild


Betrifft: AW: Datum und Quartal nicht ganz iO. von: Tobias Marx
Geschrieben am: 11.04.2005 10:09:19

Servus!

Also ich wuerd dann einfach den Umweg ueber die Rechts-Funktion gehen. Je nachdem ob dein Jahr zwei- oder vierstellig ist:

1.) =AUFRUNDEN(MONAT(A1)/3;)& "/" & RECHTS(A1;2)
2.) =AUFRUNDEN(MONAT(A1)/3;)& "/" & RECHTS(A1;4)

Gruss

Tobias


Bild


Betrifft: Danke ich habe was ich brauche von: Thomas G
Geschrieben am: 11.04.2005 10:16:25

Hallo zusammen,

vielen Dank für eure Hilfe.

Ich habe was ich brauche.

Mit freundlichen Grüßen

Thomas


Bild


Betrifft: AW: Datum und Quartal nicht ganz iO. von: UweD
Geschrieben am: 11.04.2005 10:27:08

Hallo

Klar. Zu viel geschrieben.

so klappt es:

 
 AB
111.04.200501.06.2004
22/052/04
Formeln der Tabelle
A1 : =HEUTE()
A2 : =AUFRUNDEN(MONAT(A1)/3;)& "/" &TEXT(A1;"JJ")
B2 : =AUFRUNDEN(MONAT(B1)/3;)& "/" &TEXT(B1;"JJ")
 



Gruß UweD


Bild


Betrifft: Erste Sahne. Danke von: Thomas G
Geschrieben am: 11.04.2005 09:54:42

Hallo Uwe,

danke für Deine Hilfe.

Die Formel ist ist super.

Danke

MfG

Thomas


Bild


Betrifft: AW: Quartal Summieren von: Thomas G
Geschrieben am: 11.04.2005 11:06:51

Hallo nochmal,

vieleicht hätte ich diese Frage vorhin mitstellen sollen.
Aber ich versuchs mal.

Dank euer Hilfe habe ich eine super Formel für die Quartale bekommen.
Funktioniert einwandfrei.

Zu meiner nächsten Frage.

In A1 bis J1 steht da Datum
In A2 bis J2 steht jetzt das passende Quartal.
In A3 bis J3 stehen Zahlen.

Wie kann ich jetzt die Zahlen passend zu den Quartalen summieren?

Nochmals danke für die Hilfe.

MfG Thomas


Bild


Betrifft: AW: Quartal Summieren von: Tobias Marx
Geschrieben am: 11.04.2005 11:08:37

Servus!

Was verstehst du unter summieren? Also ich hab noch nie 50 Mark dem dritten Quartal 05 hinzugefuegt... was meinst du denn genau damit?

Gruss

Tobias


Bild


Betrifft: AW: Quartal Summieren von: Thomas G
Geschrieben am: 11.04.2005 11:18:52

Hallo Tobias,

danke für Deine Antwort.

Um es einfacher zu machen habe ich mal eine Datei mit hochgeladen.

https://www.herber.de/bbs/user/20964.xls

Danke für die Hilfe

MfG

Thomas


Bild


Betrifft: AW: =SUMMEWENN(A4:J6;A4;A6:J6)....oT. von: HermannZ
Geschrieben am: 11.04.2005 11:23:30

.


Bild


Betrifft: AW: =SUMMEWENN(A4:J6;A4;A6:J6)....oT. von: Thomas G
Geschrieben am: 11.04.2005 11:28:23

Hallo Hermann,

danke für Deine Antwort,

Deine Formel funktioniert.
Aber wenn es ein neues Jahr gibt, erkennt die Formel das Jahr nicht.

Die Formel funktioniert fast wie eine Schleife.
Probiere es mal aus.

MfG

Thomas


Bild


Betrifft: AW: =SUMMEWENN(A4:J6;A4;A6:J6)....oT. von: HermannZ
Geschrieben am: 11.04.2005 11:37:01

Hallo Thomas,
das kann ich jetzt nicht nachvollziehen,siehe Beispiel;
Text
 ABCDEFGHIJ
947Jun. 04Jul. 04Aug. 04Sep. 04Okt. 04Nov. 04Dez. 04Jan. 05Feb. 05Mrz. 05
948          
949          
9502/043/043/043/044/044/044/041/051/051/05
951          
9521000100010001000100010001000100010001000
953          
9541000300030003000      
955Summe aus KW2/04Summe aus KW3/04Summe aus KW4/04Summe aus KW1/05      
956          
Formeln der Tabelle
A950 : =AUFRUNDEN(MONAT(A947)/3;)& "/" &TEXT(A947;"JJ")
B950 : =AUFRUNDEN(MONAT(B947)/3;)& "/" &TEXT(B947;"JJ")
C950 : =AUFRUNDEN(MONAT(C947)/3;)& "/" &TEXT(C947;"JJ")
D950 : =AUFRUNDEN(MONAT(D947)/3;)& "/" &TEXT(D947;"JJ")
E950 : =AUFRUNDEN(MONAT(E947)/3;)& "/" &TEXT(E947;"JJ")
F950 : =AUFRUNDEN(MONAT(F947)/3;)& "/" &TEXT(F947;"JJ")
G950 : =AUFRUNDEN(MONAT(G947)/3;)& "/" &TEXT(G947;"JJ")
H950 : =AUFRUNDEN(MONAT(H947)/3;)& "/" &TEXT(H947;"JJ")
I950 : =AUFRUNDEN(MONAT(I947)/3;)& "/" &TEXT(I947;"JJ")
J950 : =AUFRUNDEN(MONAT(J947)/3;)& "/" &TEXT(J947;"JJ")
A954 : =SUMMEWENN($A$950:$J$950;A950;$A$952:$J$952)
B954 : =SUMMEWENN($A$950:$J$950;B950;$A$952:$J$952)
C954 : =SUMMEWENN($A$950:$J$950;D950;$A$952:$J$952)
D954 : =SUMMEWENN($A$950:$J$950;H950;$A$952:$J$952)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Gruß hermann


Bild


Betrifft: Vielen Dank es funktioniert von: Thomas G
Geschrieben am: 11.04.2005 12:19:23

Hallo zusammen,

erstmal danke für die hilfreiche Unterstützung.

Hermann Deine Formel war und ist in Ordnung.
Ich habe beim kopieren einen Fehler gemacht.

Nochmals Danke

MfG

Thomas


Bild


Betrifft: AW: Quartal Summieren von: Tobias Marx
Geschrieben am: 11.04.2005 11:24:13

Servus!

Da ich kein Formelexperte bin, kann ich dir in diesem Fall nur per Makro weiterhelfen. Kannst du damit was anfangen, oder willst du lieber warten, bis eine Formelloesung auftaucht?

Gruss

Tobias


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Datum und Quartal"