Sverweis

Bild

Betrifft: Sverweis
von: Regina
Geschrieben am: 11.04.2005 14:37:54
Hallo
Die Formel habe ich bis hierher hinbekommen,
=WENN($F$2="";"";SVERWEIS($F$2;Kunden;2))
Und zwar geht es hier darum, dass bei Eingabe der Kundenname bei dieser Zeile dann der Name erscheint. Solange wie der Vor- und Nachname in einer Zelle steht, funktiert das auch.
Wie mach ich es denn, wenn der Vorname z.B. in Spalte 2 steht und der Nachname in Spalte 3.
Denn ich denke, dass eine normale Adressdatei die Namen in 2 Spalten hat.
Das gleiche gilt auch für die Postleitzahl und Ort etc.
Was muss ich da machen?
Gruß
Regina

Bild

Betrifft: AW: Sverweis
von: Fritz
Geschrieben am: 11.04.2005 14:54:22
Hi Regina,
Verkette den Vornamen und Nachnamen zu einem Suchbegriff z.B. so:
Vorname in A2 , Nachname in B2 dann Suchbegriff für Sverweis:
=SVERWEIS(A2&" "&B2;Suchmatrix;Spaltenindex;Bereich_Verweis).
Hierbei ist ein Leerzeichen zwischen Vor - und Nachname vorgeshen.

Fritz
Bild

Betrifft: AW: Sverweis
von: Regina
Geschrieben am: 12.04.2005 10:36:01
Hallo Fritz,
vielen Dank für Deine Antwort, doch leider kann ich mit der Formel so nichts machen, da ich mit den Begriffen Suchmatrix, Spaltenindes;Bereich_Verweis so nichts anfangen kann.
=SVERWEIS(A2&" "&B2;Suchmatrix;Spaltenindex;Bereich_Verweis).
Ich hatte dies mit der Wenn_Dann_Sonst Funktion gemacht.
Vielleicht kannst Du mir hier noch einmal helfen.
Regina
Bild

Betrifft: AW: Sverweis
von: Fritz
Geschrieben am: 12.04.2005 14:32:38
Hi Regina,
Ich hatte Dein Problem falsch verstanden. Du möchtest nicht nach Vornamen und Nachnamen suchen lassen, sondern aus der Kundentabelle den Vornamen aus Spalte 2 und den Nachnamen aus Spalte 3 z.B. ausgeben lassen.
Ändere Deine Formel etwa so ab.
=WENN($F$3="";"";SVERWEIS($F$3;Kundentabelle;2;0)&" "&SVERWEIS($F$3;Kundentabelle;3;0))
Fritz
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Sverweis"