Funktion SUMMEWENN

Bild

Betrifft: Funktion SUMMEWENN von: hugo
Geschrieben am: 12.04.2005 01:33:14

Hallo,
mit der schönen Funktion SUMMEWENN habe ich ein Problem. Suchkriterium ist ein Bezug auf eine Zelle, Inhalt dieser Zelle ein Datum. Soweit so gut. Wenn ich allerdings dem Suchkriterium -also dem Zellbezug- einen Vergleichs-Operator voranstelle (in diesem Fall benötige ich "<="), erhalte ich als Ergebnis der Funktion regelmäßig '0', was auch immer ich mit der Syntax probiere. Auch der Funktionsassistent führt zu diesem Ergebnis.
Hier die nicht funktionierende Funktion:
=SUMMEWENN(A1:A20;"<=C1";B1:B20)
Weiß jemand Rat? Danke im Voraus,

hugo

Bild


Betrifft: AW: Funktion SUMMEWENN von: Jörg Gradert
Geschrieben am: 12.04.2005 02:08:33

Hallo Hugo,
ich kriegs auch mit SUMMEWENN() nicht hin.
Nimm einfach SUMMENPRODUKT()

=SUMMENPRODUKT((A1:A20<=C1)*(B1:B20))

Bedenke, daß leere Zellen kleiner als C1 sind, wenn in C1 ein Wert steht.

Gruß Jörg


Bild


Betrifft: AW: Funktion SUMMEWENN von: hugo
Geschrieben am: 12.04.2005 02:19:15

Hallo Jörg,
geil, danke!
Aber fuchsen tut`s mich doch.
Gruß
Hugo


Bild


Betrifft: =SUMMEWENN(A1:A20;"<="&INDIREKT("C1");B1:B20) - oT von: Björn B.
Geschrieben am: 12.04.2005 03:43:07




Bild


Betrifft: AW: =SUMMEWENN(A1:A20;"<="&INDIREKT("C1");B1:B20) - oT von: Jörg Gradert
Geschrieben am: 12.04.2005 05:15:11

Hallo Björn,
wozu das INDIREKT()?
geht das denn nicht auch so?

=SUMMEWENN(A1:A20;"<="&C1;B1:B20)

In dieser Formel fällt mir auf, daß leere Zellen nicht kleiner als der Wert in C1 sind, was ich unlogisch finde.

Gruß Jörg


Bild


Betrifft: Natürlich, war wohl etwas spät ;-) Gruß Björn - oT von: Björn B.
Geschrieben am: 12.04.2005 19:01:45




Bild


Betrifft: AW: Funktion SUMMEWENN von: hugo
Geschrieben am: 12.04.2005 11:01:52

Hallo Björn, hallo Jörg!
der "geht-es-nicht-auch-so" Lösung von Jörg gebe ich den Vorzug, da ich sie "eleganter" finde.
Aber Dank Dir Björn, da habe ich in jedem Fall eine nützliche, und für mich neue, Funktion kennengelernt, deren Bedeutung sich mir beim Durchchecken der Funktionsliste nicht erschlossen hatte.
Und Dir Jörg danke ich für die genas-Lösung, Syntax ist alles, der Bedeutung wird viel zu wenig Raum in der online-Hilfe gegeben. Daß Deine Lösung leere Zellen ausschließt, könnte es nicht daran liegen, daß bei "summewenn" "istnichtleer" im Untergrund impliziert ist?

Nochmal fetten Dank

hugo
"so macht Excel Spaß"


Bild


Betrifft: AW: Funktion SUMMEWENN von: Jörg Gradert
Geschrieben am: 12.04.2005 15:05:14

Hallo Hugo Hallo Björn,
ja Hugo, ich denke, daß Du recht hast, daß in SUMMEWENN() ein "istnichtleer" impliziert ist.
Den entscheidenden Anstoß hat Björn gegeben, indem er uns gezeigt hat, wie das C1 aus den "" rausgenommen wird, damit die Formel funktioniert.
Die Formelverkürzung, von mir, war dann nicht mehr schwer, als ich das Prinzip begriffen hatte.
Auch ich habe dazugelernt, danke Björn, es geht doch nichts über Teamwork.

Gruß Jörg


Bild


Betrifft: Danke für die Rückmeldung - o . T. von: Björn B.
Geschrieben am: 12.04.2005 19:03:37




Bild


Betrifft: SUMMEWENN und kein Ende von: hugo
Geschrieben am: 12.04.2005 16:23:35

Hallo,
ja, es geht weiter:
jetzt muß ich das Suchkriterium mit zwei Bedingungen beladen.
A:A enthält verschiedene Datumswerte, B:B Zahlwerte, C1 und C2 enthalten Datumswerte; Ergebnis soll die Summe der zwischen den Stichtagen liegenden Zahlwerte sein.
Sinngemäß möchte ich das tun:
=SUMMEWENN(A:A;(">"&C1)und("<="&C2);B:B)
Nur die Verknüpfung der beiden Bedingungen will nicht klappen.
Also bitte ich nochmal die Welt um Rat.
Danke vorab,
hugo


Bild


Betrifft: SUMMENPRODUKT() von: Jörg Gradert
Geschrieben am: 12.04.2005 18:26:41

Hallo Hugo,
dann empfehle ich doch wieder SUMMENPRODUKT()

=SUMMENPRODUKT((A1:A100>C1)*(A1:A100<=C2)*B1:B100)

ganze Spalten, z.B. A:A, gehen in SUMMENPRODUKT() nicht, aber der Bereich kann bis 65535 gehen.

Gruß Jörg


Bild


Betrifft: AW: SUMMENPRODUKT() von: hugo
Geschrieben am: 12.04.2005 21:26:44

Hallo Jörg,
danke für deine Anteilnahme! Ich hatte mir mittlerweile zu dieser "zu Fuß"-Lösung verholfen:

=SUMMEWENN(A:A;"<="&C2;B:B)-Summe($D$1:D1)

wobei D1 das Ergebnis der Funktion ist, die sich auf C1 bezieht.
Ehrlich gesagt befriedigen mich beide Lösungen nicht, wenn Du verstehst, was ich meine.
Ich habe jetzt Deinen Lösungsvorschlag verwendet, da mir die Subtraktionslösung nun schon gar nicht gefällt.
Also Danke nochmal,
ciao
Hugo


Bild


Betrifft: PS: Jörg von: hugo
Geschrieben am: 12.04.2005 21:30:25

Hätte ich fast vergessen:
Interessanterweise funktioniert Deine SUMMENPRODUKT-Variante auch mit Leerzellen!
Gruß
Hugo


Bild


Betrifft: AW: PS: Jörg von: Jörg Gradert
Geschrieben am: 12.04.2005 22:51:48

Hallo Hugo,
ja :-), das ist klar, denn die Leerzellen können nicht "und größer als C1" sein.
Du hast ja jetzt eine Untergrenze gesetzt.
Wenn Du also ein Datum hast, das durch eine Leerzelle repräsentiert wird, wird dieses Datum immer ausserhalb des zu addierenden Bereichs liegen, nämlich darunter.
Das ist der Unterschied zur ersten Formel, für den mein Hinweis, zu den Leerzellen, galt.

Gruß Jörg


Bild


Betrifft: AW: PS: Jörg von: hugo
Geschrieben am: 13.04.2005 10:13:51

Hallo Jörg,
hier kann ich nur Björn zitieren: "war wohl etwas spät" und außerdem der Kopf offensichtlich nicht mehr ganz klar.
Tschüs,
hugo


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Funktion SUMMEWENN"