Berechnungen mit Datum

Bild

Betrifft: Berechnungen mit Datum
von: Hubert Hanscher
Geschrieben am: 12.04.2005 02:12:12
Hallo
Habe seit ca. einem Jahr die unten Stehende Formel erfolgreich im Gebrauch um einfache Statistiken abzurufen. Leider taucht jetzt nach einem Jahr folgender Fehler auf. In Zelle D30 steht 01.04.04 . Jetzt nach einem Jahr ( 01.04.05 ) ist in der Berechnung folgender Fehler. Die Formel schmeißt beide Daten ( 2004 und 2005 )durcheinander, da anscheinend nur der Monat ausgelesen wird und nicht der Monat und das Jahr. Gibt es eine Möglichkeit einen Monat aber auch das passende Jahr dazu auslesen zu lassen ? Gruß und Danke im vorraus, Hubert

=SUMMENPRODUKT((MONAT('Kunden Archiv'!$A$2:$A$60000)=MONAT($D30))*'Kunden Archiv'!$M$2:$M$60000)

Bild

Betrifft: AW: Berechnungen mit Datum
von: Björn B.
Geschrieben am: 12.04.2005 03:35:35
Hallo Hubert,
probier's mal mit:
=SUMMENPRODUKT((Jahr('Kunden Archiv'!$A$2:$A$60000)=Jahr($D30))*(MONAT('Kunden Archiv'!$A$2:$A$60000)=MONAT($D30))*'Kunden Archiv'!$M$2:$M$60000)
Gruß
Björn
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Berechnungen mit Datum"