Matrixformel geht nicht

Bild

Betrifft: Matrixformel geht nicht von: Sabine
Geschrieben am: 12.04.2005 14:07:41

Hi, versuche mit folgender Formel zu arbeiten

{=SUMME((Tab1!$B$2:$B$100=$A$1)*(Tab1!$D$2:$D$100=RECHTS($A6;3)))}

In den Bsp hat es so immer funktioniert. Wie bei einem AutoFilter, nur schneller und praktischer, wurden mit dieser Formel die Ergebnisse der Selektion angezeigt. Nun funktioniert es nicht mehr. Kann es daran liegen, dass zwar in A1 und A6 der Tab2, in der die Formel angewendet wird, Buchstaben bzw. Wörter stehen, und dass in den Bereichen B2:B100 und D2:D100 in Tab1 nur diese Buchstaben und Wörter angezeigt werden, aber SVerweise hinterlegt sind?

Grüße, Sabine

Bild


Betrifft: AW: Matrixformel geht nicht von: Martin Beck
Geschrieben am: 12.04.2005 14:19:06

Hallo Sabine,

was funktioniert denn nicht?

Versuche mal

{=SUMME((Tab1!$B$2:$B$100=$A$1)*(Tab1!$D$2:$D$100=RECHTS($A6;3))*1)}

Gruß
Martin Beck


Bild


Betrifft: AW: Matrixformel geht nicht von: Sabine
Geschrieben am: 12.04.2005 14:28:37

Mein Fehler. In den Beispielen stand in A6 nicht das Suchwort "abc", sondern "dv. abc". Habe nun den ganzen RECHTS-Krams weggelassen und nur nach A6 gesucht. Jetzt klappt's auch wieder. Trotzdem Danke.

VG, Sabine


Bild


Betrifft: AW: Matrixformel erweitert von: Sabine
Geschrieben am: 12.04.2005 14:36:16

Doch nochmal eine Frage. Diese Formel

{=SUMME((Tab1!$B$2:$B$100=$A$1)*(Tab1!$D$2:$D$100=($A10)))}

funktioniert ja nun. Kann ich ein weiteres Kriterium, nämlich benutzerdefiniert:

ist größer oder gleich 25 bezogen auf H2:H100 da mit reinnehmen?

Das wäre perfekt!

Sabi


Bild


Betrifft: AW: Matrixformel erweitert von: Martin Beck
Geschrieben am: 12.04.2005 14:51:33

Hallo Sabine,

{=SUMME((Tab1!$B$2:$B$100=$A$1)*(Tab1!$D$2:$D$100=($A10))*(Tab1!$H$2:$H$100>=25))}

Gruß
Martin Beck


Bild


Betrifft: AW: Matrixformel erweitert von: Sabine
Geschrieben am: 12.04.2005 16:34:40

Danke. Funktioniert. VG Sabi


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Matrixformel geht nicht"