Summenprodukt mit Stellvertreter

Bild

Betrifft: Summenprodukt mit Stellvertreter von: Heinz
Geschrieben am: 12.04.2005 19:46:21

Hallo an alle,

ich habe mal ne Beispieldatei reingehängt.

https://www.herber.de/bbs/user/21064.xls

Schöne Grüße an alle Forums-Teilnehmer

Heinz

Bild


Betrifft: AW: Summenprodukt mit Stellvertreter von: Beate Schmitz
Geschrieben am: 12.04.2005 20:29:32

Hallo Heinz,

danke für dein Beispiel.


Du kannst die Formel in Spalte F wie folgt verkürzen, bzw. da du dort nur eine Bedingung auswertest ist ZÄHLENWENN vorzuziehen, es ist die schnellere Funktion, da keine Arrayformel:

 
 FG
6Nur Ost_West_Auswertung
74242
8108108
9langsamer, weil SUMMENPRODUKT Arrayformelschnellere Formel: ZÄHLENWENN
Formeln der Tabelle
F7 : =SUMMENPRODUKT(N(INDIREKT($C$6)=$C7))
G7 : =ZÄHLENWENN(INDIREKT($C$6);$C7)
F8 : =SUMMENPRODUKT(N(INDIREKT($C$6)=$C8))
G8 : =ZÄHLENWENN(INDIREKT($C$6);$C8)
 



Jedenfalls sind die Array-Klammern überflüssig - Summenprodukt ist automatisch eine Arrayformel.

Ausgefallene Beispiele zu Summenprodukt findest du hier:
http://www.xldynamic.com/source/xld.SUMPRODUCT.html

Gruß,
Beate


Bild


Betrifft: AW: Summenprodukt mit Stellvertreter von: Ceyser Soze
Geschrieben am: 12.04.2005 20:42:31

Hi Heinz,
das hilft auch...
=WENN(UND(ODER(B7="";B7="*";);ODER(D7="";D7="*"));SUMMENPRODUKT((INDIREKT($C$6)=$C7)*(INDIREKT($C$6)=$C7));"SonstAnweisunung")
Gruß
CS


 Bild

Beiträge aus den Excel-Beispielen zum Thema "werte aus anderer Tabelle kopieren"