Zeile ermitteln

Bild

Betrifft: Zeile ermitteln
von: Rainer
Geschrieben am: 14.04.2005 09:56:39
Hallo,
ich versuche gerade mit UweN ein Problem zu lösen, was mein excel nicht versteht.
Jetzt will ich es austricksen, wer kann mir dabei helfen. Und zwar wie folgt:
Ich möchte die Zeile auslesen, in der ein bestimmter Wert steht.
Bspl. In Saplte A steht eine lfd. Nummer, in Spalte B stehen werte von 1000 bis 2000.
In Zelle A1 gebe ich einen Wert zwischen 1000 und 2000 ein und in Zelle B1 soll die Zeile ausgegeben werden, in der diese Zahl steht.
Ich kriege das mit der ZEILEN-Funktion irgendwie nicht hin.
Kann mir jemand helfen?
Gruß
Rainer

Bild

Betrifft: AW: Zeile ermitteln
von: ANdreas
Geschrieben am: 14.04.2005 10:02:53
Hallo Rainer,
versuch es mal so:
=VERGLEICH(A1;B2:B1000;0)+1
Gruß
Andreas
Bild

Betrifft: AW: Zeile ermitteln
von: Rainer
Geschrieben am: 14.04.2005 10:28:44
Klappt super!
Jetzt hatte ich mir folgendes gedacht: Ich geben die ermittelte Zahl einfach als Bereichsindikator für eine SUMMEWENN-Formel an:
=SUMMEWENN(1:1;C1;VERGLEICH(...):VERGLEICH(...))
Das geht aber leider nicht. Gibt es denn hierfür eine Lösung?
Bild

Betrifft: AW: Zeile ermitteln
von: Galenzo
Geschrieben am: 14.04.2005 10:05:24
=VERGLEICH(A1;B2:B1000)
Viel Erfolg!
Bild

Betrifft: Nachtrag: +1
von: Galenzo
Geschrieben am: 14.04.2005 10:12:46
ANdreas hat natürlich Recht. Wenn der Datenbereich erst in Zeile 2 beginnt, mußt du zum Ergebnis der Funktion VERGLEICH noch 1 hinzuaddieren.
Bild

Betrifft: AW: Zeile ermitteln
von: Fritz
Geschrieben am: 14.04.2005 10:10:24
Hi Rainer,
Ich weiß nicht, ob ich Dich richtig verstanden habe. Aber nach Deiner Beschreibung suchst Du die Zeile für das Suchkriterium aus Zelle A1!?
Warum mit der ZEILEN-Funktion und nicht mit der VERGLEICH-Funktion?
In Zelle B1 folgende Formel:
=VERGLEICH(A1;B2:B1002)
Fritz
Bild

Betrifft: AW: Zeile ermitteln
von: Rainer
Geschrieben am: 14.04.2005 10:30:16
Klappt super!
Jetzt hatte ich mir folgendes gedacht: Ich geben die ermittelte Zahl einfach als Bereichsindikator für eine SUMMEWENN-Formel an:
=SUMMEWENN(1:1;C1;VERGLEICH(...):VERGLEICH(...))
Das geht aber leider nicht. Gibt es denn hierfür eine Lösung?
Bild

Betrifft: SUMMEWENN für ermittelten Bereich
von: WF
Geschrieben am: 14.04.2005 11:05:27
Hi,
=SUMMEWENN(B2:B100;C1;D2:INDIREKT("D"&VERGLEICH(A1;A2:A1000;0)+1))
ermittelt die Summe aus Spalte D wenn in Spalte B das Kriterium aus C1 vorkommt für den Bereich von D2 bis zur durch Vergleich betr. Spalte A ermittelten Zeilenzahl.
trapp, trapp, trapp, trapp, trapp, brrrrr
WF
http://www.excelformeln.de/
die ultimative Formelseite
Bild

Betrifft: Ergebnis ist da, WUNDERBAR
von: Rainer
Geschrieben am: 14.04.2005 11:21:20
Isch werd bekloppt, das klappt.
Danke an alle - die Kombination aus allen Antworten ist das Ergebnis:
=SUMMEWENN(A4:CA4;E1;INDIREKT("a"&VERGLEICH(D1;B6:B134;0)+5):INDIREKT("a"&VERGLEICH(D1;B6:B134;0)+5))
Gruß
Rainer
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zeile ermitteln"