SVERWEIS - #NV

Bild

Betrifft: SVERWEIS - #NV
von: Stefan
Geschrieben am: 14.04.2005 15:06:10
Hallo zusammen,
ich hab da ein Problem mit Sverweis. Irgendwo liegt da der Hund begraben. Aus beigefügter Tabelle ist ersichtlich dass Excel mit Sverweis immer #NV angibt, obwohl die Werte vorhanden sind. Wo liegt denn mein Fehler.
Im voraus schon mal vielen Dank für eure Hilfe.
Schöne Grüße
Stefan
https://www.herber.de/bbs/user/21145.xls

Bild

Betrifft: TEXTZAHL!!!
von: c0bRa (oT)
Geschrieben am: 14.04.2005 15:12:12

Bild

Betrifft: AW: SVERWEIS - #NV
von: heikoS
Geschrieben am: 14.04.2005 15:13:48
Hallo Stefan,
addier zu Deinem SAP-download in Spalte A mal eine leere Zelle, dann geht´s.
Leere Zelle kopieren, Daten in A markieren, Menü: Bearbeiten - Inhalte einfügen - Einfügen: Werte - Vorgang: Addieren.
Alternativ wählst Du im R/3 einen anderen Weg des downloads, bzw. wenn in der Transaktion möglich, der Datenaufbereitung (Anzeige als Tabelle oder halt direkt Tabellenkalkulation).

Gruß Heiko
Bild

Betrifft: AW: SVERWEIS - #NV
von: Stefan
Geschrieben am: 14.04.2005 15:52:55
Hallo Heiko,
ich hab das mit der leeren Zelle versucht, hat aber leider nicht geklappt.
Auch waren alle Zellen als Text formatiert, daran kanns also auch nicht liegen.
Grüße
Stefan
Bild

Betrifft: AW: SVERWEIS - #NV
von: Stefan Hillenbrand
Geschrieben am: 14.04.2005 16:16:25
Hallo Namenskollege ;-),
Guckst Du: Textzahlen konvertieren
Gruß Stefan
Bild

Betrifft: AW: SVERWEIS - #NV
von: Stefan Hillenbrand
Geschrieben am: 15.04.2005 07:20:11
Nochmal Hallo,
Leere Zelle kopieren, Daten in B markieren, Menü: Bearbeiten - Inhalte einfügen - Einfügen: Werte - Vorgang: Addieren.
Gruß Stefan
Bild

Betrifft: AW: SVERWEIS - #NV
von: Stefan Hillenbrand
Geschrieben am: 15.04.2005 07:20:42
Nochmal Hallo,
Leere Zelle kopieren, Daten in Spalte B markieren, Menü: Bearbeiten - Inhalte einfügen - Einfügen: Werte - Vorgang: Addieren.
Gruß Stefan
Bild

Betrifft: AW: SVERWEIS - #NV
von: Rallef K
Geschrieben am: 14.04.2005 20:19:35
Als Matrix hast du "$A$2:$A$12" angegeben. Der Suchbegriff ist aber in der B Spalte. Du muss die Formeln von
=SVERWEIS(B6;$A$2:$A$12;1;FALSCH)
ändern in
=SVERWEIS(B6;$A$2:$B$12;1;FALSCH)
Bild

Betrifft: AW: SVERWEIS - #NV
von: Stefan
Geschrieben am: 15.04.2005 08:10:04
Hallo zusammen,
vielen Dank für eure zahlreichen Hinweise.
Leider hat keiner dieser Hinweise funktioniert. Hab alles 1 zu 1 ausprobiert.
Gruß
Stefan
Bild

Betrifft: Warum nicht?
von: heikoS
Geschrieben am: 15.04.2005 08:49:02
Hallo Stefan,
dann doppelklick mal auf eine der Zellen in Spalte A und verlaß sie wieder mit Enter. Schon liefert der sverweis() ein korrektes Ergebnis. Was er im status-quo mit #NV im übrigen auch tut, weil das Suchkriterium nunmal nicht vorhanden ist.
Um das Aktivieren jeder einzelnen Zelle (es werden wohl mehr als 10 sein) abzukürzen, gibt es die Möglichkeit mit dem "Inhalte einfügen". Im link Deines Namensvetters steht es doch optimal beschrieben drin, was zu tun ist - auch wenn da von Zahlen die Rede ist, das selbe gilt auch für Deine alphanumerischen Zellinhalte.

Gruß Heiko
 Bild

Beiträge aus den Excel-Beispielen zum Thema "SVERWEIS - #NV"