Einträge zählen, kein Makro nötig

Bild

Betrifft: Einträge zählen, kein Makro nötig
von: Erdogan
Geschrieben am: 15.04.2005 02:08:59
Hallo zusammen,
ich stehe vor einem Problem, welches bestimmt ohne Makro zu lösen ist. Ich selber weiß aber leider keine Lösung dafür.
In einer Tabelle stehen in der ersten Spalte verschiedene Kennwörter. In den nächsten drei Spalten findet man Einträge. Diese sind pro Spalte nur vier verschiedene, z.B. keine Bewertung, 1 Bewertung, 2 Bewertungen und 3 Bewertungen.
Nun soll gezählt werden, wie oft in der Tabelle ein Kennwort einen bestimmten Eintrag bekommen hat.
Die Kennwörter kommen aus einer weiteren kleinen Tabelle, die im unteren Teil des Bildes zu sehen ist. In diese Tabelle soll dann auch die Anzahl der gefundenen Einträge eingetragen sein.
Mit der Formel "Zählenwenn" komme ich nicht weiter, da ich zwar die Anzahl eines Kennwortes in der ersten Spalte zählen kann, aber ich nicht zählen möchte, wie oft dieses Kennwort vorkommt, sondern wie oft dieses Kennwort den Eintrag " x Bewertungen" erhalten hat. Dabei soll "1 Bewertung" und "3 Bewertungen" nicht zusammengezählt werden. Einzig die Anzahl interessiert mich.
Hier meine vereinfachte Darstellung des Problems:
Userbild

Weiß jemand eine Lösung?
Vielen Dank im Voraus.
PS: Feedback ist für mich selbstverständlich.

Bild

Betrifft: AW: Einträge zählen, kein Makro nötig
von: Hajo_Zi
Geschrieben am: 15.04.2005 07:15:48
Hallo Erdogan,
Summenprodukt

Bitte keine Mail, Probleme sollten im Forum gelöst werden.
Microsoft MVP für Excel
Das Forum lebt auch von den Rückmeldungen.
Betriebssystem XP Home SP2 und Excel Version 2003 SP1.


Bild

Betrifft: AW: Einträge zählen, kein Makro nötig
von: Erdogan
Geschrieben am: 15.04.2005 18:18:05
Hallo Hajo,
danke für deine Antwort. Vielleicht kannst du etwas genauer werden. Summenprodukt sagt mir garnichts. Kann dieses Summenprodukt eine Spalte nach unten durchsuchen und dabei schauen, wie oft ein bestimmter Eintrag in der ersten Spalte einen bestimmten Eintrag in der z.B. 3.Spalte besitzt?
Gruß,
Erdogan
Bild

Betrifft: AW: Einträge zählen, kein Makro nötig
von: Hajo_Zi
Geschrieben am: 16.04.2005 00:48:34
Hallo Erdogan,
Tabelle1
 ABCDEFG
1KostenstelleGesellschaftBetrag  Summe36
21002012 Kostenstelle100 
31052013 Gesellschaft20 
Formeln der Tabelle
G1 : =SUMMENPRODUKT((A2:A100=F2)*(B2:B100=F3)*(C2:C100))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Gruß Hajo
Das Forum lebt auch von den Rückmeldungen.
Bild

Betrifft: AW: Einträge zählen, kein Makro nötig
von: Martin Beck
Geschrieben am: 16.04.2005 10:46:03
Hallo Erdogan,
folgende Matrixformel (Eingabe mir STRG-SHIFT-ENTER abschließen):
=SUMME((A1:A10="Kennwort A")*(B1:B10="1 Bewertung")*1)
Statt der Texte kannst Du auch Bezüge auf Zellen eingeben.
Gruß
Martin Beck
Bild

Betrifft: AW: Einträge zählen, kein Makro nötig
von: Erdogan
Geschrieben am: 16.04.2005 17:04:02
Vielen vielen Dank für die Antworten.
Ich werde diese heute noch ausprobieren und schreibe dann, ob es geklappt hat.
Martin hat eine Frage beantwortet, die ich noch gestellt hätte, nämlich, ob ich statt der Texte auch Bezüge auf Zellen nehmen kann. Ich in sehr froh, dass es dieses Forum und die fleißigen Antworter gibt. Eine Frage habe ich aber noch: macht es Sinn, meine von euch beantwortete Frage zu überarbeiten, und diese erneut einzustellen, damit sie in einer ordentlicheren Form auch von anderen verwendet werden kann oder macht das jemand eh, zum Beispiel auf der CD zum Forum.
Viele Grüße aus Oberhausen,
Erdogan
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Diagramme und Datentabelle"