index-Funktion

Bild

Betrifft: index-Funktion
von: Gerhard
Geschrieben am: 18.04.2005 15:43:53
Hallo,
ich habe eine Index Funktion welche einen Wert liefert:
=INDEX([HRW_lfd_art.xls]Rührer!$AT$1:$BZ$50;VERGLEICH("D";[HRW_lfd_art.xls]Rührer!$AT$1:$AT$50;0);VERGLEICH("030";[HRW_lfd_art.xls]Rührer!$AT$2:$BT$2;0))
Ich müsste nun aber mehrere dieser Formeln summieren (Spaltenvergleich = "030" + "031" + "032" + "035" + "040"), sodass ich die Fehlermeldung bekomme, dass die Formel zu lange ist.
Kann ich dies irgendwie anders lösen?

Danke und viele Grüße Gerhard

Bild

Betrifft: AW: index-Funktion
von: Frank Domke
Geschrieben am: 18.04.2005 16:39:12
Hallo Gerhard,
ohne mich in Deine Formel vertieft zu haben empfehle ich Dir, mit Hilfsspalte(n) zu arbeiten.
Viel Erfolg
Frank.
Bild

Betrifft: SUMMEWENN mit variabler Matrixzeile
von: Boris
Geschrieben am: 18.04.2005 17:40:55
Hi Gerhahrd,
ungetestet:
=SUMME(SUMMEWENN([HRW_lfd_art.xls]Rührer!AT2:BZ2;{"030"."031"."032"."035"."040"};INDEX([HRW_lfd_art.xls]Rührer!AT1:AT50;VERGLEICH("D";[HRW_lfd_art.xls]Rührer!AT1:AT50;))))
Wobei mir der Aufbau deiner Matrix nicht genau klar ist.
Grüße Boris
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Ablauf wiederholen"