Excel - Spalten verknüpfen

Bild

Betrifft: Excel - Spalten verknüpfen
von: Markus
Geschrieben am: 21.04.2005 09:57:12
Hallo!
Ich habe folgendes Problem:
Eine Excel Arbeitsmappe ist gegeben, in ihr zwei Arbeitsblätter mit gefüllten Tabellen.
In jeder Arbeitsmappe gibt neben anderen Inhalten zwei Spalten, die mit dem anderen Arbeitsblatt übereinstimmen.
Ich möchte nun beide Tabellen über dieses Feld miteinander verknüpfen.
Also: "Nehme Arbeitsblatt 1, wenn der Wert in Spalte xyz in Arbeitsblatt 1 mit dem Wert von Spalte asdf in Arbeitsblatt 2 übereinstimmt, verbinde diese beiden Spalten miteinander über dieses Feld und füge diese Zusammengefügte Zeile mit allen ihren Werten in ein schon vorhandenes Arbeitsblatt 3 ein."
Ich habe eine Schleife, die mir die Zeilen durchläuft, vielleicht hilft das ja schon etwas:
Sheets("sheetname").Select
laR = Cells(Rows.Count, 1).End(xlUp).Row
For i = laR To 1 Step -1


End If
nur wie verknüpfe ich das ganze? kann mir irgendjemand helfen? :(

Bild

Betrifft: AW: Excel - Spalten verknüpfen
von: UweN
Geschrieben am: 21.04.2005 10:02:13
Hallo Markus,
hast Du es schon mit der Funktion SVERWEIS versucht ?
Vorteil: Du brauchst kein VBA
Viele Grüße
Uwe
Bild

Betrifft: AW: Excel - Spalten verknüpfen
von: Markus
Geschrieben am: 21.04.2005 10:06:11
Hi,
Danke für den Tipp, nein sorry ich kannte diese Funktion noch gar nicht ;-)
Ich schaue mir das Teil mal an, bin aber auf den ersten Blick noch nicht so schlau daraus geworden.
Bild

Betrifft: AW: Excel - Spalten verknüpfen .... Ergänzung
von: UweN
Geschrieben am: 21.04.2005 10:10:44
um noch etwas präziser zu werden:
Wenn sich Dein Schlüsselkriterium aus zwei Spalten ergibt, kannst Du:
- entweder eine Hilfsspalte in beide Tabellen einbauen, z.B. mit der Formel: =A1&B1 und anschließend den SVERWEIS auf dieses Feld durchführen
- oder ohne Hilfsspatel die Formel verwenden, die Du hier findest: http://www.excelformeln.de/formeln.html?welcher=30
Viele Grüße
Uwe
Bild

Betrifft: AW: Excel - Spalten verknüpfen .... Ergänzung
von: Markus
Geschrieben am: 21.04.2005 10:16:20
Nein, dass Schlüsselkriterium ergibt sich nicht aus beiden Spalten, es ist nur so, dass manchmal etwas in der einen Spalte steht, oder in der anderen, oder halt in beiden.
Er soll deswegen erst in Spalte 1 gucken, ob diese übereinstimmt, falls ja - über spalte 1 verbinden.
Wenn in Spalte 1 nichts Steht - Spalte 2 durchsuchen, falls übereinstimmung mit Spalte 2 aus der anderen Tabelle - verbinden
Bild

Betrifft: AW: Excel - Spalten verknüpfen .... Ergänzung
von: UweN
Geschrieben am: 21.04.2005 10:41:38
Hallo Markus,
es ist auf jeden Fall sinnvoll, in beiden zu vergleichenden Tabellen einen "Primärschlüssel" zu definieren. Dann klappt das mit SVERWEIS wunderbar.
Du könntest z.B. eine Hilfsspalte definieren mit dieser Formel:
Annahme: Deine beiden möglichen Kriterien sind in Spalte A, oder wenn dort nichts steht in Spalte B
Dann kommt in C1 diese Formel rein:
=WENN(A1="";B1;A1)
Damit hast Du Dein Schlüsselfeld.
Viele Grüße
Uwe
Bild

Betrifft: AW: Excel - Spalten verknüpfen .... Ergänzung
von: Markus
Geschrieben am: 21.04.2005 10:44:29
Danke, ich werde es mal so versuchen :-)
Markus
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Excel - Spalten verknüpfen"