ArrayFormel in VBA umwandeln?

Bild

Betrifft: ArrayFormel in VBA umwandeln?
von: Marcel
Geschrieben am: 21.04.2005 17:27:54
Hallo ExcelExperten,
könnt Ihr mir helfen, ich habe eine Formel und bräuchte dafür den VBA Code. Das kriege ich irgendwie nicht hin. Ich hoffe Ihr könnt mir helfen, vielleicht kann man die Formeln ja auch noch vereinfachen. vielen Dank Marcel
{=SUMME((Stunden_Log!$B$19:$B$10000=LZBericht!A9)*(Stunden_Log!$A$19:$A$10000=LZBericht!$C$3)*(Stunden_Log!$D$19:$D$10000))-(SUMMENPRODUKT((Stunden_Log!$C$19:$C$10000="Ergebnis")*(Stunden_Log!$B$19:$B$10000=LZBericht!A9)*(Stunden_Log!$A$19:$A$10000=LZBericht!$C$3)*(Stunden_Log!$D$19:$D$10000)))}
vielen Dank Marcel

Bild

Betrifft: AW: ArrayFormel in VBA umwandeln?
von: ransi
Geschrieben am: 21.04.2005 17:46:00
hallo marcel
das sieht nach summenprodukt aus.
=summenprodukt((Stunden_Log!$B$19:$B$10000=LZBericht!A9)*(Stunden_Log!$A$19:$A$10000=LZBericht!$C$3)....)
in vba kriegst du die formel so:
zelle markieren
direktfenster starten
?activecell.formula reinschreiben
enter
ransi
 Bild

Beiträge aus den Excel-Beispielen zum Thema "ArrayFormel in VBA umwandeln?"