wenn funktion über vba in zelle

Bild

Betrifft: wenn funktion über vba in zelle
von: Erik Walker
Geschrieben am: 22.04.2005 08:38:55
Hallo, ich möchte über einen VBA-Code eine Formel in eine Zelle einfügen:
1. mgl:ActiveCell.FormulaR1C1 = "=WENN(I3+4=A1;""Anrufen"";"""")"
2. mgl: dim f as string - f= "=WENN(I3+4=A1;""Anrufen"";"""")" - Activecell.formular1c1=f
Die Funktion wird wunderbar in die Zelle eingefügt, sieht dann auch absolut identisch aus, als wenn ich die formel per hand reinschreiben würde.(wo sie auch funktioniert)
Allerdings wird die Formel nicht als Formel interpretiert, sondern nur als Text, ich brauche e aber als Formel.
Wer kann helfen??
PS:Auch in Englisch mit if... funktionierts nicht.

Bild

Betrifft: AW: wenn funktion über vba in zelle
von: jan-und-iana
Geschrieben am: 22.04.2005 09:05:27
Hallo Erik,
probier mal anstatt,
ActiveCell.FormulaR1C1 = ...
ActiveCell.FormulaLocal = ...

Der Unterschied besteht darin, dass Excel die Eigenschaft von .FormulaLocal in einer nutzerverständlichen (entsprechend der Schreibweise) Art und Weise interpretiert und bei der Eigenschaft FormulaR1C1 erwartet Excel 'Z1S1-Bezüge in der Sprache des Makros', was nicht deiner Schreibweise entspricht.
Mit Schreibweise meine ich "=WENN(I3+4=A1;""Anrufen"";"""")"
Ich hoffe ich konnte dir weiterhelfen
Gruß, jan-und-jana

Bild

Betrifft: AW: wenn funktion über vba in zelle
von: Erik Walker
Geschrieben am: 22.04.2005 10:35:47
Es klappt trotzdem nicht.
Bild

Betrifft: AW: wenn funktion über vba in zelle
von: jan-und-iana
Geschrieben am: 22.04.2005 11:02:04
Hallo Erik,
ich hab es bei mir getestet und es funktioniert.
Ich habe in A1, 7 geschrieben.
in I3, 3 geschrieben.
auf Strg+q hab ich folgendes Makro Modul1.Makr01 gelegt (mit Makro Aufzeichnen).

Sub Makro1()
'
' Makro1 Makro
' Makro am 22.04.2005 von jan-und-jana aufgezeichnet
'
'    ActiveCell.FormulaR1C1 = "=WENN(I3+4=A1;""Anrufen"";"""")"
    ActiveCell.FormulaLocal = "=WENN(I3+4=A1;""Anrufen"";"""")"
'
End Sub

Jetz selectiere ich eine beliebige Zelle im Tabellen-Blatt, wo sich A1 und I3 befinden und siehe da es funktioniert.
Gruß jan-und-jana
PS.: Ich konnte die Datei leider nicht hoch laden um es zu zeigen
 Bild

Beiträge aus den Excel-Beispielen zum Thema "wenn funktion über vba in zelle"