Zählenwenn ...

Bild

Betrifft: Zählenwenn ...
von: Guido
Geschrieben am: 22.04.2005 10:46:21
Hallo Experten,
wie kann ich die Funktion ZÄHLENWENN dahin gehend ergänzen, dass zusätzlich zu der Bedingung in Spalte G (Postleitzahlbereich zwischen 63000 und 63999) auch die Bedingung in Spalte C (die Endziffer, d.h. die 6.+7.Zahl rechts) soll zwischen 00 und 49 (bzw. 50 und 99) liegen.
Hintergrund ist der, dass der End-Nr. Bereich jetzt zwei Sachbearbeitern zugewiesen ist (00-49 und 50-99)
Folgendes Konstrukt habe ich bisjetzt:
=(ZÄHLENWENN('[Statistik-BH.xls]Berufshilfe'!$G$2:$G$4999;">="&63000)-(ZÄHLENWENN('[Statistik-BH.xls]Berufshilfe'!$G$2:$G$4999;">="&64000)))
was vermutlich ergänzt werden muss mit:
*(ZÄHLENWENN('[Statistik-BH.xls]Berufshilfe'!$C$2:$C$4999; (right(6,7); ">="&00)-(ZÄHLENWENN('[Statistik-BH.xls]Berufshilfe'!$C$2:$C$4999; (right(6,7); ">="&49)
oder so ähnlich. Dass das ganze dann als Matrixfunktion mit geschweiften Klammern eingeschlossen werden muss, ist mir bekannt.
Ich bin für jeden Tipp dankbar.
Liebe Grüße aus Würzburg
Guido Ludwig

Bild

Betrifft: AW: Zählenwenn ...
von: heikoS
Geschrieben am: 22.04.2005 10:59:29
Hallo Guido,
so sollte es funktionieren:
=SUMMENPRODUKT((A2:A6<64000)*(A2:A6>62999)*(RECHTS(A2:A6;2)>="00")*(RECHTS(A2:A6;2)<"50"))
Mußt Du noch an Deinen Zellbereich anpassen.

Gruß Heiko
Bild

Betrifft: AW: Zählenwenn ...
von: Guido
Geschrieben am: 22.04.2005 11:42:10
Hallo Heiko,
leider komme ich mit der Syntax nicht zurecht:
=((SUMMENPRODUKT(RECHTS('[Statistik-BH.xls]Berufshilfe'!$C$11:$C$13;2)>="00")))
bringt mir als Ergebnis "0" obwohl sich in den Zellen C11:C13 die Zahlen 10, 20 und 99 befinden!
Was mache ich verkehrt?
Danke für deine Hilfe
Gruß
Guido
Bild

Betrifft: AW: Zählenwenn ...
von: heikoS
Geschrieben am: 22.04.2005 11:50:17
Hallo Guido,
=SUMMENPRODUKT((RECHTS('[Statistik-BH.xls]Berufshilfe'!$C$11:$C$13;2)>="00")*1)
Warum hast Du die Formel in (( )) gesetzt?

Gruß Heiko
Bild

Betrifft: Danke Heiko und schönes Wochenende (o.T.)
von: Guido
Geschrieben am: 22.04.2005 11:55:17

Bild

Betrifft: Danke, Dir auch! oT
von: heikoS
Geschrieben am: 22.04.2005 11:57:21

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Markieren von Sheets"