Herbers Excel-Forum - das Archiv

mehrere Fragen VBA

Bild

Betrifft: mehrere Fragen VBA
von: Hagen

Geschrieben am: 26.04.2005 11:11:18
Hallo,
ich habe heute den Auftrag bekommen ne excel basierte Auswertung von einigen Daten zu basteln, mit der Bitte, dass die Handhabung durch Excel Anfänger möglich ist. Ergo, nahezu nichts tun müssen ;)
Gut, das heisst dann wohl Gebrauch von Makros, allerdings kenne ich mich da rein garnicht aus und mit gesundem Menschenverstand kommt man auch nicht weiter, also hier meine Fragen/Bitten:
Nummer 1)
In einem Tabellenblatt sind Daten gelistet (je 4 pro Jahr) per Makro soll bei Bedarf ein Tabellenkopf für das nächste Jahr erstellt werden (also "neben die letzte Spalte" gesetzt)
Nummer 2)
Die Daten sollen die Leute über importierte SAP Reports reinholen, wobei halt neue Datenblätter ans Ende gesetzt werden (ZB "Personalbestand 2005")
Als nächstes soll ein Makro einen Sverweis schreiben, aber automatisch dieses Datenblatt als Bezug nehmen. (mal als Bsp: =SVERWEIS(C24;Personal_12_2005!$B$2:$E$5000;2;FALSCH) )
Geht das? wenn ja, wie?
Wenn ich diese 2 Dinge wüsste, wär mir schon immens geholfen!
Danke im Vorraus.
Bild

Betrifft: AW: mehrere Fragen VBA
von: Norbert
Geschrieben am: 26.04.2005 11:14:15
Hallo,
dann sag' doch denen, die Dir den Auftrag gegegen haben, daß Hans Herber auch Auftragsprogrammierungen macht.
Dieses hier ist wohl eher eine komplette Anwendung.
Gruß
Norbert
Bild

Betrifft: hmm
von: Hagen

Geschrieben am: 26.04.2005 11:20:06
also eher nein, an sich sinds kleinigkeiten ... soll halt für Excel-noch-nie-gesehen Leute handlebar sein. Mit Funktionen selber schreiben braucht man denen ja net kommen, daher eben die Makros.
Ich versuchs gerade mit verketten und solchen spielereien
also wirklich helfen würde mir vorallem, welcher Befehl mich nun neben die letzte benutzte Spalte in Zeile X springen lassen würde.
thx ;)
Bild

Betrifft: AW: hmm
von: Martin Beck

Geschrieben am: 26.04.2005 11:35:31
Hallo Hagen,
"Kleinigkeiten" - na ja ;-)
Zu Deiner letzten Frage hier ein Beispiel für Zeile 3:
Sub Letzte_markieren()
Range("IV3").End(xlToLeft).Offset(0, 1).Select
End Sub

Sub Letzte_Spaltennummer()
s = Range("IV3").End(xlToLeft).Column + 1
MsgBox s
End Sub


Zu SVERWEIS in VBA: Dort heißt die Funktion VLOOKUP. Schau mal danach in der Recherche.
Ansonsten könntest Du noch eine Beispieldatei hochladen.
Gruß
Martin Beck
Bild

Betrifft: zu 1)
von: Reinhard
Geschrieben am: 26.04.2005 11:28:49
Hallo Hagen,
letzteSpalte=activesheet.Range("A256").end(xltoleft).column
Viele Grüße
Reinhard
 Bild
Excel-Beispiele zum Thema "mehrere Fragen VBA"
Suche über mehrere Tabellen Mehrere Schaltflächen für ein Makro
Suchbegriff über mehrere Tabellenblätter suchen. Benutzerdefinierte SVERWEIS-Funktion über mehrere Bereiche
Druck aus mehreren Tabellenblättern auf eine Druckseite AutoFilter über mehrere Arbeitsblätter setzen
Daten von mehreren Blättern auf ein Druckblatt Prozentuale Erhöhung über mehrere Arbeitsblätter hinweg
Werte in mehreren Spalten sortieren Textreihe auf mehrere Spalten mit fester Seitenlänge verteilen