Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
616to620
616to620
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Liste mit Wochentagen erstellen!

Liste mit Wochentagen erstellen!
04.06.2005 13:32:30
Alfred
Hallo an Alle!
Ich möchte eine Datums-Liste (von 2005 bis 210)in Excel erstellen die nur die Werktage beinhaltet (Mo - Fr). Gib es da eine Möglichkeit das automatisch zu erstellen?
Gruß und Danke
Alfred

13
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Liste mit Wochentagen erstellen!
04.06.2005 13:35:39
Hajo_Zi
Hallo Aöfred,
hier ein Beispiel für einen Monat, bei Excel Gut bekomst Du das bstimmt geändert.
01
 AB
1Von01.02.2004
2bis:29.02.2004
3  
402. Feb 04Montag
503. Feb 04Dienstag
604. Feb 04Mittwoch
705. Feb 04Donnerstag
806. Feb 04Freitag
909. Feb 04Montag
1010. Feb 04Dienstag
1111. Feb 04Mittwoch
1212. Feb 04Donnerstag
1313. Feb 04Freitag
1416. Feb 04Montag
1517. Feb 04Dienstag
1618. Feb 04Mittwoch
1719. Feb 04Donnerstag
1820. Feb 04Freitag
1923. Feb 04Montag
2024. Feb 04Dienstag
2125. Feb 04Mittwoch
2226. Feb 04Donnerstag
2327. Feb 04Freitag
Formeln der Tabelle
B2 : =DATUM(JAHR(B1);MONAT(B1)+1;TAG(B1))-1
A4 : =WENN(WOCHENTAG(B1;2)=5;B1+3;WENN(WOCHENTAG(B1;2)=6;B1+2;WENN(WOCHENTAG(B1;2)=7;B1+1;B1)))
B4 : =A4
A5 : =WENN(A4>=$B$2;"";WENN(A4=0;;WENN(WOCHENTAG(A4;2)=5;WENN(MONAT(A4+3)<>MONAT($B$2);"";A4+3);WENN(MONAT(A4+1)<>MONAT($B$2);"";A4+1))))
B5 : =A5
A6 : =WENN(A5>=$B$2;"";WENN(A5=0;;WENN(WOCHENTAG(A5;2)=5;WENN(MONAT(A5+3)<>MONAT($B$2);"";A5+3);WENN(MONAT(A5+1)<>MONAT($B$2);"";A5+1))))
B6 : =A6
A7 : =WENN(A6>=$B$2;"";WENN(A6=0;;WENN(WOCHENTAG(A6;2)=5;WENN(MONAT(A6+3)<>MONAT($B$2);"";A6+3);WENN(MONAT(A6+1)<>MONAT($B$2);"";A6+1))))
B7 : =A7
A8 : =WENN(A7>=$B$2;"";WENN(A7=0;;WENN(WOCHENTAG(A7;2)=5;WENN(MONAT(A7+3)<>MONAT($B$2);"";A7+3);WENN(MONAT(A7+1)<>MONAT($B$2);"";A7+1))))
B8 : =A8
A9 : =WENN(A8>=$B$2;"";WENN(A8=0;;WENN(WOCHENTAG(A8;2)=5;WENN(MONAT(A8+3)<>MONAT($B$2);"";A8+3);WENN(MONAT(A8+1)<>MONAT($B$2);"";A8+1))))
B9 : =A9
A10 : =WENN(A9>=$B$2;"";WENN(A9=0;;WENN(WOCHENTAG(A9;2)=5;WENN(MONAT(A9+3)<>MONAT($B$2);"";A9+3);WENN(MONAT(A9+1)<>MONAT($B$2);"";A9+1))))
B10 : =A10
A11 : =WENN(A10>=$B$2;"";WENN(A10=0;;WENN(WOCHENTAG(A10;2)=5;WENN(MONAT(A10+3)<>MONAT($B$2);"";A10+3);WENN(MONAT(A10+1)<>MONAT($B$2);"";A10+1))))
B11 : =A11
A12 : =WENN(A11>=$B$2;"";WENN(A11=0;;WENN(WOCHENTAG(A11;2)=5;WENN(MONAT(A11+3)<>MONAT($B$2);"";A11+3);WENN(MONAT(A11+1)<>MONAT($B$2);"";A11+1))))
B12 : =A12
A13 : =WENN(A12>=$B$2;"";WENN(A12=0;;WENN(WOCHENTAG(A12;2)=5;WENN(MONAT(A12+3)<>MONAT($B$2);"";A12+3);WENN(MONAT(A12+1)<>MONAT($B$2);"";A12+1))))
B13 : =A13
A14 : =WENN(A13>=$B$2;"";WENN(A13=0;;WENN(WOCHENTAG(A13;2)=5;WENN(MONAT(A13+3)<>MONAT($B$2);"";A13+3);WENN(MONAT(A13+1)<>MONAT($B$2);"";A13+1))))
B14 : =A14
A15 : =WENN(A14>=$B$2;"";WENN(A14=0;;WENN(WOCHENTAG(A14;2)=5;WENN(MONAT(A14+3)<>MONAT($B$2);"";A14+3);WENN(MONAT(A14+1)<>MONAT($B$2);"";A14+1))))
B15 : =A15
A16 : =WENN(A15>=$B$2;"";WENN(A15=0;;WENN(WOCHENTAG(A15;2)=5;WENN(MONAT(A15+3)<>MONAT($B$2);"";A15+3);WENN(MONAT(A15+1)<>MONAT($B$2);"";A15+1))))
B16 : =A16
A17 : =WENN(A16>=$B$2;"";WENN(A16=0;;WENN(WOCHENTAG(A16;2)=5;WENN(MONAT(A16+3)<>MONAT($B$2);"";A16+3);WENN(MONAT(A16+1)<>MONAT($B$2);"";A16+1))))
B17 : =A17
A18 : =WENN(A17>=$B$2;"";WENN(A17=0;;WENN(WOCHENTAG(A17;2)=5;WENN(MONAT(A17+3)<>MONAT($B$2);"";A17+3);WENN(MONAT(A17+1)<>MONAT($B$2);"";A17+1))))
B18 : =A18
A19 : =WENN(A18>=$B$2;"";WENN(A18=0;;WENN(WOCHENTAG(A18;2)=5;WENN(MONAT(A18+3)<>MONAT($B$2);"";A18+3);WENN(MONAT(A18+1)<>MONAT($B$2);"";A18+1))))
B19 : =A19
A20 : =WENN(A19>=$B$2;"";WENN(A19=0;;WENN(WOCHENTAG(A19;2)=5;WENN(MONAT(A19+3)<>MONAT($B$2);"";A19+3);WENN(MONAT(A19+1)<>MONAT($B$2);"";A19+1))))
B20 : =A20
A21 : =WENN(A20>=$B$2;"";WENN(A20=0;;WENN(WOCHENTAG(A20;2)=5;WENN(MONAT(A20+3)<>MONAT($B$2);"";A20+3);WENN(MONAT(A20+1)<>MONAT($B$2);"";A20+1))))
B21 : =A21
A22 : =WENN(A21>=$B$2;"";WENN(A21=0;;WENN(WOCHENTAG(A21;2)=5;WENN(MONAT(A21+3)<>MONAT($B$2);"";A21+3);WENN(MONAT(A21+1)<>MONAT($B$2);"";A21+1))))
B22 : =A22
A23 : =WENN(A22>=$B$2;"";WENN(A22=0;;WENN(WOCHENTAG(A22;2)=5;WENN(MONAT(A22+3)<>MONAT($B$2);"";A22+3);WENN(MONAT(A22+1)<>MONAT($B$2);"";A22+1))))
B23 : =A23
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Bitte keine Mail, Probleme sollten im Forum gelöst werden.
Microsoft MVP für Excel
Das Forum lebt auch von den Rückmeldungen.
Betriebssystem XP Home SP2 und Excel Version 2003 SP1.


Anzeige
AW: Liste mit Wochentagen erstellen!
04.06.2005 14:19:34
Alfred
Hallo Hajo,
da hab ich meine Excel Fähigkeiten wohl ziemlich überschätzt, ich bekomme das leider nicht hin und bitte deshalb nochmals um Hilfe!
Gruß
und DANKE
Alfred
AW: Liste mit Wochentagen erstellen!
04.06.2005 14:20:02
Alfred
Hallo Hajo,
da hab ich meine Excel Fähigkeiten wohl ziemlich überschätzt, ich bekomme das leider nicht hin und bitte deshalb nochmals um Hilfe!
Gruß
und DANKE
Alfred
AW: Liste mit Wochentagen erstellen!
04.06.2005 14:20:12
Alfred
Hallo Hajo,
da hab ich meine Excel Fähigkeiten wohl ziemlich überschätzt, ich bekomme das leider nicht hin und bitte deshalb nochmals um Hilfe!
Gruß
und DANKE
Alfred
AW: Liste mit Wochentagen erstellen!
04.06.2005 14:20:50
Alfred
Hallo Hajo,
da hab ich meine Excel Fähigkeiten wohl ziemlich überschätzt, ich bekomme das leider nicht hin und bitte deshalb nochmals um Hilfe!
Gruß
und DANKE
Alfred
Anzeige
AW: Liste mit Wochentagen erstellen!
04.06.2005 14:20:57
Alfred
Hallo Hajo,
da hab ich meine Excel Fähigkeiten wohl ziemlich überschätzt, ich bekomme das leider nicht hin und bitte deshalb nochmals um Hilfe!
Gruß
und DANKE
Alfred
AW: Liste mit Wochentagen erstellen!
04.06.2005 14:23:40
Alfred
Tut mir leid, daß meine Antwort so oft gepostet wurde, da ist was falschgelaufen!
Alfred
AW: Liste mit Wochentagen erstellen!
04.06.2005 14:29:06
Hajo_Zi
Hallo Alfred,
01
 AB
1Von01.02.2004
2  
302. Feb 04Montag
403. Feb 04Dienstag
Formeln der Tabelle
A3 : =WENN(WOCHENTAG(B1;2)=5;B1+3;WENN(WOCHENTAG(B1;2)=6;B1+2;WENN(WOCHENTAG(B1;2)=7;B1+1;B1)))
B3 : =A3
A4 : =WENN(WOCHENTAG(A3;2)=5;A3+3;A3+1)
B4 : =A4
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Gruß Hajo
Das Forum lebt auch von den Rückmeldungen.
Anzeige
AW: Liste mit Wochentagen erstellen!
04.06.2005 14:35:45
Alfred
Hallo Hajo!
Danke für die Hilfe jetzt hab ichs geschnallt, vielen Dank!
Gruß
Alfred
AW: Liste mit Wochentagen erstellen!
04.06.2005 14:23:26
Fred
Hi,
das geht auch ganz ohne Formel mit wenigen Mausklicks.
Gib in einer Zelle das Stardatum ein.
Markier die Spalte
Bearbeiten, ausfüllen, Reihe, Wochentag, ok, fertig.
mfg Fred
AW: Liste mit Wochentagen erstellen!
04.06.2005 14:30:30
Alfred
Hallo Fred!
Herzlichen DANK hat einwandfrei funktioniert!
Gru�
Alfred
AW: Liste mit Wochentagen erstellen!
04.06.2005 19:54:59
rlenz
Hallo Alfred,
sieh mal hier:
https://www.herber.de/bbs/user/23631.xls
und teilweise auch hier:
 
 HI
1Dein Wille geschehe: Gut, das Anfangsdatum eines Jahres erscheint nicht.
2Berechnungnur prüfen
3Jahr Eingeben 
41999 
5  
601.01.1999Freitag
704.01.1999Montag
805.01.1999Dienstag
906.01.1999Mittwoch
1007.01.1999Donnerstag
1108.01.1999Freitag
1211.01.1999Montag
1312.01.1999Dienstag
1413.01.1999Mittwoch
1514.01.1999Donnerstag
1615.01.1999Freitag
1718.01.1999Montag
1819.01.1999Dienstag
1920.01.1999Mittwoch
2021.01.1999Donnerstag
2122.01.1999Freitag
2225.01.1999Montag
2326.01.1999Dienstag
2427.01.1999Mittwoch
2528.01.1999Donnerstag
Formeln der Tabelle
I5 : =WENN(H5="";"";H5)
H6 : =WENN(ISTZAHL(H4)=FALSCH;"";WENN(WOCHENTAG(DATUM(H4;1;1);2)=6;DATUM(H4;1;1)+2;WENN(WOCHENTAG(DATUM(H4;1;1);2)=7;DATUM(H4;1;1)+1;DATUM(H4;1;1))))
I6 : =WENN(H6="";"";H6)
H7 : =WENN(H6="";"";WENN(WOCHENTAG(H6;2)=5;H6+3;WENN(WOCHENTAG(H6;2)=6;H6+2;WENN(WOCHENTAG(H6;2)=7;H6+1;H6+1))))
I7 : =WENN(H7="";"";H7)
H8 : =WENN(H7="";"";WENN(WOCHENTAG(H7;2)=5;H7+3;WENN(WOCHENTAG(H7;2)=6;H7+2;WENN(WOCHENTAG(H7;2)=7;H7+1;H7+1))))
I8 : =WENN(H8="";"";H8)
H9 : =WENN(H8="";"";WENN(WOCHENTAG(H8;2)=5;H8+3;WENN(WOCHENTAG(H8;2)=6;H8+2;WENN(WOCHENTAG(H8;2)=7;H8+1;H8+1))))
I9 : =WENN(H9="";"";H9)
H10 : =WENN(H9="";"";WENN(WOCHENTAG(H9;2)=5;H9+3;WENN(WOCHENTAG(H9;2)=6;H9+2;WENN(WOCHENTAG(H9;2)=7;H9+1;H9+1))))
I10 : =WENN(H10="";"";H10)
H11 : =WENN(H10="";"";WENN(WOCHENTAG(H10;2)=5;H10+3;WENN(WOCHENTAG(H10;2)=6;H10+2;WENN(WOCHENTAG(H10;2)=7;H10+1;H10+1))))
I11 : =WENN(H11="";"";H11)
H12 : =WENN(H11="";"";WENN(WOCHENTAG(H11;2)=5;H11+3;WENN(WOCHENTAG(H11;2)=6;H11+2;WENN(WOCHENTAG(H11;2)=7;H11+1;H11+1))))
I12 : =WENN(H12="";"";H12)
H13 : =WENN(H12="";"";WENN(WOCHENTAG(H12;2)=5;H12+3;WENN(WOCHENTAG(H12;2)=6;H12+2;WENN(WOCHENTAG(H12;2)=7;H12+1;H12+1))))
I13 : =WENN(H13="";"";H13)
H14 : =WENN(H13="";"";WENN(WOCHENTAG(H13;2)=5;H13+3;WENN(WOCHENTAG(H13;2)=6;H13+2;WENN(WOCHENTAG(H13;2)=7;H13+1;H13+1))))
I14 : =WENN(H14="";"";H14)
H15 : =WENN(H14="";"";WENN(WOCHENTAG(H14;2)=5;H14+3;WENN(WOCHENTAG(H14;2)=6;H14+2;WENN(WOCHENTAG(H14;2)=7;H14+1;H14+1))))
I15 : =WENN(H15="";"";H15)
H16 : =WENN(H15="";"";WENN(WOCHENTAG(H15;2)=5;H15+3;WENN(WOCHENTAG(H15;2)=6;H15+2;WENN(WOCHENTAG(H15;2)=7;H15+1;H15+1))))
I16 : =WENN(H16="";"";H16)
H17 : =WENN(H16="";"";WENN(WOCHENTAG(H16;2)=5;H16+3;WENN(WOCHENTAG(H16;2)=6;H16+2;WENN(WOCHENTAG(H16;2)=7;H16+1;H16+1))))
I17 : =WENN(H17="";"";H17)
H18 : =WENN(H17="";"";WENN(WOCHENTAG(H17;2)=5;H17+3;WENN(WOCHENTAG(H17;2)=6;H17+2;WENN(WOCHENTAG(H17;2)=7;H17+1;H17+1))))
I18 : =WENN(H18="";"";H18)
H19 : =WENN(H18="";"";WENN(WOCHENTAG(H18;2)=5;H18+3;WENN(WOCHENTAG(H18;2)=6;H18+2;WENN(WOCHENTAG(H18;2)=7;H18+1;H18+1))))
I19 : =WENN(H19="";"";H19)
H20 : =WENN(H19="";"";WENN(WOCHENTAG(H19;2)=5;H19+3;WENN(WOCHENTAG(H19;2)=6;H19+2;WENN(WOCHENTAG(H19;2)=7;H19+1;H19+1))))
I20 : =WENN(H20="";"";H20)
H21 : =WENN(H20="";"";WENN(WOCHENTAG(H20;2)=5;H20+3;WENN(WOCHENTAG(H20;2)=6;H20+2;WENN(WOCHENTAG(H20;2)=7;H20+1;H20+1))))
I21 : =WENN(H21="";"";H21)
H22 : =WENN(H21="";"";WENN(WOCHENTAG(H21;2)=5;H21+3;WENN(WOCHENTAG(H21;2)=6;H21+2;WENN(WOCHENTAG(H21;2)=7;H21+1;H21+1))))
I22 : =WENN(H22="";"";H22)
H23 : =WENN(H22="";"";WENN(WOCHENTAG(H22;2)=5;H22+3;WENN(WOCHENTAG(H22;2)=6;H22+2;WENN(WOCHENTAG(H22;2)=7;H22+1;H22+1))))
I23 : =WENN(H23="";"";H23)
H24 : =WENN(H23="";"";WENN(WOCHENTAG(H23;2)=5;H23+3;WENN(WOCHENTAG(H23;2)=6;H23+2;WENN(WOCHENTAG(H23;2)=7;H23+1;H23+1))))
I24 : =WENN(H24="";"";H24)
H25 : =WENN(H24="";"";WENN(WOCHENTAG(H24;2)=5;H24+3;WENN(WOCHENTAG(H24;2)=6;H24+2;WENN(WOCHENTAG(H24;2)=7;H24+1;H24+1))))
I25 : =WENN(H25="";"";H25)
 
Spalte I zeigt nur den "deutschen" DIN bzw. EN Wochentag an und dient nur zur Kontrolle.
MfG
Rüdiger
Anzeige
AW: Liste mit Wochentagen erstellen!
04.06.2005 19:56:50
Alfred
DSanke dir Rüdiger!

179 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige