Gleiche Werte zusammenfassen und zählen

Bild

Betrifft: Gleiche Werte zusammenfassen und zählen von: clsven
Geschrieben am: 09.02.2006 00:07:33

Hallo,

habe ein vielleicht relativ simples Problem, aber irgendwie ein Brett vorm Kopf :-).

Mit einem EAN-Scanner habe ich verschiedene EAN-Codes in einer Tabelle erfaßt, es ist somit pro EAN eine Zeile gefüllt, alle Codes stehen untereinander in einer Spalte.

1234
4321
1234
1234
78787 usw...

Ich möchte nun die IDENTISCHEN Codes zusammenfassen, genau genommen zählen.

Das Ergebnis sollte etwa so aussehen:
Bsp.: EAN CODE 1234 = 5x
EAN CODE 4321 = 10x
EAN CODE 1111 = 1x

Diese Auswertung sollte am besten in einer separaten Spalte erfolgen.
Wie kann ich mein Problem lösen? Wäre toll, wenn mir jemand schnell helfen könnte, am Freitag haben wir Inventur :-).

Vielen Dank im voraus!

Gruß

SVEN

Bild


Betrifft: AW: Gleiche Werte zusammenfassen und zählen von: Josef Ehrensberger
Geschrieben am: 09.02.2006 00:17:48

Hallo Sven!

Die Formeln aus F2 und G2 kannst du nach unten kopieren!

Tabelle2
 ABCDEFG
11234    12343
24321    43211
31234    787871
41234      
578787      
6       
Formeln der Tabelle
F1 : =MIN(A:A)
G1 : =WENN(F1<>"";ZÄHLENWENN(A:A;F1);"")
F2 : =WENN(MAX(A:A)=MAX(F$1:F1);"";KGRÖSSTE(A:A;ZÄHLENWENN(A:A;">"&F1)))
G2 : =WENN(F2<>"";ZÄHLENWENN(A:A;F2);"")
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  




'******************************
'* Gruß Sepp
'*
'* Rückmeldung wäre nett!
'******************************



Bild


Betrifft: AW: Gleiche Werte zusammenfassen und zählen von: clsven
Geschrieben am: 09.02.2006 22:02:34

Danke für die superschnelle Antwort, hat mir echt wahnsinnig geholfen und jetzt klappt alles wie gewünscht und einwandfrei! Jetzt kann die Inventur starten...vielen Dank!!!

Gruß

der SVEN


Bild


Betrifft: AW: Gleiche Werte zusammenfassen und zählen von: et999
Geschrieben am: 09.02.2006 00:20:00

Hi Sven,
so (s.u.) hast Du neben jedem Artikel in Deiner Liste stehen wie oft er vorkommt.
Wenn Du eine extra Liste mit allen möglichen Artikeln hast kann man da auch mit ZÄHLENWENN die Mengen eintragen.
Tabelle2
 AB
112343
243211
312343
412343
5787874
6787874
7456541
8787874
9787874
Formeln der Tabelle
B1 : =ZÄHLENWENN(A:A;A1)
B2 : =ZÄHLENWENN(A:A;A2)
B3 : =ZÄHLENWENN(A:A;A3)
B4 : =ZÄHLENWENN(A:A;A4)
B5 : =ZÄHLENWENN(A:A;A5)
B6 : =ZÄHLENWENN(A:A;A6)
B7 : =ZÄHLENWENN(A:A;A7)
B8 : =ZÄHLENWENN(A:A;A8)
B9 : =ZÄHLENWENN(A:A;A9)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

Gruß
Uwe
(:o)


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Gleiche Werte zusammenfassen und zählen"