Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
748to752
748to752
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Anzahl Tage im Zeitbereich

Anzahl Tage im Zeitbereich
25.03.2006 09:41:46
rlenz
Hallo, wer kann mir helfen.
Ich möchte die Anzahl von Tagen mit einer Formel aus einer Liste ermitteln, die in einem vorgegebenen Zeitraum fallen.
 
 ABCDEFGH
1Anzahl von Tagen im vorgegebenen Zeitbereich  
2von, nicht ein- schließlichbis, ein- schließlich ListeListe, Spezialfilter keine DuplikateErgebnis von H3 ohne Hilfsspalten?so nicht
301.04.200620.04.2006 02.04.200602.04.2006 16
4   09.04.200609.04.2006 1 
5   16.04.200616.04.2006 1 
6   23.04.200623.04.2006 0 
7   30.04.200630.04.2006 0 
8   07.05.200607.05.2006 0 
9   14.05.200614.05.2006 0 
10   21.05.200621.05.2006 0 
11   28.05.200628.05.2006 0 
12   04.06.200604.06.2006 0 
13   11.06.200611.06.2006 0 
14   18.06.200618.06.2006 0 
15   14.04.200614.04.2006 1 
16   17.04.200617.04.2006 1 
17   09.04.200603.04.2006 1 
18   03.04.2006  0 
Formeln der Tabelle
G3 : =WENN(UND(E3>$A$3;E3;1;0)
H3 : =SUMME(G3:G33)
G4 : =WENN(UND(E4>$A$3;E4;1;0)
G5 : =WENN(UND(E5>$A$3;E5;1;0)
G6 : =WENN(UND(E6>$A$3;E6;1;0)
G7 : =WENN(UND(E7>$A$3;E7;1;0)
G8 : =WENN(UND(E8>$A$3;E8;1;0)
G9 : =WENN(UND(E9>$A$3;E9;1;0)
G10 : =WENN(UND(E10>$A$3;E10;1;0)
G11 : =WENN(UND(E11>$A$3;E11;1;0)
G12 : =WENN(UND(E12>$A$3;E12;1;0)
G13 : =WENN(UND(E13>$A$3;E13;1;0)
G14 : =WENN(UND(E14>$A$3;E14;1;0)
G15 : =WENN(UND(E15>$A$3;E15;1;0)
G16 : =WENN(UND(E16>$A$3;E16;1;0)
G17 : =WENN(UND(E17>$A$3;E17;1;0)
G18 : =WENN(UND(E18>$A$3;E18;1;0)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
MfG
Rüdiger Lenz

6
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Anzahl Tage im Zeitbereich
ransi
Hallo rüdiger
Mal 2 Möglichkeiten:
 
 ABCDEFGHI
1Anzahl von Tagen im vorgegebenen Zeitbereich   
2von, nicht ein- schließlichbis, ein- schließlich ListeListe, Spezialfilter keine DuplikateErgebnis von H3 ohne Hilfsspalten?so nicht 
301.04.200620.04.2006 02.04.200602.04.2006 166
4   09.04.200609.04.2006 1  
5   16.04.200616.04.2006 1  
6   23.04.200623.04.2006 0  
7   30.04.200630.04.2006 0  
8   07.05.200607.05.2006 0  
9   14.05.200614.05.2006 0  
10   21.05.200621.05.2006 0  
11   28.05.200628.05.2006 0  
12   04.06.200604.06.2006 0  
13   11.06.200611.06.2006 0  
14   18.06.200618.06.2006 0  
15   14.04.200614.04.2006 1  
16   17.04.200617.04.2006 1  
17   09.04.200603.04.2006 1  
18   03.04.2006  0  
Formeln der Tabelle
H3 : =SUMMENPRODUKT((E3:E18>=A3)*(E3:E18<=B3))
I3 : =ZÄHLENWENN(E3:E18;">=" &A3)-ZÄHLENWENN(E3:E18;">=" &B3)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
ransi
Anzeige
AW: Anzahl Tage im Zeitbereich
25.03.2006 11:16:09
rlenz
Hallo Ransi,
deine Lösungen sind Klasse. Vielen Dank.
Diese Lösung =INDEX(HÄUFIGKEIT(E:E;{38808;38827});2) funktioniert auch. Wie aber bekomme ich die Datumwerte in die Formel ohne die Datumwerte mühsam im Standard- Format reinschreiben zu müssen?
MfG
Rüdiger Lenz
AW: Anzahl Tage im Zeitbereich
25.03.2006 13:35:48
Josef
Hallo Rüdiger
Mit Häufigkeit würde das so gehen.
=INDEX(HÄUFIGKEIT(E:E;A3:B3);2)
Aber eben nur würde!! Wenn das Startdatum von A3 in E3:E18 auch vorkommt, dann liefert dir die Formel diesen Treffer nicht.
Die zählenwenn Formel von Ransi hat noch einen kleinen Fehler.
Seine Formel:=ZÄHLENWENN(E3:E18;"&gt=" &A3)-ZÄHLENWENN(E3:E18;"&gt=" &B3)
Richtig ist : =ZÄHLENWENN(E3:E18;"&gt=" &A3)-ZÄHLENWENN(E3:E18;"&gt" &B3)
Gruss Josef
Anzeige
AW: Anzahl Tage im Zeitbereich
25.03.2006 15:53:20
rlenz
Hallo Josef,
recht vielen Dank für deine Hinweise. Ich habe entsprechende Korrekturen vorgenommen. Diese Formel =INDEX(HÄUFIGKEIT(E:E;A3:B3);2)geht doch auch dann wenn das Startdatum von A3 in E3:E18 auch vorkommt, oder mache ich da etwas falsch?
MfG
Rüdiger Lenz
Nein du machst nichts falsch
25.03.2006 16:52:18
Josef
Hallo Rüdiger
Die Überschrift in A2, "nicht ein- schließlich", habe ich nicht gelesen.
Auch Ransi hatte das mit seinen Formeln übersehen.
Aber du hast das natürlich mit Leichtigkeit korrigiert. :-)
Gruss Josef
AW: Dank an Ransi und Josef
26.03.2006 10:51:09
rlenz
 

315 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige