Live-Forum - Die aktuellen Beiträge
Datum
Titel
15.07.2024 16:00:57
15.07.2024 15:41:38
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
748to752
748to752
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Feiertage eines Monats errechnen

Feiertage eines Monats errechnen
01.04.2006 22:18:38
DieterG.
Guten Abend zusammen,
ich brauch mal wieder einmal Euere Hilfe bei einer Formel.
Ich habe das Problem in einer Beispieldatei beschrieben.
https://www.herber.de/bbs/user/32528.xls
Danke schon mal und noch ein schönes Wochenende
Gruß
Dieter

10
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Feiertage eines Monats errechnen
01.04.2006 22:44:19
Reinhard
Hi Dieter,
ich verstehe deine Tabelle nicht, 14.6 und 17.6 sind gelb markiert, hinter 14.6 steht ein "x" und du sagst in der Tabelle:
In Zelle E2 soll die Anzahl der Feiertage eines Monats errechnet werden welche auf einen Werktag fallen und wenn in SpalteC ein x eingetragen wurde.
Das heisst für mich E2 muss 0 sein!?
Gruß
Reinhard
AW: Feiertage eines Monats errechnen
01.04.2006 23:07:53
DieterG.
Hallo Reihard,
in Zelle B2 gehört 01.04.2006 eingegeben. Anscheinend habe ich bevor ich die Datei weggeschickt habe noch ein anderes Datum eingegeben.
Der 14.04.2006 (Karfreitag) und der 17.04.2006 (Otermontag) sind Feiertage an einem Werktag.
In C15 ist ein x eingetragen. Das eregebniss in E2 müsste also 1 sein!
Danke
Gruß
Dieter
Anzeige
AW: Feiertage eines Monats errechnen
01.04.2006 23:08:21
GeorgK
Hallo,
habe ich das richtig verstanden, dass in Deinem Beispiel die Summe aus den zwei Feiertagen und einem X gebildet werden soll und Dein Ergebnis 3 sein müsste?, dann
=SUMMENPRODUKT(NETTOARBEITSTAGE(B2;B31)-NETTOARBEITSTAGE(B2;B31;Feiertage))+ZÄHLENWENN(C2:C31;"X")
Grüße
Georg
AW: Feiertage eines Monats errechnen
01.04.2006 23:19:30
DieterG.
Hallo Georg,
das Ergebnis müsste nicht 3 sondern 1 sein!!
Gruß Dieter
AW: Feiertage eines Monats errechnen
01.04.2006 23:19:16
Armin
Hi
ich verstehe deine Tabelle nicht, du muss nur nochmal lesen
AW: Feiertage eines Monats errechnen
02.04.2006 01:48:04
DieterG.
Frage noch offen!!
AW: Feiertage eines Monats errechnen
02.04.2006 09:52:21
Werner
Hallo Dieter
Ich habe in Zelle E1 die Monatszahl eingegeben. In E2 folgende Formel ....
=SUMMENPRODUKT((WOCHENTAG(G15:G31;2)&lt6)*(MONAT(Feiertage)=E1))
Gruss Werner
Anzeige
AW: Feiertage eines Monats errechnen
ransi
Hallo
versuchs mal so:
 
 DE
2 1
Formeln der Tabelle
E2 : {=SUMME((C2:C31="x")*(ISTZAHL(VERGLEICH(B2:B31;Feiertage;0))))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
ransi
Anzeige
Korrektur:
ransi
Hallo
hatte eben den Wochentag() vergessen:
 
 DE
2 1
Formeln der Tabelle
E2 : {=SUMME((C2:C31="x")*(ISTZAHL(VERGLEICH(B2:B31;Feiertage;0)))*(WOCHENTAG(B2:B31;2)<6))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
ransi
Anzeige
AW: Korrektur:
02.04.2006 12:18:03
DieterG.
Halli ransi,
das haut hin!!
Danke
Gruß
Dieter

318 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige