Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
764to768
764to768
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Zählenwenn in Matrix mit Wennfunktion

Zählenwenn in Matrix mit Wennfunktion
22.05.2006 14:33:40
Korl
Hallo,
ich zeige hier mal eine Beispietabelle.
In diesem Beispiel möchte ich folgendes erreichen.
Die gleichen Zahlen in Spalte "A" stellt jeweils eine Gruppe dar.
Nun möchte ich die Spalte "B" mit einer Formel in Spalte "C" auswerten.
Wenn in den einzelnen Gruppen in Spalte "B" der Wert "R" häufige gleich 1 vorkommt,in Spalte "E" die Aussage "gut" angezeigt wird, ist kein Wert "R" vorhanden, dann "schlecht" angezeigt wird.
 
 ABC
1GruppeZählenwenn
21 gut
31R 
41R 
51  
61  
72  
82  
92  
102  
112  
122  
132  
142  
153  
163R 
173  
183  
Formeln der Tabelle
C2 : =WENN(A2<>A1;WENN(ZÄHLENWENN(WENN($A$1:$A$200=A2;$B$1:$B$200);"R")>=1;"gut";"schlecht"))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Ist dies wohl möglich?
Gruß Korl

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Zählenwenn in Matrix mit Wennfunktion
22.05.2006 14:42:46
IngGi
Hallo Korl,
meinst du so?
 
 ABC
21 schlecht
31  
42 gut
52R 
63 schlecht
73  
Formeln der Tabelle
C2 : =WENN(A2=A1;"";WENN(SUMMENPRODUKT(($A$2:$A$7=A2)*($B$2:$B$7="R"))>0;"gut";"schlecht"))
C3 : =WENN(A3=A2;"";WENN(SUMMENPRODUKT(($A$2:$A$7=A3)*($B$2:$B$7="R"))>0;"gut";"schlecht"))
C4 : =WENN(A4=A3;"";WENN(SUMMENPRODUKT(($A$2:$A$7=A4)*($B$2:$B$7="R"))>0;"gut";"schlecht"))
C5 : =WENN(A5=A4;"";WENN(SUMMENPRODUKT(($A$2:$A$7=A5)*($B$2:$B$7="R"))>0;"gut";"schlecht"))
C6 : =WENN(A6=A5;"";WENN(SUMMENPRODUKT(($A$2:$A$7=A6)*($B$2:$B$7="R"))>0;"gut";"schlecht"))
C7 : =WENN(A7=A6;"";WENN(SUMMENPRODUKT(($A$2:$A$7=A7)*($B$2:$B$7="R"))>0;"gut";"schlecht"))
 

Gruß Ingolf
Anzeige
ups ... ich hatte nicht aufgefrischt ... oT
22.05.2006 14:48:57
heikoS
AW: Zählenwenn in Matrix mit Wennfunktion
22.05.2006 14:47:16
heikoS
Hallo Korl,
das sollte so gehen:
=WENN(A1=A2;"";WENN(SUMMENPRODUKT(--($A$2:$A$17=A2);--($B$2:$B$17="R"))&gt0;"gut";"schlecht"))
Formel in C1 und runterkopieren.
Klappt´s?
Gruß Heiko
AW: Zählenwenn in Matrix mit Wennfunktion
22.05.2006 15:17:30
Korl
Hallo Ingolf und Heiko,
vielen Dank erstmal für eure schnelle Reaktion.
Die Formeln sehe jeweils gut aus.
Nun muß ich es nur noch in meine eigentlichen Formel mit
4 Wenn
1 Und
2 Oder
einbinden. ;-)
Wenn ich es geschafft habe, melde ich mich auf jeden Fall nochmal.
Gruß Korl
AW: Zählenwenn in Matrix mit Wennfunktion
22.05.2006 15:51:51
Korl
Hallo Ingolf und Heiko,
ich freue mich riesig, ehrlich!
Mit Eure Formel konnte ich mein eigentliches Ziel erreichen.
Gruß Korl
Anzeige

334 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige