Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
776to780
776to780
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Aufrunden auf bestimmte Endungen

Aufrunden auf bestimmte Endungen
01.07.2006 10:14:18
Berndt
Hallo,
möchte Zahlen von 0,01 - 10 auf 2 Nachkommastellen aufrunden. Diese sollen, wenn Sie Nchkommastellen von x,01 bis x,29 auf x,29, von x,291 bis x,49 auf x,49,von x,491 bis x,79 auf x,79 und von x,791 bis x,99 auf x,99 enden. Von x,991 bis x,999 sollte abgerundet werden.
z. B. endet ein Betrag auf 5,26 soll er automatisch auf 5,29 gerundet werden.
Kann man das mit einer Formel lösen?
Vorab Danke für eure Zeit!
Gruß Berndt

4
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Aufrunden auf bestimmte Endungen
01.07.2006 10:46:47
fcs
Hallo Berndt,

für Zahlen >=0 geht's mit:
=GANZZAHL(A1)+WENN(REST(A1;1)=0;0;WENN(REST(A1;1)<=0,29;0,29;
WENN(REST(A1;1)<=0,49;0,49;WENN(REST(A1;1)<=0,79;0,79;0,99))))
für positive und negative zahlen wird es etwas länger:
=WENN(A1<0;-1;1)*(GANZZAHL(ABS(A1))+WENN(REST(ABS(A1);1)=0;0;
WENN(REST(ABS(A1);1)<=0,29;0,29;WENN(REST(ABS(A1);1)<=0,49;0,49;
WENN(REST(ABS(A1);1)<=0,79;0,79;0,99)))))

mfg
Franz

AW: Aufrunden auf bestimmte Endungen
01.07.2006 13:14:15
Berndt
Hallo Franz,
fantastisch....funktioniert einwandfrei! Auch interessant das mehrere Wege nach Rom führen! Mit der anderen Formel vom anderen Franz funktioniert es ebenso.
Vielen Dank!
Hoffe ich bin nicht unverschämt....gibts noch eine Möglichkeit das man in die Formel folgendes einbaut: Ab 100 Endung auf x,99 und ab 1000 glatt?
Nochmals Vielen Dank!
Gruß Berndt
Anzeige
Vordefinierte Auf/Abrundung
01.07.2006 10:53:48
FP
Hallo Berndt,
für positive Zahlen:
=KÜRZEN(A1)+SVERWEIS(REST(A1;1)*1000;{0.0;1.290;291.490;491.790;791.990;991.990};2;1)/1000
für positive und negative Zahlen:
=KÜRZEN(C1)+VORZEICHEN(C1)*SVERWEIS(REST(ABS(C1);1)*1000;{0.0;1.290;291.490;491.790;791.990;991.990};2;1)/1000
Servus aus dem Salzkammergut
Franz
AW: Vordefinierte Auf/Abrundung
01.07.2006 13:19:34
Berndt
Hallo Franz,
habs gerade dem anderen Franz gemailt, der mir eine andere Formel genannt hat...fantastisch das es sogar mehrere Wege nach Rom gibt! Beide Formeln funktionieren einwandfrei! Vielen dank nochmals!
Frage aber auch bei dir noch mal nach und hoffe ich bin nicht unverschämt....gibts noch eine Möglichkeit das man in die Formel folgendes einbaut: Ab 100 Endung auf x,99 und ab 1000 glatt?
Gruß Berndt
Anzeige

305 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige