Herbers Excel-Forum - das Archiv

Wenn Funktion komme nicht weiter

Bild

Betrifft: Wenn Funktion komme nicht weiter
von: trebor-robert

Geschrieben am: 12.12.2006 10:55:27
Hallo zusammen,
habe folgendes Problem in der Spalte habe ich Werte (beginnend ab Zeile 5) die mit verschiedenen Faktoren multipliziert werden sollen.
Das Ergebnis soll dann in Zellen A5, A6, A7, A8 ausgegeben werden.
Die Faktoren mit denen die Berechung durchgeführt werden soll stehen in den Zellen B1, B2 und B3 (Standartwert in allen 3 Zellen ist immer der Wert 1)
B1 kann sein zwischen 1 und 3 (Kalkulationsfaktor für Kundenindividuellen VK)
B2 kann sein zwischen 0,1 und 1 (EK Berechnung)
B3 kann nur sein 1 oder grösser (VK Berechnung inkl. MwSt)
Es soll folgende Rechnung in A5 gemacht werden, abhängig davon wo ein von dem Stamdart Wert 1 abweichender Wert als Faktor eingegeben wird soll der Wert aus Zelle A5 mit einem der Faktoren aus B1 - B3 multipliziert werden
Ich habe es mit einer Wenn Funktion versucht komme da aber nicht weiter. Geht da vielleicht was mit UND oder ODER?
Bin dankbar für jede Hilfe.
Hintergrund.
Es handelt sich hierbei um eine Basispreisliste, aus der fallweise auf die Schnelle (durch Veränderung der Faktoren) entweder ein Preis inkl. MwSt (Faktor in Zelle B3, ein EK-Preis ohne Mwst (Faktor in Zelle B2) oder ein kundenindividueller Verkaufspreis inkl. MwSt (Faktor in Zelle B1) berechnet werden soll.
Die Reihenfolge welche Faktor zuerst geprüft wird ist eigentlich unerheblich.
Die fertige Formel ist dann in Spalte A runterzuziehn bis unendlich.
Danke für jeden Hinweis (vielleicht sogar eine komplette Formel? ;-) )
trebor-robert
Bild

Betrifft: AW: Wenn Funktion komme nicht weiter
von: Reinhard

Geschrieben am: 12.12.2006 11:35:01
Hi Robert,
k.A. ob ich das verstanden habe:
Tabelle:
[Mappe1]!Tabelle2
│  A  │  B  │  C  │
──┼─────┼─────┼─────┤
1 │ 5,6 │   1 │   7 │
2 │ 6,4 │ 0,8 │   8 │
3 │ 7,2 │   1 │   9 │
4 │   8 │     │  10 │
5 │  80 │     │ 100 │
6 │   0 │     │   0 │
──┴─────┴─────┴─────┘
Benutzte Formeln:
A1:  =WENN($B$1<>1;C1*$B$1;WENN($B$2<>1;C1*$B$2;WENN($B$3<>1;C1*$B$3;"Fehler")))
A2:  =WENN($B$1<>1;C2*$B$1;WENN($B$2<>1;C2*$B$2;WENN($B$3<>1;C2*$B$3;"Fehler")))
A3:  =WENN($B$1<>1;C3*$B$1;WENN($B$2<>1;C3*$B$2;WENN($B$3<>1;C3*$B$3;"Fehler")))
A4:  =WENN($B$1<>1;C4*$B$1;WENN($B$2<>1;C4*$B$2;WENN($B$3<>1;C4*$B$3;"Fehler")))
A5:  =WENN($B$1<>1;C5*$B$1;WENN($B$2<>1;C5*$B$2;WENN($B$3<>1;C5*$B$3;"Fehler")))
A6:  =WENN($B$1<>1;C6*$B$1;WENN($B$2<>1;C6*$B$2;WENN($B$3<>1;C6*$B$3;"Fehler")))

Gruß
Reinhard
ps: Ich freue mich über eine Rückmeldung ob diese Antwort hilfreich war oder nicht..
Bild

Betrifft: AW: Wenn Funktion komme nicht weiter
von: trebor-robert
Geschrieben am: 12.12.2006 13:16:50
Danke für die Antworten,
ist aber nicht ganz das, was mir weiterhillft.
Anbei noch eine Bsp-mappe:
https://www.herber.de/bbs/user/38905.xls
Danke schon vorab für weitere Hilfestellung
Bild

Betrifft: AW: Wenn Funktion komme nicht weiter
von: EtoPHG
Geschrieben am: 12.12.2006 13:20:51
Hallo Robert,
Kannst Du mir erklären, was diese Formel macht ????????????????????
=WENN(B$1>1;B5*B$1;WENN(B$2<1;B5*B$2;B5*B$3))

Gruss Hansueli
Bild

Betrifft: AW: Wenn Funktion komme nicht weiter
von: EtoPHG
Geschrieben am: 12.12.2006 11:38:29
Hallo Robert,
Vielleicht sowas:
=WENN(B$1>1;B5*B$1;WENN(B$2<1;B5*B$2;B5*B$3))

Gruss Hansueli
Bild

Betrifft: AW: Wenn Funktion komme nicht weiter
von: trebor-robert

Geschrieben am: 12.12.2006 16:01:41
Hallo Hansueli,
danke für Deine Postings und sorry ich hatte bei der Übernahme deines ersten Formelvorschlages bei mir eine Fehler gemacht und den nicht bemerkt, daher das neue Posting.
Zwischenzeitlich habe ich das korrigiert und es funktioniert soweit. Es ist aber noch nicht ganz das was ich benötige (ich habe mich aber wohl auch nicht richtig ausgedrückt).
Meine jetzige Formel lautet wie folgt:
WENN(AW$1>1;AW5*AW$1;WENN(AW$2<1;WENN(UND(AW$2<1;AW$1>1);(AW5*AW$2)*AW$1;AW5*AW$2);AW$3*AW5)))
Ich brauche nämlich zusätzlich die Abfrage, wenn in B2 und in B3 abweichende Werte von 1 sind (mal unabhängig davon, daß der eine höher sein muss und der andere niedriger als 1)
daß dann folgende Berechnung durchgeführt werden soll gültig dann für A5
(B5*B2)*B1
ich habe das oben mal in meiner Formel probiert, da ist aber noch der Wurm drin und ich weiss nicht wie, ich den Dreh bekomme, dass es richtig funktioniert. In dieser Formel wird nämlich der UND Bereich nicht mehr berücksicht, da Excel schon das Ergebnis aus dem Formelteil liefert der vorher in der Reihenfolge ist.
Wäre dankbar, wenn Du mir hier noch einmal eine Hilfestellung geben würdest.
danke
trebor-robert
Bild

Betrifft: AW: Wenn Funktion komme nicht weiter
von: EtoPHG
Geschrieben am: 12.12.2006 17:20:52
Hallo Robert,
Na, dann nimmste die UND-Bedingung eben als erste....
=WENN(UND(B$2<1;B$3>1);B5*B$2*B$1;WENN(B$1>1;B5*B$1;WENN(B$2<1;B5*B$2;B5*B$3)))

Gruss Hansueli
Bild

Betrifft: AW: Wenn Funktion komme nicht weiter
von: Reinhard

Geschrieben am: 12.12.2006 18:37:04
Hi Robert,
ich habe sicher nicht alle Kombinationen, auf jeden Fall fehlt noch wenn B1 oder/undB2 oder/und B3 ausserhalb ihrer Werte sind, was soll dann passieren?
Tabelle:
│  A │  B │  C │    D   │
──┼────┼────┼────┼────────┤
1 │ B1 │ B2 │ B3 │        │
2 │  1 │  1 │  1 │ =B1*B5 │
3 │ >1 │  1 │  1 │ =B1*B5 │
4 │ >1 │ <1 │  1 │   ?    │
5 │ >1 │  1 │ >1 │   ?    │
6 │ >1 │ <1 │ >1 │   ?    │
7 │  1 │ <1 │  1 │ =B2*B5 │
8 │  1 │  1 │ >1 │ =B3*B5 │
9 │  1 │ <1 │ >1 │   ?    │
──┴────┴────┴────┴────────┘

Gruß
Reinhard
ps: Ich freue mich über eine Rückmeldung ob diese Antwort hilfreich war oder nicht..
Bild

Betrifft: AW: Wenn Funktion komme nicht weiter
von: trebor-robert

Geschrieben am: 18.12.2006 11:21:17
Hallo Reinhard,
zunächst Danke für dein Posting, auf das ich erst heute wegen fehlendem Onlinezugang zurückkommen kann.
Zu Deiner Tabelle noch einige Anmerkungen. Es gibt einiger der aufgeführten Kombinationen, die ausgeschlossen werden als Eingabekombination. Dies erfolgt mit einem Hinweistext der neben der Zelle steht (ganz ohne Fehlermeldungen oder Programmierung, da dies hierfür zu aufwändig ist) Kobination die nicht möglich sind habe ich mit einem Hinweis unten versehen.
Tabelle:
│ A │ B │ C │ D │
──┼────┼────┼────┼────────┤
1 │ B1 │ B2 │ B3 │ │
2 │ 1 │ 1 │ 1 │ =B5~f~ geändert │
3 │ >1 │ 1 │ 1 │ nicht möglich geändert │
4 │ >1 │ <1 │ 1 │ ~f~=(B2*B5)*B1~f~ geändert │
5 │ >1 │ 1 │ >1 │ nicht möglich(geändert)│
6 │ >1 │ <1 │ >1 │ ~f+~ ((B2*B5)*B1)*B3 ~f~ (geä.)│
7 │ 1 │ <1 │ 1 │ ~f~=B2*B5~f~ (ok) │
8 │ 1 │ 1 │ >1 │ ~f~=B3*B5~f~ (ok) │
9 │ 1 │ <1 │ >1 │nicht möglich (geändert) │
──┴────┴────┴────┴────────┘
Zusätzlich erfolgt ganz am Anfang noch eine Abfrage, die sinngemäss lautet. Wenn in B5 kein Wert enthalten ist, soll in A5 entsprechend leer sein (also "")
Meine derzeitige Formel laute wie folgt (da ist allerdings noch der Wurm drin)
nachfolgend die Formel für A5
~f~
=WENN(B5="";"";WENN(SUMME(B$1:B$3)=3;B5;WENN(UND(B$2<1;B$1>=1);(B5*B$2)*B$1;WENN(B$1>1;B5*B$1;WENN(B$2<1;B$3*B5)))))
Ich wäre dankbar, wenn Du mir einen Lösungsweg aufzeigen könntest, da ich hieran verzweifle.
Danke schon vorab für Deine Hilfe
trebor-robert
 Bild
Excel-Beispiele zum Thema "Wenn Funktion komme nicht weiter"
Funktion ANZAHL2 ohne ausgeblendete Spalten Mit der Indirekt-Funktion auf geschlossene Arbeitsmappe zugreifen
Benutzerdefinierte SVERWEIS-Funktion über mehrere Bereiche Alle Prozeduren und Funktionen auflisten
In Funktionskategorie einordnen Ausgabe einer benutzerdefinierten Funktion in Matrixformel
Benutzerdefinierte Funktion durch Code erstellen und löschen Ermittlung von Entfernungen über benutzerdefinierte Funktion
Handhabung von Arrays in benutzerdefininierten Funktionen Arbeitsmappen-Titel über benutzerdefinierte Funktion