Herbers Excel-Forum - das Archiv

Zellinhalte vergleichen - andere Inhalte addieren

Bild

Betrifft: Zellinhalte vergleichen - andere Inhalte addieren
von: Kay

Geschrieben am: 12.12.2006 11:46:28
Hallo,
ich habe folgendes Problem:
Ich habe in Spalte A unterschiedliche Unternehmen stehen, teilweise nur einmal, teilweise mehrmals. Ich möchte in Spalte G alle Werte (Währung) aus Spalte F addieren, wenn die zugehörigen Zellen in Spalte A den gleichen Unternehmer enthalten. Mit einer WENN- Funktion kann ich leider nicht arbeiten, da ich mit den 7 Argumenten nicht auskomme (100 und mehr Unternehmen). Ich weiß leider nicht, ob es mit Excel überhaupt eine Lösung für mein Problem gibt.
Vielen Dank im Voraus für die Bemühungen sagt Kay aus dem wunderschönen Merseburg.
Bild

Betrifft: AW: Zellinhalte vergleichen - andere Inhalte addie
von: EtoPHG
Geschrieben am: 12.12.2006 11:51:35
Hallo Kay,
Deine Lösung heisst: Menu - Daten - Pivottable
Gruss Hansueli
Bild

Betrifft: AW: Zellinhalte vergleichen - andere Inhalte addieren
von: HermannZ

Geschrieben am: 12.12.2006 11:59:06
Hallo Kay;
oder meinst du das so?????
Beispiel;
Summe
 ABCD
850Summebilden aus Spalte B beim letzten und ersten auftreten des Namens in Spalte A   
851  Ergebnis beimErgebnis beim
852  letzten auftretenersten auftreten
853Meier12 325
854Meier23  
855Schmitz  488
856Meier34  
857Meier45  
858Hansen56 201
859Hansen67  
860Schmitz   
861Hansen78201 
862Meier89  
863Schmitz100  
864Schmitz111  
865Schmitz   
866Meier122325 
867Schmitz133  
868Schmitz144488 
869  Formeln 
870  herunterkopieren 
Formeln der Tabelle
C853 : =WENN(ZÄHLENWENN(A853:$A$868;A853)=1;SUMME(($A$853:$A$868=A853)*($B$853:$B$868));"")
D853 : {=WENN(ZÄHLENWENN($A$853:A853;A853)=1;SUMME(($A$853:$A$868=A853)*($B$853:$B$868));"")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Gruß HermannZ
Bild

Betrifft: AW: Zellinhalte vergleichen - andere Inhalte addieren
von: Christian

Geschrieben am: 12.12.2006 12:01:34
Hallo Kay,
wenn du nur eine begrenzte Menge Unternehmen(Zellinhalten) hast, dann kannst du mit der Formel Summe und Wenn arbeiten.
Wenn du periodisch unterschiedliche Unternehmen auswerten möchtest hilft es dir weniger.
{=Summe(wenn(($A$1:$A$100)=$A1;($F$1:$F$100);""))}
Bitte melde dich, ob du damit klargekommen bist.
Wenn du nur bestimmte Unternehmen auswerten möchtest, geht es auch, wenn du in der Spalte H die Vergleichswerte einträgst. Wichtig ist dabei die geschweifte Klammer die durch gleichtzeitiges Drücken der Tasten "Strg" + "Shift" + "Enter" erhältst.
Christian
 Bild
Excel-Beispiele zum Thema "Zellinhalte vergleichen - andere Inhalte addieren"
Einlesen von Zellinhalten in Variablen Zellinhalte zeilenweise sortieren
Wiederherstellung des alten Zellinhaltes bei unerlaubten Werten Bereiche in Abhängigkeit eines Zellinhaltes drucken
Die tatsächliche Anzeige eines Zellinhaltes per VBA abrufen Zellinhalte in Verbindung mit Variablen in Textdatei schreiben
Zellinhalte aus Einzelblättern in Deckblatt übertragen Excel-Zellinhalte in Worddokument einlesen um per Email versenden
Zellinhalte über VBA verbinden Zellinhalte vor dem Verbinden der Zellen zusammenfassen