Herbers Excel-Forum - das Archiv

Ereignisanzeige in einer Spalte

Bild

Betrifft: Ereignisanzeige in einer Spalte
von: Andreas

Geschrieben am: 12.12.2006 14:10:45
Hallo,
ich bräuchte Hilfe bei folgendem Problem (falls möglich ohne Makro):
In einer Spalte werden Zahlenfolgen aufgenommen. Wenn untereinander mehr als z.B.3 Zahlen stehen soll mir in einer separaten Spalte ein Hinweis ausgegeben werden.
D.h. zwischen den untereinander stehenden Zahlen sind Lücken und das Ereignis soll eben nur angezeigt werden, wenn mehr als 3 ohne Lücke untereinander stehen.
Hilfreich wäre, wenn alle nach 3 Nachfolgenden ebenfalls bezeichnet würden.
Beispiel:
456
65
11111 (hier der Hinweis, evtl.auch für jede weitere Folgende Zahl als Ausgabe z.B. eine 1)
666
989988 (hier nicht, da Lücke folgt)
4577
Vielen Dank für die Hilfe.
Gruß
Andreas
Bild

Betrifft: AW: Ereignisanzeige in einer Spalte
von: EtoPHG
Geschrieben am: 12.12.2006 14:54:12
Hallo Andreas,
In B3 und dann runterkopieren:
=WENN(A1*A2*A3=0;FALSCH();WAHR())

Gruss Hansueli
Bild

Betrifft: AW: Ereignisanzeige in einer Spalte
von: Andreas
Geschrieben am: 12.12.2006 15:23:29
Hallo Hansueli,
da die Spalte sehr viele Werte enthält mit einigen Leerzellen dazwischen, kann ich nicht per Hand nach jeder Leerstelle die Funktion eintragen.
Vieleicht noch eine Idee??
Gruß
Andreas
Bild

Betrifft: AW: Ereignisanzeige in einer Spalte
von: EtoPHG


Geschrieben am: 12.12.2006 15:45:16
Hallo Andreas,
Ich versteh nicht was Du meinst.
Wenn Du die Formel in Spalte B auf B3 kopierst und anschliessend bis ans Ende der Spalte kopierst, erhälst Du bei jeder Zeile in der 2 Vorläufer (Zahlen) in Spalte A existiern den Wert WAHR() ansonsten den Wert FALSCH().
Falls Du statt FALSCH() lieber nichts siehst, ersetze mit:
=WENN(A1*A2*A3=0;"";WAHR())
Gruss Hansueli
Bild

Betrifft: AW: Ereignisanzeige in einer Spalte
von: EtoPHG
Geschrieben am: 12.12.2006 15:45:16
Hallo Andreas,
Ich versteh nicht was Du meinst.
Wenn Du die Formel in Spalte B auf B3 kopierst und anschliessend bis ans Ende der Spalte kopierst, erhälst Du bei jeder Zeile in der 2 Vorläufer (Zahlen) in Spalte A existiern den Wert WAHR() ansonsten den Wert FALSCH().
Falls Du statt FALSCH() lieber nichts siehst, ersetze mit:
=WENN(A1*A2*A3=0;"";WAHR())
Gruss Hansueli
Bild

Betrifft: AW: Ereignisanzeige in einer Spalte
von: Andreas

Geschrieben am: 12.12.2006 16:12:59
Hi Hansueli,
das Problem ist, dass entweder nur 1 Wert, dann Leerzeile und bis zu 30 Werten und dann wieder Leerzeile stehen kann. Deiner Formel fehlt hier die Flexibilität zu erkennen, wieviele Werte stehen.
Ich hoffe das ist verständlicher. Nochmal zum Beispiel:
5465
465613
798215
8646
Leerzelle (hier sollte z.B. 1 oder wahr stehen, da ein Wert mehr als 3)
456
Leerzelle
878956
4
87987
Leerzelle
879643
1387
7892
46546
789451
546876
213548
513878643
548951
Leerzelle (hier sollte 6 stehen oder jeder Wert nach der 3. Zahl mit 1 bewertet werden.
Danke nochmals.
Bild

Betrifft: AW: Ereignisanzeige in einer Spalte
von: EtoPHG
Geschrieben am: 12.12.2006 16:48:44
Hallo Andreas,
Ich hab zwar in der Schule Zählen und das kleine Einmaleins gelernt, aber das übersteigt meinen Horizont bei weitem...
Lass die Frage drum offen!
Hansueli
Bild

Betrifft: AW: Ereignisanzeige in einer Spalte
von: Reinhard

Geschrieben am: 12.12.2006 18:04:39
Hi Andreas,
Tabelle:
│     A     │  B  │
───┼───────────┼─────┤
1 │      5465 │     │
2 │    465613 │     │
3 │    798215 │     │
4 │      8646 │   1 │
5 │           │     │
6 │       456 │     │
7 │           │     │
8 │    878956 │     │
9 │         4 │     │
10 │     87987 │     │
11 │           │     │
12 │    879643 │     │
13 │      1387 │     │
14 │      7892 │     │
15 │     46546 │     │
16 │    789451 │     │
17 │    546876 │     │
18 │    213548 │     │
19 │ 513878643 │     │
20 │    548951 │   6 │
───┴───────────┴─────┘
Bedingte Formatierung in B4:
Formel: =ODER(B5>0;B4=0)
SChriftfarbe weiß
Formatierung mit dem Pinsel nach unten ziehen.
Benutzte Formeln:
B4 :  =WENN(UND(A1<>"";A2<>"";A3<>"";A4<>"");B3+1;0)
B5 :  =WENN(UND(A2<>"";A3<>"";A4<>"";A5<>"");B4+1;0)
B6 :  =WENN(UND(A3<>"";A4<>"";A5<>"";A6<>"");B5+1;0)
B7 :  =WENN(UND(A4<>"";A5<>"";A6<>"";A7<>"");B6+1;0)
B8 :  =WENN(UND(A5<>"";A6<>"";A7<>"";A8<>"");B7+1;0)
B9 :  =WENN(UND(A6<>"";A7<>"";A8<>"";A9<>"");B8+1;0)
B10:  =WENN(UND(A7<>"";A8<>"";A9<>"";A10<>"");B9+1;0)
B11:  =WENN(UND(A8<>"";A9<>"";A10<>"";A11<>"");B10+1;0)
B12:  =WENN(UND(A9<>"";A10<>"";A11<>"";A12<>"");B11+1;0)
B13:  =WENN(UND(A10<>"";A11<>"";A12<>"";A13<>"");B12+1;0)
B14:  =WENN(UND(A11<>"";A12<>"";A13<>"";A14<>"");B13+1;0)
B15:  =WENN(UND(A12<>"";A13<>"";A14<>"";A15<>"");B14+1;0)
B16:  =WENN(UND(A13<>"";A14<>"";A15<>"";A16<>"");B15+1;0)
B17:  =WENN(UND(A14<>"";A15<>"";A16<>"";A17<>"");B16+1;0)
B18:  =WENN(UND(A15<>"";A16<>"";A17<>"";A18<>"");B17+1;0)
B19:  =WENN(UND(A16<>"";A17<>"";A18<>"";A19<>"");B18+1;0)
B20:  =WENN(UND(A17<>"";A18<>"";A19<>"";A20<>"");B19+1;0)

Gruß
Reinhard
ps: Ich freue mich über eine Rückmeldung ob diese Antwort hilfreich war oder nicht..
 Bild
Excel-Beispiele zum Thema "Ereignisanzeige in einer Spalte"
Vorkommen von Zahlenreihen in Spalten Funktion ANZAHL2 ohne ausgeblendete Spalten
Spaltenbreite anpassen Spalten einer Mehrbereichsauswahl ausblenden.
Spaltennamen bestimmen Spalten/Zeilen aus- und einblenden
Zeilen und Spalten über ein Drehfeld ein- und ausblenden In einem Dialog ausgewählte Spalten drucken
Spalten bedingt summieren und Zellen formatieren Abfrage der markierten Spalten