Herbers Excel-Forum - das Archiv

Summenprodukt mit vielen Kritierien - Ergänzung

Bild

Betrifft: Summenprodukt mit vielen Kritierien - Ergänzung
von: Basti

Geschrieben am: 15.12.2006 11:35:42
hallo,
ich habe folgendes problem und weiß noch nicht wie ich es lösen kann:
in einer spalte stehen typen, bspw. M51, M20, M24, E38 usw. in einer zugehörigen zelle bzw. spalte noch deren kw. siehe beispiel.
https://www.herber.de/bbs/user/39025.xls
mein problem ist nun die anzahl anhand der verschiedenen kriterien zu berechnen, so wie ich es in der beispielmappe beschrieben habe.
vielen dank schon mal für eure antworten und liebe grüße,
basti
Bild

Betrifft: AW: Summenprodukt mit vielen Kritierien - Ergänzung
von: heikoS
Geschrieben am: 15.12.2006 11:56:23
Hallo Basti,
diese Formel in Zelle c21 und runterkopieren:
=SUMMENPRODUKT(($B$5:$B$16={"M20"."M24"."M51"})*($D$5:$D$16="x")*($C$5:$C$16="c")*($A$5:$A$16<=B21))
Klappt´s?
Gruß Heiko
Bild

Betrifft: AW: Summenprodukt mit vielen Kritierien - Ergänzung
von: Basti
Geschrieben am: 15.12.2006 12:19:07
hallo, und danke erst mal, nein klappt leider noch nicht. wo summierst du denn auch die jeweiligen anzahlen von spalte E???
grüße
Bild

Betrifft: AW: Summenprodukt mit vielen Kritierien - Ergänzung
von: heikoS
Geschrieben am: 15.12.2006 12:26:08
Hallo Basti,
ups, die Spalte E hatte ich nicht beachtet:
=SUMMENPRODUKT(($B$5:$B$16={"M20"."M24"."M51"})*($D$5:$D$16="x")*($C$5:$C$16="c")*($A$5:$A$16<=B21)*$E$5:$E$16)
Und jetzt?
Gruß Heiko
Bild

Betrifft: hab es selber danke!!!
von: Basti
Geschrieben am: 15.12.2006 12:24:48
o.t.
 Bild