Herbers Excel-Forum - das Archiv

Liste erzeugen

Bild

Betrifft: Liste erzeugen
von: Michael

Geschrieben am: 19.12.2006 14:54:27
Hallo Excel-User,
ich habe folgendes Problem:
Ich habe eine Urlaubsdatei, die wie folgt aufgebaut ist.
Tabellenblatt1: Nr.|Personal-nr.|Name|Urlaub alt|Urlaub neu| Urlaub gesamt
Blätter 2 - 13: jeweils ein Monat, wo die Urlaubstage eingetragen werden
Blatt14: Auswertung
Nun sollen auch noch EDV-Schulungen eingetragen werden.
Mein Problem ist nun, dass nicht jeder Mitarbeiter EDV Schulungen bekommt. So habe ich in Blatt1 noch eine Spalte eingefügt mit dem Kennzeichen "E" um die Leute zu kennzeichnen, die Schulungen erhalten dürfen.
Auf einem separatem Tabellenblatt15 habe ich nun folgende Auswertung aufgebaut:
Personal-nr(aus Blatt1 - mit sverweis über Kennzeichen"E")|Name (mit sverweis aus Blatt1)|Januar|Februar|März ... |Dezember (die Daten aus den Blättern2-13).
Nun besteht mein Problem darin, dass ich mit dem Kennzeichen zwar die Daten in Blatt15 bekomme, aber nun ist die erste Zeile gefüllt, dann 4 leer und dann wieder 2 gefüllt und dann wieder 8 leer usw. Wie bekomme ich die einzelnen Daten jetzt automatisch untereinander, ohne die Leerzeilen dazwischen?
Die Namen fest einzutragen bringt nichts, da die Mitarbeiter im Wechsel die Schulungen erhalten werden.
Vielen Dank im Voraus
Michael
Bild

Betrifft: AW: Liste erzeugen
von: jockel

Geschrieben am: 19.12.2006 15:45:28
hi Michael, ist es dir möglich eine (beispiel)datei ins forum zu stellen? ansonsten kann man nur mutmaßen. das ergebnis, was du erhälst mit leerzellen könntest du ja als hilfsspalte nehmen und z.b. das hier: http://www.excelformeln.de/formeln.html?welcher=43 anwenden.
cu jörg
Bild

Betrifft: AW: Liste erzeugen
von: Michael

Geschrieben am: 19.12.2006 16:49:16
Hallo Jörg,
das ist genau das was ich suchte, aber leider bekomme ich dauernd die Fehlermeldung #Zahl
Da meine Daten in Spalte S stehen und ich 200 Zeilen habe, habe ich die Formel wie folgt umgebaut:
=WENN(ZEILE(S2)>ANZAHL(S:S);"";INDEX(S:S;KKLEINSTE(WENN(S$2:S$200<>"";ZEILE($2:$200));ZEILE(S2)))
In Spalte S stehen auch nur Zahlen und die Daten beginnen in Zeile 2, vielleicht hat es damit etwas zu tun.
Vielleicht könntest du noch einmal drüber schauen.
Vielen Dank
Michael
Bild

Betrifft: AW: Liste erzeugen
von: jockel

Geschrieben am: 19.12.2006 17:49:06
hi Michael, ich habs gerade noch mal ausprobiert die formel ist so einzugeben wie dort steht. also
=WENN(ZEILE(A1)>ANZAHL2(A:A);"";INDEX(A:A;KKLEINSTE(WENN(A$1:A$1000<>"";ZEILE($1:$1000));ZEILE(A1)))) und mit strg+umsch+enter (wegen array-formel) abschließen; egal, wo die liste beginnt... also nicht schreiben Zeile(A2) oder WENN(A$2:A$1000...
cu jörg vielleicht bis später, ich muss jetzt erstmal weg...
Bild

Betrifft: AW: Liste erzeugen
von: jockel

Geschrieben am: 19.12.2006 20:06:01
hi Michael, guckst du hier:
Tabelle1
 PQRSTU
1Cognac     Cognac
2Calvados     Calvados
3Rotwein   Cognac  Rotwein
4Bier     Bier
5Ratzeputz     Ratzeputz
6Vollrausch    Vollrausch
7Bier  Calvados  Bier
8Wein    Wein
9Cognac   Rotwein  Cognac
10Calvados   Bier  Calvados
11Rotwein     Rotwein
12Bier     Bier
13Ratzeputz     Ratzeputz
14Vollrausch  Ratzeputz  Vollrausch
15Bier    Bier
16Wein    Wein
17   Vollrausch  
18      
19      
20   Bier  
21      
22      
23      
24   Wein  
25      
26      
27      
28   Cognac   
29      
30      
31      
32   Calvados   
33      
34   Rotwein   
35   Bier   
36      
37      
38      
39   Ratzeputz   
40      
41      
42   Vollrausch  
43      
44      
45   Bier  
46      
47      
48      
49   Wein  
Formeln der Tabelle
P1 : {=WENN(ZEILE(S1)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S1))))}
U1 : {=WENN(ZEILE(S1)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S1))))}
P2 : {=WENN(ZEILE(S2)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S2))))}
U2 : {=WENN(ZEILE(S2)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S2))))}
P3 : {=WENN(ZEILE(S3)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S3))))}
U3 : {=WENN(ZEILE(S3)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S3))))}
P4 : {=WENN(ZEILE(S4)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S4))))}
U4 : {=WENN(ZEILE(S4)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S4))))}
P5 : {=WENN(ZEILE(S5)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S5))))}
U5 : {=WENN(ZEILE(S5)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S5))))}
P6 : {=WENN(ZEILE(S6)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S6))))}
U6 : {=WENN(ZEILE(S6)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S6))))}
P7 : {=WENN(ZEILE(S7)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S7))))}
U7 : {=WENN(ZEILE(S7)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S7))))}
P8 : {=WENN(ZEILE(S8)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S8))))}
U8 : {=WENN(ZEILE(S8)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S8))))}
P9 : {=WENN(ZEILE(S9)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S9))))}
U9 : {=WENN(ZEILE(S9)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S9))))}
P10 : {=WENN(ZEILE(S10)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S10))))}
U10 : {=WENN(ZEILE(S10)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S10))))}
P11 : {=WENN(ZEILE(S11)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S11))))}
U11 : {=WENN(ZEILE(S11)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S11))))}
P12 : {=WENN(ZEILE(S12)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S12))))}
U12 : {=WENN(ZEILE(S12)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S12))))}
P13 : {=WENN(ZEILE(S13)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S13))))}
U13 : {=WENN(ZEILE(S13)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S13))))}
P14 : {=WENN(ZEILE(S14)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S14))))}
U14 : {=WENN(ZEILE(S14)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S14))))}
P15 : {=WENN(ZEILE(S15)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S15))))}
U15 : {=WENN(ZEILE(S15)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S15))))}
P16 : {=WENN(ZEILE(S16)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S16))))}
U16 : {=WENN(ZEILE(S16)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S16))))}
P17 : {=WENN(ZEILE(S17)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S17))))}
U17 : {=WENN(ZEILE(S17)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S17))))}
P18 : {=WENN(ZEILE(S18)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S18))))}
U18 : {=WENN(ZEILE(S18)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S18))))}
P19 : {=WENN(ZEILE(S19)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S19))))}
U19 : {=WENN(ZEILE(S19)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S19))))}
P20 : {=WENN(ZEILE(S20)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S20))))}
U20 : {=WENN(ZEILE(S20)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S20))))}
P21 : {=WENN(ZEILE(S21)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S21))))}
U21 : {=WENN(ZEILE(S21)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S21))))}
P22 : {=WENN(ZEILE(S22)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S22))))}
U22 : {=WENN(ZEILE(S22)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S22))))}
U23 : {=WENN(ZEILE(S23)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S23))))}
U24 : {=WENN(ZEILE(S24)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S24))))}
U25 : {=WENN(ZEILE(S25)>ANZAHL2(S$1:S$1000);"";INDEX(S$1:S$1000;KKLEINSTE(WENN(S$3:S$1000<>"";ZEILE($3:$1000));ZEILE(S25))))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Bild

Betrifft: AW: Liste erzeugen
von: michael
Geschrieben am: 20.12.2006 08:37:24
Hallo Jörg,
funktioniert prima. Vielen, Vielen Dank und Frohe Weihnachten und einen Guten Rutsch.
Michael
 Bild
Excel-Beispiele zum Thema "Liste erzeugen"
Laufschrift erzeugen ComboBoxes per VBA-Code in Tabellenblatt erzeugen
Beim Öffnen zweites Fenster erzeugen und anordnen