Herbers Excel-Forum - das Archiv

Datum nach Tage auf die Monate verteilen

Bild

Betrifft: Datum nach Tage auf die Monate verteilen
von: Andre

Geschrieben am: 21.12.2006 13:13:32
Hallo zusammen,
ich komme leider nicht auf eine schöne Formel, in der ich die Tage auf Monate aufteilen kann.
Wie kann ich bei einem Anfangsdatum und einem Enddatum eine Formel verwenden um die Tage für alle Monate anzeigen zu lassen die enthalten sind.
Anfangsdatum Enddatum Januar Februar März
01.01.2007 27.03.2007 31 Tage 28 Tage 27 Tage
Hintergrund für die Berechnung ist eine Berechnung für den fehlenden Aufwand auf Tagesbasis.
Falls ihr mehr Input benötigt, lasst es mich wissen.
Gruss
Andre
Bild

Betrifft: AW: Datum nach Tage auf die Monate verteilen
von: haw

Geschrieben am: 21.12.2006 14:34:53
Hallo Andre,
eine Möglichkeit:
(hier im Büro funktioniert der Upload nicht)
Formeln in der Tabelle:
A2 Anfangsdatum
A3 Enddatum
B1 =A2
B2 =WENN(MONATSENDE($A$2;0)<$A$3;TAG(MONATSENDE(A2;0))-TAG(A2)+1;TAG(A3)-TAG(A2)+1)
C1 =WENN(DATUM(JAHR(B1);MONAT(B1)+1;1)<$A$3;DATUM(JAHR(B1);MONAT(B1)+1;1);"")
C2 =WENN(C1="";"";WENN(MONAT(C1)=MONAT($A$3);TAG($A$3);TAG(MONATSENDE(DATUM(JAHR($A$2);MONAT($A$2)+SPALTE(A1);1);0))))
D1 =WENN(DATUM(JAHR(C1);MONAT(C1)+1;1)<$A$3;DATUM(JAHR(C1);MONAT(C1)+1;1);"")
D2 =WENN(D1="";"";WENN(MONAT(D1)=MONAT($A$3);TAG($A$3);TAG(MONATSENDE(DATUM(JAHR($A$2);MONAT($A$2)+SPALTE(B1);1);0))))
E1 =WENN(D1="";"";WENN(DATUM(JAHR(D1);MONAT(D1)+1;1)<$A$3;DATUM(JAHR(D1);MONAT(D1)+1;1);""))
E2 =WENN(E1="";"";WENN(MONAT(E1)=MONAT($A$3);TAG($A$3);TAG(MONATSENDE(DATUM(JAHR($A$2);MONAT($A$2)+SPALTE(C1);1);0))))
F1 =WENN(E1="";"";WENN(DATUM(JAHR(E1);MONAT(E1)+1;1)<$A$3;DATUM(JAHR(E1);MONAT(E1)+1;1);""))
F2 =WENN(F1="";"";WENN(MONAT(F1)=MONAT($A$3);TAG($A$3);TAG(MONATSENDE(DATUM(JAHR($A$2);MONAT($A$2)+SPALTE(D1);1);0))))
G1 =WENN(F1="";"";WENN(DATUM(JAHR(F1);MONAT(F1)+1;1)<$A$3;DATUM(JAHR(F1);MONAT(F1)+1;1);""))
G2 =WENN(G1="";"";WENN(MONAT(G1)=MONAT($A$3);TAG($A$3);TAG(MONATSENDE(DATUM(JAHR($A$2);MONAT($A$2)+SPALTE(E1);1);0))))
H1 =WENN(G1="";"";WENN(DATUM(JAHR(G1);MONAT(G1)+1;1)<$A$3;DATUM(JAHR(G1);MONAT(G1)+1;1);""))
H2 =WENN(H1="";"";WENN(MONAT(H1)=MONAT($A$3);TAG($A$3);TAG(MONATSENDE(DATUM(JAHR($A$2);MONAT($A$2)+SPALTE(F1);1);0))))
I1 =WENN(H1="";"";WENN(DATUM(JAHR(H1);MONAT(H1)+1;1)<$A$3;DATUM(JAHR(H1);MONAT(H1)+1;1);""))
I2 =WENN(I1="";"";WENN(MONAT(I1)=MONAT($A$3);TAG($A$3);TAG(MONATSENDE(DATUM(JAHR($A$2);MONAT($A$2)+SPALTE(G1);1);0))))
J2 =WENN(J1="";"";WENN(MONAT(J1)=MONAT($A$3);TAG($A$3);TAG(MONATSENDE(DATUM(JAHR($A$2);MONAT($A$2)+SPALTE(H1);1);0))))
usw.
Gruß Heinz
Bild

Betrifft: AW: Datum nach Tage auf die Monate verteilen
von: HermannZ

Geschrieben am: 21.12.2006 14:52:14
Hallo Andre;
ein Beispiel;
Nettoarbeit
 LMNOPQRSTUVWXY
16Wieviele Tage des Datums von bis sind in welchem Monat             
17              
18Datum Tage pro Monat           
19vonbisJanFebMrzAprMaiJunJulAugSepOktNovDez
2001.01.200615.05.20063128313015       
2115.05.200608.10.2006    17303131308  
22              
Formeln der Tabelle
N19 : =DATUM(JAHR(HEUTE());SPALTE(A$1);1)
N20 : =WENN(UND(MONAT($L20)<=MONAT(N$19);MONAT($M20)>=MONAT(N$19));MAX(0;(MIN($M20;DATUM(JAHR(N$19);MONAT(N$19)+1;0))-MAX($L20;N$19)+1));"")
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
PS: erste Formel nach rechts kopieren.
zweite Formel nach rechts und nach unten kopiert werden.
Gruß HermannZ
Bild

Betrifft: AW: Datum nach Tage auf die Monate verteilen
von: Andre

Geschrieben am: 21.12.2006 16:13:38
Hallo HermannZ,
vielen Dank für deine Super Hilfe. Ich bin echt sprachlos, ich habe jetzt nur noch zwei Fragen.
1. Frage
Ich verstehe die erste Formel nicht
N19 : =DATUM(JAHR(HEUTE());SPALTE(A$1);1)
brauche ich die Formel zur Berechnung?
2. Frage
Ich habe manche Rechnungen die über ein Jahr laufen, also z.B.
01.01.06 bis 01.05.07
Aber die Formel hört im Mai auf, da er das Jahr nicht berücksichtigt, wie kann man das ändern?
Gruss
Andre
Bild

Betrifft: AW: Datum nach Tage auf die Monate verteilen
von: HermannZ

Geschrieben am: 21.12.2006 16:46:34
Hallo Andre;
zu 1. nein brauchst du nicht.
zu 2. neues Beispiel;
DatumZeitMuster
 ABCDEFGHIJKLMNOPQRSTUVW
2868Ein Datumsbereich auf die entsprechenden Monate aufteilen                      
2869                       
2870                       
2871Datum:  Monate                   
2872vonbis Jan 05Feb 05Mrz 05Apr 05Mai 05Jun 05Jul 05Aug 05Sep 05Okt 05Nov 05Dez 05Jan 06Feb 06Mrz 06Apr 06Mai 06   
287301.01.200502.05.2006 312831303130313130313031312831302   
2874                       
2875                       
Formeln der Tabelle
D2872 : =A2873
E2872 : =WENN(D2872="";"";WENN(DATUM(JAHR(D2872);MONAT(D2872)+1;TAG($A$2873))<$B$2873;DATUM(JAHR(D2872);MONAT(D2872)+1;TAG($A$2873));""))
D2873 : =MAX(0;MIN(E$2872;$B2873+1)-MAX(D$2872;$A2873))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Gruß HermannZ
Bild

Betrifft: AW: Datum nach Tage auf die Monate verteilen
von: Andre
Geschrieben am: 21.12.2006 17:32:05
Hallo HermannZ,
vielen vielen Dank für deine Hilfe. Fange bereits an die Tabelle aufzubauen, aber ohne dich hätte ich es nicht geschafft.
Ich wünsche dir und deiner Familie schöne Weihnachten und einen gute Rutsch.
Gruss
Andre
Bild

Betrifft: AW: Danke für die Rückantwort.........mT.
von: HermannZ
Geschrieben am: 21.12.2006 17:35:23
Hallo Andre;
Ich wünsche dir und deiner Familie ebenfalls schöne Weihnachten und einen guten Rutsch.
Gruß HermannZ
Bild

Betrifft: AW: Datum nach Tage auf die Monate verteilen
von: Andre

Geschrieben am: 21.12.2006 16:21:17
Hallo HermannZ,
vielen Dank für deine Super Hilfe. Ich bin echt sprachlos, ich habe jetzt nur noch zwei Fragen.
1. Frage
Ich verstehe die erste Formel nicht
N19 : =DATUM(JAHR(HEUTE());SPALTE(A$1);1)
brauche ich die Formel zur Berechnung?
2. Frage
Ich habe manche Rechnungen die über ein Jahr laufen, also z.B.
01.01.06 bis 01.05.07
Aber die Formel hört im Mai auf, da er das Jahr nicht berücksichtigt, wie kann man das ändern?
Gruss
Andre
 Bild
Excel-Beispiele zum Thema "Datum nach Tage auf die Monate verteilen"
Datumsdifferenz in der Form "12 Jahre, 3 Monate, 4 Tage" Dynamischer Kalender mit Jahr, Quartal und Monaten
Jahre, Monate und Tage von Zeiträumen ermitteln Zählen von Jahren, Monaten, Tagen, Stunden, Minuten, Sekunden
Textreihe auf mehrere Spalten mit fester Seitenlänge verteilen Tabellenwerte nach Kriterien auf Arbeitsblätter verteilen
Wertereihe nach dem Zufallsprinzip auf 4 Spalten verteilen Buchungsliste in Arbeitsmappe mit anzulegenden Konten verteilen
Daten aus Tagesliste auf Tagesblätter verteilen Werte nach Kriterien prüfen und auf Blätter verteilen